Bluescreen during shutdown when TVService.exe is active (1 Viewer)

badboyxx

Portal Pro
June 15, 2012
728
97
Home Country
Germany Germany
I get always a blue screen when I shutdown my pc. When I deactivate the service TVService.exe then everything is ok. My DB has no failure. I'm using Win7 x64 with MP 1.3 final. I think this problem appears since I have installed MP 1.3 final. Do you need some files, logs or something else?
 

badboyxx

Portal Pro
June 15, 2012
728
97
Home Country
Germany Germany
Ok at least I could solve the problem myself. If someone else has this problem too then perhaps this could help.
- in windows services I killed the process TVService and shut the pc down. If no bluescreen appears, then you have the same problem and should do this:

- create a new .txt-file in the directory where you want and call it whatever you want
- open the .txt-file and write the following text
net stop "TVService"
- rename the suffix of the file to .bat
- open the prompt and type gpedit.msc and hit enter
- go to Computerconfiguration --> Windows Settings --> Scripts
- in the right window double click on shutdown
- click on add and then search
- select the path to your.bat-file and click ok

When you reboot your system the bluescreen should be away.
 

mm1352000

Retired Team Member
  • Premium Supporter
  • September 1, 2008
    21,577
    8,224
    Home Country
    New Zealand New Zealand
    Though BSODs can be triggered by program behaviour, they are usually an indication of driver or hardware issues.
    If this script is solving the problem then it sounds like Windows was shutting down without stopping the TV service... which would be very unusual.
     

    badboyxx

    Portal Pro
    June 15, 2012
    728
    97
    Home Country
    Germany Germany
    I don't know wether the service should stop when MePo is closing. I think that my system had a problem and never stoped the service before shutdown.
     

    mm1352000

    Retired Team Member
  • Premium Supporter
  • September 1, 2008
    21,577
    8,224
    Home Country
    New Zealand New Zealand
    I don't know wether the service should stop when MePo is closing.
    I can confirm - it shouldn't. MP and TV Server are independent in this regard.

    I think that my system had a problem and never stoped the service before shutdown.
    I agree, and this is not normal.
     

    Users who are viewing this thread

    Top Bottom