Brisbane - TV Guide doesn't look at timezone information (1 Viewer)


Portal Pro
July 25, 2005
Home Country
I'm having an issue with timezone processing in the Guide.

I live in Brisbane, where I use tvxb to extract free to air guide information (correct for my timezone) and Cable guide which is 1 hour different. I have set up tvxb to attempt to offset the cable channels by 1 hour from my other channels, but no matter what I do, the timezone does not seem to offset the timing of these channels relative to the other channels.

I have the "use Timezone from XMLTV file" checkbox set in the program guide setup, but no go.

For example, my XMLTV output for a FTA channel is;

- <programme start="200510300900 +1000" stop="200510301000 +1000" channel="free.Brisbane.7digital">
<title lang="en">Jetix</title>

then I have a cable channel setup with a different offset;

- <programme start="200510300900 +1100" stop="200510301000 +1100" channel="optus.Brisbane.TheComedyChannel">
<title lang="en">The Chris Isaak Show</title>

However in the guide the two shows run from 9 - 10 AM, even though the cable show is set with a different offset.

My system is setup for brisbane time, GMT+10, no daylight saving.

I have tried all manner of things;

- Remove the space between the time and the offset
- Try different offsets, they all seem to be ignored.

Unfortunately I cannot use the fixed offset mechanism in the Guide setup, as I need to offset only some of my channels, not all.

Has anyone ever tried to use tvguide with channels that have different timezone offsets ?

Area: Media Portal Program - Power scheduler / Blue two skin
MP Version: 0.1.3 - LAST CVS release
Skin: Blue Two
Windows Version: Windows XP SP2
CPU Type: Intel P4 2.8GHz
Memory: 512 MB generic PC3200
Motherboard Chipset: ASUS P4P800 - Intel 865G
Video Card: HIS Excalibur Radeon 9200
Video Card Driver: Catalyst 5.7
Video Render Type: VMR9
Video Codec Type & Version: mpeg2dec
Audio Codec Type & Version: MPEG/AC3/DTS/LPCM Audio Decoder
TV Card: DNTV Live
TV Card Driver: Latest
TV Card Type: DVB
TV Card: Hauppauge 150MCE
TV Card Driver: Latest
TV Card Type: hardware
Optional Log:


Portal Pro
June 26, 2005
Perth, Australia
Interesting problem... I just played around with this a bit. It seems that MediaPortal doesn't want to read the timezone information from the XML file, even with that option ticked.

Anyway, I've found a way around the problem for you. Add the line "special=utctime" (without the quotes) to the heading section of your tvxb.ini file (before it starts listing the channels) - this will incorporate the timezone settings for each channel & convert all program times to Greenwich Mean Time. Then go into the program guide section of MediaPortal setup & set the 'compensate time zone' setting to 10 hours. It's probably a good idea to remove all the programs from the TV guide database as well, to clear out the old information.

When you go back into MediaPortal's TV guide, the times should be ok...




Portal Pro
July 25, 2005
Home Country
Now that is thinking out of the box... thanks heaps for that.

I have run a capture and can see that the offset is now applied to the timestamp, rather than just by the addition of the suffix.

I'm recording a program at the moment, so can't reload my program guide, but based on the xmltv output I'd say this should work a treat. The output is actually the local time of the program suffixed with UTC, so I think if I import it with the timzeone information ignored, it should be enough without needing to apply the offset, as the timestamp as it appears in the xmltv file is actually the correct time.

Thanks again heaps for the help.

I'll post an update later when I get a chance to reload the guide

Users who are viewing this thread

Top Bottom