Bug is back again: wrong date-sorting with recordings (1 Viewer)

kkendall

Portal Pro
April 24, 2007
864
16
40
Gouda
Netherlands Netherlands
TV-Server Version:
MediaPortal Version: MP/TVserver 1.0
MediaPortal Skin: Blue3 Wide
Windows Version: Vista SP1
CPU Type: Intel Core 2 Duo E6750 775 1333FSB 2.66Ghz 4MB
HDD: 2x Samsung spinpoint 500GB
Memory: 2x Kingston DDR2 ValueRAM 1GB 667 CL5.0
Motherboard: Asus P5K
Video Card: NVIDIA 9600
Video Card Driver:
Sound Card:
Sound Card AC3: AC3 and DTS: S/PDIF
Sound Card Driver: latest
1. TV Card: FloppyDTV
1. TV Card Type: DVB-C
1. TV Card Driver: latest
2. TV Card: Hauppauge PVR500
2. TV Card Type: analog
2. TV Card Driver: latest
3. TV Card:
3. TV Card Type:
3. TV Card Driver:
4. TV Card:
4. TV Card Type:
4. TV Card Driver:
MPEG2 Video Codec: PowerDVD 8
MPEG2 Audio Codec:
h.264 Video Codec: PowerDVD 8
Satelite/CableTV Provider: CAIWAY
HTPC Case: Silverstone LC17b
Cooling: fans
Power Supply: ANTEC
Remote: Microsoft MCE 2005 remote
TV: Panasonic TH-42PZ85
TV - HTPC Connection: DVI-HDMI

The bug that makes recordings show the wrong latest date is back again :(

Description:
In the recording section, multiple recordings of the same show are shown in a folder.
When you set the recording section to "sorting by date", not the most recent date of the recordings in the folder is shown but the oldest, resulting in a wrong sorting of the folders and recordings...

This has been a bug earlier that was resolved...unfortunately it is back again in the final 1.0 release :mad:
 

ronilse

Retired Team Member
  • Premium Supporter
  • July 19, 2005
    4,422
    282
    Moss
    Norway Norway
    Country flag
    Hi,
    Click the small arrow behind search order option to invert search order

    Regards
    Roy
     

    kkendall

    Portal Pro
    April 24, 2007
    864
    16
    40
    Gouda
    Netherlands Netherlands
    Hi,
    Click the small arrow behind search order option to invert search order

    Regards
    Roy
    Offcourse I know how that works and I wish that was it :(
    But it isn't. :p
    Let me explain it again:
    When tv is recorded it the recording goes to the recordings section.
    The list of recordings makes folders of all recordings with the same name.
    So after a while you get a list of folders and files.
    Now, If I choose to order the recordings from old to new or from new to old, MP always takes the OLDEST file of the folder and uses that for the date of that folder to sort in the recordings list.

    I hope it's understandable this time...It's hard to explain, just try it out:
    make 2 recordings of the same show on 2 different dates. MP always uses the oldest date for sorting.

    In my case I want my recordings to be sorted from newest to oldest. Now the folders with the most recent files in it should appear on top of the list...but it doesn't. The folder with the oldest file in it always appears on top, no matter how i set the little arrow! :s

    EDIT: to make it more clear to you: The sorting 'on the highest level' goes ok, but the dates used of the files in the (sub)folders are wrong(always the oldest date). So if i have 3 recordings of say Knightrider: 1, 3 and 5 december. The sorting will always use december 1st for the date of the folder.
     

    ronilse

    Retired Team Member
  • Premium Supporter
  • July 19, 2005
    4,422
    282
    Moss
    Norway Norway
    Country flag
    Hi,
    Just to follow up, have you tested with latest SVN if it's still the same.
    Here even subfolders it's sorted, or do you mean that it doesn't update folders date sice it was created(because that would mean, not show the folder date as top date but last file created as top date)?

    Regards
    Roy
     

    kkendall

    Portal Pro
    April 24, 2007
    864
    16
    40
    Gouda
    Netherlands Netherlands
    Hi,
    Just to follow up, have you tested with latest SVN if it's still the same.
    No, I'd like to stick with the official releases for now. I'm just reporting on the official releases, not SVN's.
    Here even subfolders it's sorted, or do you mean that it doesn't update folders date sice it was created(because that would mean, not show the folder date as top date but last file created as top date)?
    Exactly! The first (oldest) file created in the subfolder is the date used as folderdate :(
    So it doesn't update folder dates (if you leave the oldest file in there), once it is created. What it actually should show is offcourse the date of the most recent file created, not the oldest.
    In other words, the folder should always show the date of the last file created as top date.
    Otherwise you can never know what folders have new recordings.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    R Bug: Video Folders disappear General Support 11
    catalpa Bug MP2-837 Allgemeines Support- und Diskussionsforum 2
    framug [Approved] Fix Irtrans config bug Submit: code patches (MediaPortal/TV-Server/etc.) 4
    ge2301 Bugs and Improvements Nereus 6
    N [Finished] Focus problems - I think I've found the bug MediaPortal 2 30
    Scheibes [solved] Kategorisierung der Genres (Bug?) Allgemeines Support- und Diskussionsforum 13
    joecrow 3 Bugs in MP 1.21 1.21 5
    dcapslock TV Server xmltv IWakeupHandler Bug Television (MyTV frontend and TV-Server) 6
    rsbrux Various bugs, some Zombies ;-) 1.20 6
    J [solved] Mp 2.2 future bugs General 7
    S [MP2-768] Installation Setup Failed - Error 0x80070666 - VC++ 2015/2017 Redist bug 2.2 Archive 19
    D MP2.2: Possible bugs 2.2 Archive 20
    R Jira bug exposed private server keys at major companies Developer Discussions 1
    R Minor bug in recorded TV list Watch / Listen Media 0
    P MP2 - V2.1 Bug - Onlinevideos U.S. Amazon Prime Fails to Connect Older releases 5
    H Unable to play stream - again... Television (MyTV frontend and TV-Server) 2
    pur_berger Again ... fun with Elgato Eye TV Watch / Listen Media 0
    Glith Audio out of sync after pause. Rewind 15sec gets it into sync again. MediaPortal 1 Talk 0
    T [solved] "Unable To Play" (Videos) rears it's head again. Logs not possible... WatchDog error attached!! :( General Support 1
    J Trying out MP 1 again, have some questions and a few log files Newcomers Forum 5
    GhoSe Back again! Team Lounge 20
    W Need help getting my TV guide working again General Support 1
    M [solved] IMDB script broken again General Support 67
    horned_reaper 1.25.0 Wrong processing of / character in artist name ID3 tag Bugreports 5
    M 1.25.0 Wrong signal strenth with Digital Devices Max M4 and CineS2 TV-Server 0
    Top Bottom