BUG - Problem with FM radio scan in TV server (1 Viewer)


MP Donator
  • Premium Supporter
  • November 8, 2007
    Home Country
    Canada Canada
    TV-Server Version: 1.0 Final w/ SVN 22162
    MediaPortal Version: 1.0 Final w/ SVN 22162
    MediaPortal Skin: Blue3 Wide
    Windows Version: Windows Vista
    CPU Type: Intel Q8200
    HDD: 120G
    Memory: 2G
    Motherboard: Gigabyte EP45-UD3R
    Video Card: Radeon 3450
    Video Card Driver: 8.12
    Sound Card: Integrated
    Sound Card AC3: Optical
    Sound Card Driver:
    1. TV Card: digiwave 103g
    1. TV Card Type: DVB-S
    1. TV Card Driver:
    2. TV Card: Hauppauge HVR-2250
    2. TV Card Type: dual-ATSC
    2. TV Card Driver:
    3. TV Card: Hauppauge PVR-500
    3. TV Card Type: dual-analog
    3. TV Card Driver:
    4. TV Card:
    4. TV Card Type:
    4. TV Card Driver:
    MPEG2 Video Codec: ATI Avivo
    MPEG2 Audio Codec: MPA
    h.264 Video Codec: FFDShow
    Satelite/CableTV Provider:
    HTPC Case: Antec
    Cooling: Stock
    Power Supply: Antec 500W
    Remote: MCE
    TV: Samsung 56
    TV - HTPC Connection: HDMI

    I just set up an FM antenna in my attic, connected to my TV server in my basement, & figured I'd set up FM on the server.

    When scanning for FM stations, the scanner scans every .1MHz, even though I'm set for Canada. Even frequencies aren't used in N.A for FM, & the scan should therefore only scan every .2Mhz on the odd decimals ie. 102.1, 102.3 etc.

    I assume it scans every .1Mhz, because the even frequencies are used elsewhere (Europe?). It wouldn't be a problem waiting though the extended scan, but scanning the even frequencies here, causes a problem.

    If a station is powerful, the noise on the even frequency just before the station, is sufficient to make MP incorrectly import it as a station, even though it's a bunch of noise. MP then skips .4Mhz, evey time it imports a station, before it resumes it's scan. This causes it to jump right passed the correct frequency for the station, which was .1MHz higher. It also causes it to sometimes skip another station that was .2Mhz away. I live near two major markets, so it's not unheard of to have one station on 103.3 (in one market), & another on 103.5 (in the other market).

    I tried setting the sensitivity to low, hoping it would stop it from adding in false stations on adjacent frequencies, but it does not help.

    Could the scanner be changed to adhere to country selection, or at least allow manual selection of odd/even scanning?

    I'd also like to be able to set it to only skip .2 Mhz when it finds a station. Is this possible?

    The stations it did import, are listed in the radio channels section as type analog, instead of type FM. Trying to view FM details throws an error.

    Scan logs, & multiple pics attached.



    • FM_Scan_Results_Type.jpg
      81.7 KB
    • FM_Scan.jpg
      70.7 KB
    • FM_Details.jpg
      25.5 KB
    • Analog_Details.jpg
      35.3 KB
    • FM_Scan.rar
      30.6 KB

    Users who are viewing this thread

    Top Bottom