[confirm] Bug with launch path of MP breaking dialogs (1 Viewer)


MP Donator
  • Premium Supporter
  • June 9, 2008
    Home Country
    United Kingdom United Kingdom
    Originally posted here - feel free to delete original.

    My IR.ini file doesn't seem to handle long filepaths. (I'd recently changed it to let me press the green button to start up MP if I had closed it to access the config)
    Anything with a space breaks:

    "c:\program files\team mediaportal\mediaportal\mediaportal.exe" gives "c:\program " not found. I tried wrapping in quotes too, but the problem persisted.

    I changed it to the short-path:
    "c:\progra~1\teamme~1\mediaportal\mediaportal.exe" and now it works. BUT - launching MP this way, breaks Mediaportal. NO dialogs will show (see attached error log) and in addition, exiting MP crashes with an IO error.

    So I think this is a bug - the launchpath shouldn't affect the working of the application. A workaround is to create a batch file (c:\mp.bat) with the long-name path to MP in it.


    • err.txt
      696 bytes

    Users who are viewing this thread

    Top Bottom