Building TV Plugin (1 Viewer)

vapourEyes

Portal Pro
July 31, 2013
142
43
United Kingdom United Kingdom
Country flag
Will do... thanks again !

Output:
================================================
Build\MSBUILD_Rebuild_All_MediaPortal_Relese.bat
'BuildInit.bat' is not recognized as an internal or external command,
operable program or batch file.

Writing GIT revision assemblies...
The system cannot find the path specified.

Building Libbluray Java...
The system cannot find the path specified.

Building native components...
'VS_Rebuild_Release_DirectShowFilters.bat' is not recognized as an internal or
xternal command,
operable program or batch file.

Building MediaPortal...
The system cannot find the path specified.
The system cannot find the path specified.

Reverting assemblies...
The system cannot find the path specified.

Reading the git revision...
The system cannot find the path specified.
Could Not Find D:\Develop\WorkspaceCCpp\MediaPortal\version.txt

Make MediaPortal 2GB LARGEADDRESSAWARE...
'MSBUILD_MP_LargeAddressAware.bat' is not recognized as an internal or external
command,
operable program or batch file.

Building Installer...
The system cannot find the path specified.
'BuildInit.bat' is not recognized as an internal or external command,
operable program or batch file.

Writing GIT revision assemblies...
The system cannot find the path specified.

Building TV Server...
The system cannot find the path specified.
The system cannot find the path specified.

Building TV Client plugin...
The system cannot find the path specified.
The system cannot find the path specified.

Reverting assemblies...
The system cannot find the path specified.

Reading the GIT revision...
The system cannot find the path specified.
Could Not Find D:\Develop\WorkspaceCCpp\MediaPortal\version.txt

Building Installer...
The system cannot find the path specified.
================================================

Running it 'in folder':
================================================
MSBUILD_Rebuild_All_MediaPortal_Release.bat

-= MediaPortal =-
-= build mode: Release =-

File not found - _BuildReport_Files
0 File(s) copied
The system cannot find the path specified.

Writing GIT revision assemblies...

Building Libbluray Java...
The system cannot find the path specified.

Building native components...

-= DirectShowFilters =-
-= build mode: Release =-

File not found - _BuildReport_Files
0 File(s) copied
The system cannot find the path specified.

Building DirectShowFilters
The system cannot find the path specified.
'BuildReport\msxsl' is not recognized as an internal or external command,
operable program or batch file.

Building MediaPortal...
The system cannot find the path specified.
'BuildReport\msxsl' is not recognized as an internal or external command,
operable program or batch file.

Reverting assemblies...

Reading the git revision...

Make MediaPortal 2GB LARGEADDRESSAWARE...

Make MediaPortal 2GB LARGEADDRESSAWARE...
'"vsvars32.bat"' is not recognized as an internal or external command,
operable program or batch file.
'EditBin.exe' is not recognized as an internal or external command,
operable program or batch file.

Building Installer...
The system cannot find the path specified.

-= TVServer_Client =-
-= build mode: Release =-

File not found - _BuildReport_Files
0 File(s) copied
The system cannot find the path specified.

Writing GIT revision assemblies...

Building TV Server...
The process cannot access the file because it is being used by another process.
'BuildReport\msxsl' is not recognized as an internal or external command,
operable program or batch file.

Building TV Client plugin...
The process cannot access the file because it is being used by another process.
'BuildReport\msxsl' is not recognized as an internal or external command,
operable program or batch file.

Reverting assemblies...
The process cannot access the file because it is being used by another process.

Reading the GIT revision...
The process cannot access the file because it is being used by another process.
Could Not Find D:\Develop\WorkspaceCCpp\MediaPortal\Build\version.txt

Building Installer...
The system cannot find the path specified.
================================================

Possibly my buld environment is shot ?
 

vapourEyes

Portal Pro
July 31, 2013
142
43
United Kingdom United Kingdom
Country flag
YASM installed to:
C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\BuildCustomizations

Hasn't fixed the build any.

Will check other git commit versions I have here now.
 

doskabouter

Development Group
  • Team MediaPortal
  • September 27, 2009
    3,536
    1,742
    Nuenen
    Netherlands Netherlands
    Country flag
    Will do... thanks again !

    Output:
    ================================================
    Build\MSBUILD_Rebuild_All_MediaPortal_Relese.bat
    'BuildInit.bat' is not recognized as an internal or external command,
    operable program or batch file.
    This surprises me: Relese instead of Release and "'BuildInit.bat' is not recognized..."
    I think there's something really strange going on...
    How do you start that MSBUILD_Rebuild_All_MediaPortal_Relese.bat? Just doubleclicking it?
    In the end, that buildinit.bat is in the same folder as the ...Release.bat, so it should find it...

    Edit: perhaps you can try to just compile the tvserver in visual studio? How far do you get with that?
     

    vapourEyes

    Portal Pro
    July 31, 2013
    142
    43
    United Kingdom United Kingdom
    Country flag
    Hi, agreed, it is odd.

    So far:
    I have tried to build filters, tvlibrary and tvplugin in VS2013. Errors result in tvplugin with missing library references.
    The first missing library reference being, GUI.

    So I popped here and followed win8 setup instructions.

    I have invoked all .bat build scripts inside an MS build command prompt and outside, both from the top level folder, invoking build\buildScript...bat and within the folder issuing the command without the build prefix.

    I'm stumped.

    Moreover, I have multiple MediaPortal versions here all compiling fine up to 1.22 I think the last one was.
    So this new 1.23 and I think 1.24 have caused me headaches this end.

    Could it be vs2013 though? Maybe I should try with 2015 ?
     

    vapourEyes

    Portal Pro
    July 31, 2013
    142
    43
    United Kingdom United Kingdom
    Country flag
    Building the Pre-Req DirectShow filters at an MSStudio Developer Prompt, yields:

    The system cannot find the path specified.
    'BuildReport\msxsl' is not recognized as an internal or external command,
    operable program or batch file.
     

    doskabouter

    Development Group
  • Team MediaPortal
  • September 27, 2009
    3,536
    1,742
    Nuenen
    Netherlands Netherlands
    Country flag
    strange indeed.
    I don't remember big changes (that could cause this) in the last 2 MP versions.
    Don't know if vs2013 still works (i'm on 2015 and 2019 and possibly 2017) so you could have a go at it with 2015.
    But if it's going to be only to create a tv server plugin then in the end, you only need to compile that and put it in it's place?

    And compiling the c++ stuff can be really frustrating, most of the time I just copy the c++ dll's from a MP installation into the correct subfolder in bin\debug.
     

    vapourEyes

    Portal Pro
    July 31, 2013
    142
    43
    United Kingdom United Kingdom
    Country flag
    Excellent advice !

    I only need tvplugin and have been doing the bare minimum to get my grubby mits on it.

    I think its time to try 2015 and see where I get. If you had success with 2015, then I can aim for that.

    Thanks to all !
     

    doskabouter

    Development Group
  • Team MediaPortal
  • September 27, 2009
    3,536
    1,742
    Nuenen
    Netherlands Netherlands
    Country flag
    well why not switch to 2019? Only thing that could by tricky (or helpful!) is new syntax not supported by 2015
     

    vapourEyes

    Portal Pro
    July 31, 2013
    142
    43
    United Kingdom United Kingdom
    Country flag
    well why not switch to 2019? Only thing that could by tricky (or helpful!) is new syntax not supported by 2015
    Did just that.

    Under a developer command prompt I now get a nuget download failure.
    Wonder if its due to a secure download failing coz tls1.2 or something ?

    _Release_DirectShowFilters.bat

    -= DirectShowFilters =-
    -= build mode: Release =-

    File not found - _BuildReport_Files
    0 File(s) copied
    Microsoft (R) Build Engine version 14.0.24730.2
    Copyright (C) Microsoft Corporation. All rights reserved.

    Build started 07/03/2020 21:29:14.
    Project "D:\Develop\WorkspaceCCpp\MediaPortal-1.24-master-custom-notify2\Build\
    RestorePackages.targets" on node 1 (default targets).
    CustomRestorePackages:
    Downloading 'https://nuget.org/nuget.exe' ...
    D:\Develop\WorkspaceCCpp\MediaPortal-1.24-master-custom-notify2\Build\RestorePa
    ckages.targets(15,5): error : The underlying connection was closed: An unexpect
    ed error occurred on a send.
    Done Building Project "D:\Develop\WorkspaceCCpp\MediaPortal-1.24-master-custom-
    notify2\Build\RestorePackages.targets" (default targets) -- FAILED.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    M General TVE 3.5 VS2019 - build discussion TV Engine 50
    morpheus_xx [Help Me!] Build issues on TeamCity MediaPortal 2 1
    framug 1.24.0 1.25.0 pre : problem with build ? 1.24 Pre Release 89
    doskabouter Build errors MediaPortal 1 9
    doskabouter Building TVPlugins MediaPortal 1 17
    wizard123 [solved] MP1 Build help MediaPortal 1 21
    morpheus_xx Test builds of MP2.3 WiP, x64, Nereus and more... MediaPortal 2 44
    T No TV after updating Windows 10 to latest Version 1903 / OS build 18362.175 (logs attached) General Support 2
    N [Question] How come when I build WIP_2.2.1 the logged version number is 2.1.1711.10774? MediaPortal 2 1
    N [Question] Build troubles MediaPortal 2 6
    Stéphane Lenclud [fixed] Core DLL not building from Visual Studio MediaPortal 1 2
    J Clock speed vs multi-core CPU's Can MediaPortal benefit from multi core cpu's? General 0
    J Recorded TV to NAS no longer working after Windows build 1803 1.19 6
    joecrow 1.25.0 Radio Time plugin fails after Resume from Sleep with MP 1.25 Bugreports 4
    P MP2: US user, OTA - can NOT get SchedulesDirect plugin to work on MP1 or MP2 --> how do I get OTA schedule? General 5
    E aktuelle englische Forums Webseite von - Showtime Plugin v3 Plugins & Erweiterungen 4
    mrmojo666 [Tv Server Plugin ]Direct Show Video Control Plugin 0.0.0.1 for Hauppauge PVR cards MediaPortal 1 Plugins 0
    joecrow MultiShortcut Plugin (Uavailable) in DWHD skin General Support 58
    Golf4 Nach Windows-Updates läuft TV-Plugin nicht mehr Allgemeines Support- und Diskussionsforum 0
    joecrow How about a Launcher plugin for MP1? MediaPortal 1 6
    D [solved] TVServer Plugin must be missing something. General Development (no feature request here!) 1
    framug Nouveau plugin XmlTvFR pour récupérer le guide télé français Kazer / ZguideTv (WebEPGfr) 11
    emphatic Allow remote control mapping of all plugins Improvement Suggestions 0
    D Where should plugins be located on hard drive? General Support 0
    D how to disengage from one version of a plugin to use another Newcomers Forum 0
    Similar threads

























    Top Bottom