Building TV Plugin (1 Viewer)

vapourEyes

Portal Pro
July 31, 2013
142
43
United Kingdom United Kingdom
Country flag
I'm still having assemblies hell with 1.23.0.

I've tried all manner of extensions and packages around nuget package management and rebuilding and restore.

I found a neat tool below for adding nuget packages quickly.

1584018508483.png
 

vapourEyes

Portal Pro
July 31, 2013
142
43
United Kingdom United Kingdom
Country flag
But... I'd be really happy with a 1.23.0 build that works.

I'm using Eclipse for C/C++ here, which may seem odd, but enables me to track and build about 5 versions of MediaPortal so far.

So, my 1.24.0 build is working, but not 1.23.0.

If anyone has an idea, I'm happy to try it.
 

vapourEyes

Portal Pro
July 31, 2013
142
43
United Kingdom United Kingdom
Country flag
Having tried 2012, 2013, 2015, 2017 and 2019 against the MediaPortal code base, I'm still none-the-wiser why it wont build in all .NET 4.5+ compatible dev environments ?

Am I laboring a point that isn't worth making though ?

There are nuget extensions, mentioned above, that very quickly enables you to bring a nuget package into scope within VS making life potentially easier.
 

doskabouter

Development Group
  • Team MediaPortal
  • September 27, 2009
    3,521
    1,719
    Nuenen
    Netherlands Netherlands
    Country flag
    Don't know if I'm just lucky but I don't have the issues you're having...
    Would help if you can show what's going wrong
     

    azzuro

    Test Group
  • Team MediaPortal
  • May 10, 2007
    9,366
    4,994
    France - IDF
    France France
    Country flag
    But I do not know what problem it solves with nuget.
    the problem is related to latency return from myget, as it's big latency, nuget is used 1st, on nuget with the same name.
    but with the update of BASS, it will solve part of this issue, because the nuget name is unique.

    but the tips for enable nuget from myget work only in batch mode, using btach script, if you use VS for download nuget, the issue is always here.
     

    vapourEyes

    Portal Pro
    July 31, 2013
    142
    43
    United Kingdom United Kingdom
    Country flag
    but the tips for enable nuget from myget work only in batch mode, using btach script, if you use VS for download nuget, the issue is always here.
    I like the comfort of VS, so was battling to get it all working there.

    I've no problem building from batch, but it is nice to code and build in VS. As mentioned, at VS2017 with MediaPortal 1.24+ things just work, very well.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    M General TVE 3.5 VS2019 - build discussion TV Engine 50
    morpheus_xx [Help Me!] Build issues on TeamCity MediaPortal 2 1
    framug 1.24.0 1.25.0 pre : problem with build ? 1.24 Pre Release 89
    doskabouter Build errors MediaPortal 1 9
    doskabouter Building TVPlugins MediaPortal 1 17
    wizard123 [solved] MP1 Build help MediaPortal 1 21
    morpheus_xx Test builds of MP2.3 WiP, x64, Nereus and more... MediaPortal 2 44
    T No TV after updating Windows 10 to latest Version 1903 / OS build 18362.175 (logs attached) General Support 2
    N [Question] How come when I build WIP_2.2.1 the logged version number is 2.1.1711.10774? MediaPortal 2 1
    N [Question] Build troubles MediaPortal 2 6
    Stéphane Lenclud [fixed] Core DLL not building from Visual Studio MediaPortal 1 2
    J Clock speed vs multi-core CPU's Can MediaPortal benefit from multi core cpu's? General 0
    J Recorded TV to NAS no longer working after Windows build 1803 1.19 6
    joecrow 1.25.0 Radio Time plugin fails after Resume from Sleep with MP 1.25 Bugreports 4
    P MP2: US user, OTA - can NOT get SchedulesDirect plugin to work on MP1 or MP2 --> how do I get OTA schedule? General 5
    E aktuelle englische Forums Webseite von - Showtime Plugin v3 Plugins & Erweiterungen 4
    mrmojo666 [Tv Server Plugin ]Direct Show Video Control Plugin 0.0.0.1 for Hauppauge PVR cards MediaPortal 1 Plugins 0
    joecrow MultiShortcut Plugin (Uavailable) in DWHD skin General Support 58
    Golf4 Nach Windows-Updates läuft TV-Plugin nicht mehr Allgemeines Support- und Diskussionsforum 0
    joecrow How about a Launcher plugin for MP1? MediaPortal 1 6
    D [solved] TVServer Plugin must be missing something. General Development (no feature request here!) 1
    framug Nouveau plugin XmlTvFR pour récupérer le guide télé français Kazer / ZguideTv (WebEPGfr) 11
    emphatic Allow remote control mapping of all plugins Improvement Suggestions 0
    D Where should plugins be located on hard drive? General Support 0
    D how to disengage from one version of a plugin to use another Newcomers Forum 0
    Similar threads

























    Top Bottom