Cannot connect after W10 update (1 Viewer)

Mat Walker

Portal Member
July 7, 2014
24
8
Australia Australia
So this is driving me silly and soo regret 'up'grading to Win10 :)

All has been working great. MP1 server on a W10 box and clients on a mix of W10 and W7 boxes,

The Server installed a bunch of W10 updates and life became much harder. The file shares were the first I noticed had broken (outside MP); ended up having to reset IP/Winsock/etc on clients.

Then found that none of my MP clients could connect to TV server anymore. Complaining of inability to connect to server or database. The server has no firewall (disabled) and the local TV client running on the server works fine. The client logs don't show any errors (which is fair enough, there is no error as far as they are concerned; they just cant connect) and the server doesn't register any connection coming in. I've tried using server name and ip address when connecting and I can remote desktop in (so 3389 is not blocked by anything); its odd.

Has anyone else had this? Or is it just me? lol

Server & Clients at 1.15.0.0
 
Last edited:

jmuellers

Portal Member
August 20, 2010
33
1
Country flag
I seem to have the same Problem, Server and Client, for 1.18 as well as 1.19pre.
Problem started after a power fail on the client.

Disabling firewalls on client and server did not help.
Only error I can find in MediaPortal-Error.log is:

Code:
[2018-02-09 10:46:56,047] [Error  ] [MPMain   ] [ERROR] - Tv NotifyManager: Exception at timer_tick System.TypeInitializationException: Der Typeninitialisierer für "Gentle.Framework.ProviderFactory" hat eine Ausnahme verursacht. ---> Gentle.Common.GentleException: FATAL ERROR: No configuration store was found!
Gentle is unable to continue!

The handlers emitted the following error messages:
Unable to create GentleSectionHandler for section named "gentle" in file "C:\Program Files (x86)\Team MediaPortal\MediaPortal\MediaPortal.exe.Config".

Unable to create FileHandler for file Gentle.config.
This usually means that the file could not be found in any of the default search locations.

The handlers threw the following exceptions:
System.Xml.XmlException: '.', hexidezimaler Wert 0x00, ist ein ungültiges Zeichen. Zeile 1, Position 1.
   bei System.Xml.XmlTextReaderImpl.Throw(Exception e)
   bei System.Xml.XmlTextReaderImpl.Throw(String res, String[] args)
   bei System.Xml.XmlTextReaderImpl.ThrowInvalidChar(Char[] data, Int32 length, Int32 invCharPos)
   bei System.Xml.XmlTextReaderImpl.ParseRootLevelWhitespace()
   bei System.Xml.XmlTextReaderImpl.ParseDocumentContent()
   bei System.Xml.XmlTextReaderImpl.Read()
   bei System.Xml.XmlValidatingReaderImpl.Read()
   bei System.Xml.XmlLoader.Load(XmlDocument doc, XmlReader reader, Boolean preserveWhitespace)
   bei System.Xml.XmlDocument.Load(XmlReader reader)
   bei Gentle.Common.FileHandler.LoadXml(TextReader reader)
   bei Gentle.Common.FileHandler..ctor(String file)
   bei Gentle.Common.Configurator.AddFileHandler(String configStoreName, String fileName)


   bei Gentle.Common.Configurator.InitializeHandlers()
   bei Gentle.Common.Configurator.Configure(String configStoreName, Object instance)
   bei Gentle.Framework.ProviderRegistry..ctor()
   bei Gentle.Framework.ProviderFactory..cctor()
   --- Ende der internen Ausnahmestapelüberwachung ---
   bei Gentle.Framework.ProviderFactory.GetProvider(Type type)
   bei Gentle.Framework.SqlBuilder..ctor(IGentleProvider provider, StatementType stmtType, Type type, LogicalOperator logicalOperator)
   bei TvDatabase.Recording.ListAllActive()
   bei TvPlugin.TvNotifyManager.AddActiveRecordings()
   bei TvPlugin.TvNotifyManager._timer_Tick(Object sender, EventArgs e) st :    bei System.Environment.GetStackTrace(Exception e, Boolean needFileInfo)
   bei System.Environment.get_StackTrace()
   bei TvPlugin.TvNotifyManager._timer_Tick(Object sender, EventArgs e)
   bei System.Windows.Forms.Timer.OnTick(EventArgs e)
   bei System.Windows.Forms.Timer.TimerNativeWindow.WndProc(Message& m)
   bei System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
   bei System.Windows.Forms.UnsafeNativeMethods.DispatchMessageW(MSG& msg)
   bei System.Windows.Forms.Application.ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(IntPtr dwComponentID, Int32 reason, Int32 pvLoopData)
   bei System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
   bei System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
   bei System.Windows.Forms.Application.Run(Form mainForm)
   bei MediaPortalApp.Main(String[] args)
Edit:
It seems I have fixed to problem.
I was looking in this thread: please specify the ip address or hostname of the master tv service
And indeed, after I exchangend the gentle.config with a backed-up version (which luckily Mediaportal seems to create every now and then), it is running flawlessly again.
 
Last edited:

Mat Walker

Portal Member
July 7, 2014
24
8
Australia Australia
I think I'm going to have to do a server rebuild. I was on it all last night. Tried uninstalling network 'card', re-installing, turning firewall on then off again, finding every 'tweak' I could and fiddling (admittedly relatively blindly - I'm techy, but there some stuff in W10 I find baffling lol) with it but no; MP clients just 'cant see' the server.

I can open file shares, access Remote Desktop and browse to a website being hosted on the server - but all the MP clients are quite adamant; they cannot connect to server or database. Local client running on the server is ok so thye TV server and database are running all ok.

Using TCPView from Sysinternals, I can see TVService is listening on 554 & 31456 and MySQL on 3306 - and also that the local client is hooked in to them. So why are the clients saying they cannot connect to the TV service or the database?

Is it really only me this has happened to?
 
Last edited:

Mat Walker

Portal Member
July 7, 2014
24
8
Australia Australia
Ok, fixed.

As usual with things that are bizarre it was both simple and weird. After trying everything sensible and semi-sensible I slowly moved to the downright stupid. I run Viper as my antivirus as it has a small footprint and just gets on with the job quietly. I had the firewall on it turned off as I use a hardware firewall at the WAN level and so happy without firewalls inside. For no reason other than I'd not tried it, I turned it on allowing MP and MySql throught - hey presto, what problem!??? It just worked.

How bizarre is that. Windoze 10 was stating quite adamantly - almost shouting - that my computer was at risk as I had no firewall. I'd tried turning it/defender on and off to no avail. Yet, turn on the third party firewall, allowing MP through, and all was good!!! My guess is that there is - yet another - bug in W10 around the defender firewall and latest update that makes it misreport that it is off whereas it is actually on. Turning the 3rd party firewall really does turn off the defender firewall and hence allowing MP/MySql through when allowed.

- Just incase it helps any other unfortunate Microsoft customer :) (I actually only run Windows at home now for Media Portal - which I must repeat is fab)
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

OP Similar threads Forum Replies Date
J [solved] Newbie to MediaPortal 2 - Cannot open/run TV programs Newcomers Forum 4
caveman [solved] Cannot download new version My TVSeries 5
B xmltv - cannot import tvguide.xml australia Installation, configuration support 0
T I cannot get a basic media import-what is the best configuration? General 10
Terra LAVFilter Plugin cannot be updated (MP1.23) MediaPortal 1 Plugins 10
Baron of L/S [solved] Cannot record MediaPortal 1 Talk 3
D Cannot get a fully populated UK Freesat EPG (DVB-S) General 14
K [solved] Cannot get EPG populating in the UK General 7
Terra [solved] MP TV Server cannot find any channels anymore, DVB viewer works Installation, configuration support 8
N [solved] Cannot delete recordings from remote client MediaPortal 2 32
N [fixed] [MP2-786] Cannot play audio playlist with >=1000 entries 2.2 Archive 36
D [solved] Initital testing with second client - cannot play recorded TV General 33
U Client cannot tune channels General 1
G [solved] Cannot skip when programme info is visible Archive 20
O [solved] Cannot find TV DVB-T2 channels (TBS-6281SE) Newcomers Forum 7
M MovingPictures: Hang at retrieving details (connection fails) ? Moving Pictures 23
R Connection (api) problems with thetvdb.com General 3
I [solved] Connection to TV Server MySQL General Support 8
F After resume, TV Server connection screen is shown General Support 4
W Setup data connection - mySQL connection failed Installation, configuration support 1
markthenewf HDHR connect not located General 2
D MPTvScheduler - Can't Connect WebService and Mobile Access 1
T TV Series - can't connect to http://thetvdb.com/api General Support 4
B 'Successful' install of MP2.2.2 on W8.1 - but can't connect to sql db General 1
Steve.Rayner61 Online Videos - Automatic Updates fails 'Automatic update disabled. Check your internet connection' OnlineVideos 10
Similar threads

























Top Bottom