Cannot play recordings MP2 Client only (1 Viewer)

waynenz

Portal Member
March 28, 2017
28
4
59
New Zealand New Zealand
With a MP2 2.1 client only install I can't play recordings. they start to play for a few seconds then player quits. I can play live Tv ok. Client on the server plays recording ok. In the attached log I tried to play a recording at 19:11. I have tried this on 2 different win 10 pc's with the same result.
 

HTPCSourcer

MP2 Product Manager
  • Team MediaPortal
  • May 16, 2008
    11,431
    2,333
    Germany Germany
    Country flag
    With a MP2 2.1 client only install I can't play recordings. they start to play for a few seconds then player quits.
    Your client log says
    [2017-05-27 19:10:08,059] [108083 ] [InputMgr ] [WARN ] - AbstractItemsScreenData: Error creating items list
    System.IO.IOException: Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host. ---> System.Net.Sockets.SocketException: An existing connection was forcibly closed by the remote host
    The respective server log would be required to take a look what is happening at the server side.

    Did you enter Network Credentials? The client/server communication is handled under different user contexts, hence entering for example your Windows user account credentials may already resolve the problem.

    If this doesn't help can you please
    • Set log level to DEBUG (see Wiki)
    • Try one more time to watch a recording
    • Post both client and server log here
     

    waynenz

    Portal Member
    March 28, 2017
    28
    4
    59
    New Zealand New Zealand
    Hi thanks for your reply. I added the network credentials but it made no difference. Set log level to debug, tried to play a recording at 22:28. server and client logs attached.
    [2017-05-27 22:28:00,005] [73660 ] [AMQ 'SynchronizeToPrimaryPlayer'] [INFO ] - SkinEngine MainForm: Synchronized render framerate to video player 'TsVideoPlayer: Extreme Road Rescue - TVNZ 1 - 2017-05-27.ts
     

    waynenz

    Portal Member
    March 28, 2017
    28
    4
    59
    New Zealand New Zealand
    hi i tried to play the recording after setting debug level at
    [2017-05-27 22:31:59,864] [313518 ] [Thread122] [DEBUG] - TsVideoPlayer: Initializing for stream 'C:\ProgramData\Team MediaPortal\MP2-Client\RemoteResources\0e2c7973-3bb0-45f9-b51a-fab3d919cad4\Extreme Road Rescue - TVNZ 1 - 2017-05-27.ts'
     

    HTPCSourcer

    MP2 Product Manager
  • Team MediaPortal
  • May 16, 2008
    11,431
    2,333
    Germany Germany
    Country flag
    According to the log the replay of the recording starts correctly. However the evr.log is showing
    2017-05-27 22:32:04.322 [0f1c] ProcessMessage: MFVP_MESSAGE_INVALIDATEMEDIATYPE
    2017-05-27 22:32:04.332 [0f1c] EVRCustomPresenter::RenegotiateMediaType
    2017-05-27 22:32:04.342 [0f1c] EVRCustomPresenter::IsMediaTypeSupported
    2017-05-27 22:32:04.352 [0f1c] EVRCustomPresenter::CreateOptimalVideoType
    2017-05-27 22:32:04.362 [0f1c] EVRCustomPresenter::confused:etMediaType
    2017-05-27 22:32:05.901 [1214] ProcessMessage: MFVP_MESSAGE_ENDOFSTREAM
    Have you tried playing this file in Windows MediaPlayer?
     

    waynenz

    Portal Member
    March 28, 2017
    28
    4
    59
    New Zealand New Zealand
    hi I figured out the problem. My server uses a wifi network connection and I wasn't getting enough bit rate. I was sitting at around 4500KBytes which not enough for MP2. MP 1 is ok at this rate
     

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,085
    3,685
    Lehmden
    Germany Germany
    Country flag
    Hi.
    A weak WiFi connection for the server is a very, very bad idea. WiFi never is reliable and never will be. Imagine a second client also try to communicate with the server.... And you need to think about the structure of MP2. Opposite to MP1 the MP2 server has much more work to do than the MP1 TV server as it is responsible for nearly everything. The MP2 server needs to communicate to the clients to be able to show e.g. media lists, EPG,... It needs to download metadata from the internet, it needs to populate data via UPnP, it delivers all media from the media library,... The MP2 server literally is the heart and the brain of the whole media infrastructure.
    Even with MP1 I can not believe a WLan connection can be "enough" for HDTV and more than one client...
    There are flat Ethernet cable available that can be hidden very easily, even below a carpet or the wallpaper.
     

    morpheus_xx

    Lead Dev MP2
  • Team MediaPortal
  • March 24, 2007
    11,400
    6,971
    Germany Germany
    Country flag
    @waynenz you can try a workaround by creating a network share on your server (read+write) and configure this path for your recordings. This way, the client will play them back directly from the UNC source and avoids the MP2 Server-Client-HttpBridge.

    PS. After changing the recording folder you should remove the old media source "recordings" (local folder) and then restart the MP2 server service (this will recreate the recordings source for new unc path)
    Let us know if this improves playback

    Gesendet von meinem SM-T110 mit Tapatalk
     

    waynenz

    Portal Member
    March 28, 2017
    28
    4
    59
    New Zealand New Zealand
    Hi thanks for your advice. Solved the problem. I was looking at getting LAN over power cable, but won't have to now saved me some dollars.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    D [solved] Initital testing with second client - cannot play recorded TV General 33
    N [fixed] [MP2-786] Cannot play audio playlist with >=1000 entries 2.2 Archive 36
    J [solved] Newbie to MediaPortal 2 - Cannot open/run TV programs Newcomers Forum 4
    caveman [solved] Cannot download new version My TVSeries 5
    B xmltv - cannot import tvguide.xml australia Installation, configuration support 0
    T I cannot get a basic media import-what is the best configuration? General 10
    Terra LAVFilter Plugin cannot be updated (MP1.23) MediaPortal 1 Plugins 10
    Baron of L/S [solved] Cannot record MediaPortal 1 Talk 3
    D Cannot get a fully populated UK Freesat EPG (DVB-S) General 14
    K [solved] Cannot get EPG populating in the UK General 7
    Terra [solved] MP TV Server cannot find any channels anymore, DVB viewer works Installation, configuration support 8
    N [solved] Cannot delete recordings from remote client MediaPortal 2 32
    U Client cannot tune channels General 1
    G [solved] Cannot skip when programme info is visible Archive 20
    O [solved] Cannot find TV DVB-T2 channels (TBS-6281SE) Newcomers Forum 7
    M [solved] WTV Files does not play on client, MPEG files works well General 1
    A [solved] How to Play All Videos in a List watch/edit Videos 3
    horned_reaper [solved] When playing music Fanart does not shuffle Fanart Handler 20
    horned_reaper [solved] No Fanart when playing Fanart Handler 115
    horned_reaper [solved] When playing music Fanart does not appear immediately after downloading Fanart Handler 272
    B MP 2.2.3 Error playing videos from NAS Submit: Bug Reports 2
    N Play a TV recording needs a double selection - twice ok on remote Television (MyTV frontend and TV-Server) 2
    M MP 2.2.3 Unable to play .ts recordings and MediaPortal stops working for TV viewing General 31
    Z Error when attempting to play Blu Ray General 1
    Rob Hexenmeister Playing with hyperlinkParameter and List Control indexes General Support 2
    Similar threads

























    Top Bottom