Collection was modified; enumeration operation may not execute (1 Viewer)

mrceolla

Portal Pro
December 11, 2010
136
12
Country flag
Anyone have any idea what may be causing this error? A window pops up asking me to Continue or Quit. MP still is operating behind this window as if nothing was wrong, except for the spinning 'Wait' wheel. If I click "Continue", my GPU usage (as seen via Windows 10 Task Manager) goes through the roof, and the spinning 'Wait' wheel remains on screen until I close MP. If I choose "Quit", MP closes.

I recently upgraded to 1.19 and did not have this problem previously. Unfortunately I forget the version I came from.

The error text seems to indicate it has something to do with the Playlist screen. I do have a 4,000 song playlist loaded by default, but this has never been a problem before. It also doesn't occur every time. I haven't figured out the trigger yet. I've tried both Titanius and the stock Titan. Both show this error so I don't think it is skin related.


Collection was modified; enumeration operation may not execute

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.InvalidOperationException: Collection was modified; enumeration operation may not execute.
at System.Windows.Forms.Control.MarshaledInvoke(Control caller, Delegate method, Object[] args, Boolean synchronous)
at System.Windows.Forms.Control.Invoke(Delegate method, Object[] args)
at System.Windows.Forms.Control.Invoke(Delegate method)
at MediaPortal.GUI.Music.GUIMusicPlayList.bw_RunWorkerCompleted(Object sender, RunWorkerCompletedEventArgs e)
at System.ComponentModel.BackgroundWorker.OnRunWorkerCompleted(RunWorkerCompletedEventArgs e)
at System.ComponentModel.BackgroundWorker.AsyncOperationCompleted(Object arg)


************** Loaded Assemblies **************
...


It goes on to list a bunch of loaded items. I could provide the entire list if helpful. I don't presently have a log file for when this error occurred, but if needed I will grab it the next time this happens. I can tell you that it seems to usually happen when I programmatically start playing the loaded playlist via WiFi Remote commands (via home automation). The HTPC is usually showing the Blank Screen screensaver at this time. Once I wake up the screen I am greeted with this error window. Again, this didn't happen before I upgraded to 1.19.

This is running on a Minix NGC-1.

Any help is greatly appreciated!
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom