[solved] Coming from WMC and completely lost (1 Viewer)

thompsontv

New Member
January 3, 2020
5
0
53
United States of America United States of America
Country flag
Been using WMC since 2013 using Hauppage DCR-2650 with cable card and Verizon FIOS. Now that MS pulled the plug on EPG data, I figured it's time to upgrade to Windows 10 and a new HTPC software. I chose MP2 because I thought it would be easy to configure...I was wrong about that. I am quite tech savvy - have been in IT for quite awhile but this is a whole new level of frustration. My end goal though is to NOT pay Verizon for their DVR solution, so...

The installation went smoothly but the tv guide shows the channels on the side but no program data. When I click on a channel to watch it, nothing...I'm sure I'm missing something simple, I just don't know where to look. I'm in Virginia if that helps for guidance on an EPG solution. I've signed up for Schedules Direct but getting that to interact with xmltv gui didn't work and I guess webepg doesn't work anymore...? I've done quite a bit of searching on using MP2 with the DCR-2650...am I wasting my time?

Does anyone have FIOS? What do you use for a cable card tuner? Do you even need a cable card? I thought yes in order to view HD channels...

Any help would be more than appreciated!
 

Attachments

mm1352000

Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Hello!

    When I click on a channel to watch it, nothing.
    I'm not all that familiar with MP2 (I've only ever used MP1), but there are a couple of things that stand out in the log files.

    First, from the log files I gather you may not have enabled the "CAM" (CableCARD), as instructed here under "CAM setup":
    TV Servers

    The log files indicate this with messages like this:
    [2020-01-04 17:08:58,112] [77343222] [115 ] [INFO ] - CanCardDecodeChannel: card:4 type:Atsc channel is encrypted but card has no CAM
    [2020-01-04 17:08:58,113] [77343223] [115 ] [INFO ] - CanCardDecodeChannel: card:3 type:Atsc channel is encrypted but card has no CAM

    Please make sure you've done that as a first step.

    The other thing the log files show a lot is:
    TvLibrary.TvExceptionGraphBuildingFailed: DRI CC: tuner appears to be in use

    This can often indicate that MediaPortal is having trouble controlling your tuner because it can't access it properly. Although the DCR-2650 is connected via USB, it is actually exposed to Windows as a network interface. That in turn means that security software - firewalls in particular - can obstruct access to it. For that reason I recommend that you make sure you've granted MediaPortal Server full access to your tuner in any security software you might be running.

    Finally, I can't see which firmware version you're using from the log files, but make sure you've installed the latest version from here:
    Hauppauge Support | WinTV-DCR-2650

    The installation went smoothly but the tv guide shows the channels on the side but no program data.
    This is normal. MediaPortal doesn't provide or have any way of grabbing guide data from the tuner for the USA. Guide data has to be sourced from elsewhere, as you've indicated - SchedulesDirect etc. - and then imported using one of the TV Server plugins such as XMLTV.

    I'm in Virginia if that helps for guidance on an EPG solution.
    It doesn't really. EPG solutions for the USA aren't state-specific.

    I've signed up for Schedules Direct but getting that to interact with xmltv gui didn't work and I guess webepg doesn't work anymore...?
    Well, I'm not sure about the status of WebEPG. Given that you've signed up for SchedulesDirect, I'd recommend you just stick with that.

    The processing chain you'll need to setup is: SchedulesDirect -> mc2xml -> MediaPortal TV Server XMLTV plugin.

    There's no xmltv gui involved with that at all.

    Here's a setup guide for mc2xml and XMLTV:
    XMLTV mc2xml
     

    thompsontv

    New Member
    January 3, 2020
    5
    0
    53
    United States of America United States of America
    Country flag
    Thanks so much for the quick reply. I'll go through what you said when it finishes a windows update.

    Quick question: I remember when I click on each tuner, there's an option for 1) ATSC Terrestrial something, 2) Clear QAM, and 3) Digital Cable. Based on my setup and using FIOS, which one should I choose? I've been using #3 as it updates quickly and shows all the channels. I tried both 1 and 2, but they were updating very slowly and it would've taken hours to finish if I let it go...

    Thanks again!
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    #3 is right for a CableCARD tuner. That is covered in our wiki here:
    Scan ATSC

    To scan for digital channels broadcast over the air using a tuner connected to an aerial, select "ATSC Digital Terrestrial".

    To scan for digital channels broadcast on a cable system using a tuner connected to a cable feed, select "Clear QAM Cable".

    To scan for digital channels broadcast on a cable system using a CableCARD tuner connected to a cable feed, select "Digital Cable".
    Given this and your earlier questions, make sure you've read and applied the advice given here:
    Scan ATSC
     

    thompsontv

    New Member
    January 3, 2020
    5
    0
    53
    United States of America United States of America
    Country flag
    Still having issues scanning channels. Still getting "out-of-band service information... signal locked, no channels found". Are the TV Server and the tuner supposed to be on the same network? Server is on 192.168.1.x network and the DCR-2650 is on 192.168.39.x network. Does that matter?

    Oh, and I turned the firewall off. I'm at a standstill here...
     

    Attachments

    thompsontv

    New Member
    January 3, 2020
    5
    0
    53
    United States of America United States of America
    Country flag
    Hold on...I power-cycled the DCR-2650 and now I'm getting channels. Yes!
     

    thompsontv

    New Member
    January 3, 2020
    5
    0
    53
    United States of America United States of America
    Country flag
    Thanks MM for your help. Last I said I was getting channels but the tuner wasn't tuning any channels. Went through your setup wiki once more and now I have TV again! Thanks again...on to fine tune it now.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom