Corrupt ts file after recording? (1 Viewer)

Owlsroost

Development Group
  • Team MediaPortal
  • October 28, 2008
    5,539
    5,037
    Cambridge
    United Kingdom United Kingdom
    Country flag
    It's hard to know for sure, but in your logs it looks like there was a problem with MP Audio Renderer - the playback started normally but was stopped immediately (and there are error messages in the MPAR log. Try using default direct sound renderer instead of MPAR for TV.

    Code:
    11-12-2014 14:14:37.572 [ 10bc] WASAPIRenderFilter::StartAudioClient
    11-12-2014 14:14:37.572 [ 10bc]   start failed (0x88890001)
    11-12-2014 14:14:37.572 [ 10bc] CWASAPIRenderFilter::Render thread Error, starting audio client failed: (0x88890001)
    11-12-2014 14:14:37.572 [ 10bc] CWASAPIRenderFilter::Render thread - closing down - thread ID: 4284
     

    hamp

    Portal Member
    August 18, 2007
    32
    1
    Sweden Sweden
    I changed to use default direct sound device but it still won't start. This only happens with the regional news program and it's not a big problem for me so I can live with it. Thanks for your help.
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Hello hamp

    Unfortunately my 10 GB per month Internet cap doesn't allow me to download large files without budgeting/planning. If the file plays in VLC then that is positive... but I'm not so sure that it guarantees that the recording is created perfectly. Could you please switch back to the default TsWriter and see if it makes a difference. For your sake I hope it works... but for my sake I hope it doesn't (...because if it does, I will need to figure out what is wrong in my new TsWriter - that could be very very hard).

    Thanks for the testing and feedback! (y)
    mm
     

    hamp

    Portal Member
    August 18, 2007
    32
    1
    Sweden Sweden
    I have these test recordings so far and E1-E10 was with old TsWriter and then I can play the file in both VLC and MediaPortal but I only got the first minutes recorded until my regional news program ends.
    With the new TsWriter (E11 and E12) I got the complete recording and can play it in VLC but it won't start in MediaPortal.

    Do you want me to test the old TsWriter again and verify that I'm still able to play the recording?

    Niclas



    Capture2.PNG
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Do you want me to test the old TsWriter again and verify that I'm still able to play the recording?
    In short: yes please. I want to see if a recording created with the TV library patch and old TsWriter can play in VLC and MediaPortal.

    I think it is almost certain that the TV library patch for M***I made it possible to get the complete recording, and that the alternative/new TsWriter was unnecessary. The alternative/new TsWriter has not been tested very much so may have a few problems. These problems (which may or may not exist) might be the cause of MediaPortal's failure to play the recording. Since the alternative/new TsWriter should be unnecessary, it should be possible to go back to the old/default TsWriter... which is well tested, maybe more stable, less problems etc.
     

    hamp

    Portal Member
    August 18, 2007
    32
    1
    Sweden Sweden
    With the TV library patch and the old TsWriter I get the complete recording and it's possible to play the file :) I couldn't rewind from the second program to the first (it freezes) but the rest works.(y)

    Added log files...
     
    Last edited:

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Ahhh, great! :)
    Thanks for testing. (y)
    Could you please post the log files for the successful case so we can try to compare between the old and new TsWriter?
     

    hamp

    Portal Member
    August 18, 2007
    32
    1
    Sweden Sweden
    If you want me to test anything just let me know...
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    If you want me to test anything just let me know...
    I might... but first I'd need the TsWriter log file for the successful case, as previously requested.

    [edit: Ahhh, sorry - I see now you added the logs to the old post. I'll take a look... :) ]
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    F 1.25.0 Display corruption Bugreports 0
    D MP2 - V2.1 Recorded TV - recording corrupted if MP client used while recoding in progress Older releases 20
    M [solved] WTV Files does not play on client, MPEG files works well General 1
    bigboss97 Does anyone has a SoundGraph imon remote file for MP2 to share? General 0
    J Help with new grabber file. WebEPG 1
    S [solved] No sound - MKV file MediaPortal 1 Talk 2
    G WTV files General 11
    Golf4 TV-Records werden als Audio-Files importiert ? Allgemeines Support- und Diskussionsforum 0
    azzuro [fixed] [WIP MP2.3] - Audio files not imported to MP MediaPortal 2 18
    HTPCSourcer Media Accessor is flooding logs with files from attached monitor MediaPortal 2 9
    R [will not fix] [MP2-832] MP2.2.2 subtitles not shown for WTV files Submit: Bug Reports 7
    R [solved] Files moved to new location - Easy way to update database? My TVSeries 7
    R Files moved to different location - Easy way to update database? Moving Pictures 2
    thepahakurki Trakt error: Invalid or missing file Trakt 8
    M Keymapping Which File To Edit General Support 4
    F No data in "File Details" Moving Pictures 2
    R [solved] Moving pictures importer wont add files from a removable drive. Is there a work around ? Moving Pictures 8
    R Directx 9.0 June 2010 does not install on Windows 10 x64, ends up with weird failure / no debug file Installation, configuration support 0
    B xml file for perfect player Newcomers Forum 1
    K How to enable autoplaying of the next video files in the folder MediaPortal 1 Talk 2
    B Text files attached to videos Watch / Listen Media 10
    Neoculture Bulk file name update My TVSeries 6
    ge2301 [fixed] [MP2-807] Problem when switching player in PiP mode with audio files MediaPortal 2 32
    C How do I get MediaPortal to separate recording files by channel and month? General 2
    CyberSimian [Bug] Signed/unsigned error in calculation of file timestamps MediaPortal 1 11
    Similar threads

























    Top Bottom