Crash when scanning for channels - RTSP on DVB-IP Card (1 Viewer)

gavo

Portal Member
July 27, 2008
24
8
Hi,

I have a Dahua IP camera that provides a live stream via RTSP. I thought I would try to tune it as a channel on my Mediaportal 1.9.0 Setup on Windows 7 64bit. I created a HomeCameras.m3u containing the following:

#EXTM3U
#EXTINF:0,Front Door
rtsp://mediaportal:password@192.168.1.150/cam/realmonitor?channel=1&subtype=0

The RTSP URL above when pasted into VLC results in the picture being streamed to my PC. When however I try to "Scan for Channel" from service "HomeCameras" within the TV-Server configuration tool, both the TVServer service and configuration tool crash (see logs attached).

I then tried to tune "France.FreeBox_TV" which is a configuration supplied with MediaPortal and again I get a crash.

Does anyone else see this behavior?

Cheers,
 

mm1352000

Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Hello gavo

    I don't know why you have problems with FreeBox, but according to the MPIPTVSource.log the problem with the IP camera is:
    31-10-2014 20:15:35.574 [7260] [{A7662A72-EEEA-474B-A760-5AEE439C231A}] [Error] CMPIPTV_RTSP: OpenConnection(): error occured while sending OPTIONS command: cannot handle OPTIONS response: RTSP/1.0 401 Unauthorized
    Maybe the URL is not passing the username and password successfully?

    Regards,
    mm
     

    gavo

    Portal Member
    July 27, 2008
    24
    8
    Maybe the URL is not passing the username and password successfully?
    Thanks MM,

    I disabled authentication on my camera and tried again. Again I was able to open the stream in VLC, but unfortunately again the TVServer service and TV Server configuration tool crashed when trying to scan for channels (logs attached - TVServerLogs-IPCamera-NoAuth.zip).

    Also, I have attached the logs (TVServerLogs-FreeBox.zip) from when I try to scan for channels for France-Freebox, which also results in the same (from my user perspective) crash.

    Interestingly, if I scan for channels on something that isnt using RTSP sources, I dont seem to get the crash - such as "Austria.Aon TV_Premium" - it goes through the scanning process.

    Cheers,
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,433
    10,254
    France
    France France
    Country flag
    I remember talking with georgius that tvservice can't handle return error from iptv stream and make it crash, i know that i have added a try/catch for it on my build for TVE3 but this is surely fixed for TVE35 build :)
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Hello gavo

    I disabled authentication on my camera and tried again. Again I was able to open the stream in VLC, but unfortunately again the TVServer service and TV Server configuration tool crashed when trying to scan for channels (logs attached - TVServerLogs-IPCamera-NoAuth.zip).
    Sorry but it looks like the stream format is not supported. The TV Server IPTV source filter currently only supports receiving MPEG 2 transport streams, but your camera is supplying an "H264" stream:
    01-11-2014 17:54:08.329 [7440] [{684DA504-4967-4C35-8B9A-D4A6983E6410}] [Info] CMPIPTV_RTSP: OpenConnection(): Start
    01-11-2014 17:54:08.392 [7440] [{684DA504-4967-4C35-8B9A-D4A6983E6410}] [Error] CMPIPTV_RTSP: OpenConnection(): H264 not supported
    01-11-2014 17:54:08.393 [7440] [{684DA504-4967-4C35-8B9A-D4A6983E6410}] [Info] CMPIPTV_RTSP: CloseConnection(): Start
    Also, I have attached the logs (TVServerLogs-FreeBox.zip) from when I try to scan for channels for France-Freebox, which also results in the same (from my user perspective) crash.
    I don't know why FreeBox is failing. The log is a bit cryptic:
    01-11-2014 17:56:26.150 [722c] [{00871304-84C0-407F-B5F6-C13295BF4D74}] [Info] CMPIPTV_RTSP: OpenConnection(): Start
    01-11-2014 17:56:31.155 [722c] [{00871304-84C0-407F-B5F6-C13295BF4D74}] [Error] CMPIPTV_RTSP: OpenConnection(): error occured while sending OPTIONS command: select/connect() failed: No error
    01-11-2014 17:56:31.156 [722c] [{00871304-84C0-407F-B5F6-C13295BF4D74}] [Info] CMPIPTV_RTSP: CloseConnection(): Start
    "Error occured while sending...", and then "no error" - makes no sense to me. :confused:

    @azzuro
    How did you get FreeBox working? Did you have to use the other merged filter?
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,433
    10,254
    France
    France France
    Country flag
    I use a freebox here :) (french man lol).
    I use also Latest Georgius merged filter (so for IPTV and OV) and it works
    Maybe i can share a build for testing and if ok look for tve35 :)
     

    azzuro

    Test Group
  • Team MediaPortal
  • May 10, 2007
    9,360
    4,987
    France - IDF
    France France
    Country flag
    How did you get FreeBox working? Did you have to use the other merged filter?
    hello MM

    i don't use freebox for now, i have moved to an other provider,
    but i can explain a little:
    all the script is here :
    https://forum.team-mediaportal.com/threads/french-free-fr-freebox-tuningdetails.121146/
    https://forum.team-mediaportal.com/attachments/2013-08-21-free-tuningdetail-explication-zip.135152/
    but this was for MP1.5
    i'm not sure, if the tuning detail work with last georgius work.

    About freebox and M3u channel list, @Sebastiii have you updated this one for georgius rework. ?

    PS :
    this is my new internet connection lol : 3869139468.png
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,433
    10,254
    France
    France France
    Country flag
    Crasy boy :) too fast internet connexion :)

    Not sure about your question for georgius, i'm using the very latest Filter from him :)
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    R [fixed] [MP2-819] MP2 Server crashes on ATSC OTA channel scan Submit: Bug Reports 33
    Tim [further infos missing] MP2 Server crashes on channel scan 2.2 Archive 9
    A DVB IP Crash on Scanning - 1.20 General Support 0
    L Service keeps crashing General 0
    U [solved] MediaPortal crashing on startup General Support 10
    RoChess Weird GPU crash -- possible cause: resizing media MediaPortal 1 Talk 8
    torone Dritter versuch mit Mediaportal 2 Allgemeines Support- und Diskussionsforum 1
    W [solved] MP suddenly Crashes when starting live TV on most channels and on recordings from the same channels General Support 20
    W [solved] MP suddenly Crashes when starting live TV on some channels and on some recordings Television (MyTV frontend and TV-Server) 1
    D [solved] Changed username in Win10, now TV Server config crashes on fresh install Installation, configuration support 1
    ajs Trakt error when start with MP crash Trakt 1
    R TV server crash with WintTV quadHD General 0
    Dark Eyes TVService locks up or fails to restart on resuming from sleep, and crashes when grabbing EPG Installation, configuration support 7
    atlantic [solved] MP1.24 Pre released crash in TV General Support 12
    RoChess Random GPU crash leads to MePo restart, but works fine afterwards MediaPortal 1 14
    doskabouter 1.23.0 Crash when skipping in a dvd Bugreports 3
    J [fixed] [MP2-833] 2.2.2 server crash during import Submit: Bug Reports 50
    P MP2 TV Server crashes when starting - throws error remoting exception General 2
    G MP Crashed during setting up recording. Newcomers Forum 1
    Rob Hexenmeister DVD Skip steps causing crash General Support 2
    badboyxx MP 1.22 final is crashing when jumping forward while playing DVD-Iso watch/edit Videos 26
    Terra Crash when opening ACTORS list My TVSeries 3
    Terra Crash when searching movies, reproducable Moving Pictures 2
    KlausWirn Music crash Bass crash no change to play music Installation, configuration support 2
    cladinshadows85 [solved] Audio playing mutiple times over video and crashing General 8
    Similar threads

























    Top Bottom