Crash with latest MPUrlSourceFilter and ITV player (1 Viewer)

Brownard

Development Group
  • Team MediaPortal
  • March 21, 2007
    1,953
    1,307
    United Kingdom United Kingdom
    Country flag
    • Thread starter
    • Moderator
    • #1
    Hi @georgius
    The source filter appears to be crashing when trying to play an ITV player stream, I managed to revert to an older version and the stream works fine so I believe that the url is OK and playable, Sorry I can't remember which version I reverted to (the extension manager always downloads the latest version btw),

    Logs and dump are attached, any further info needed let me know.
    Thanks in advance.
     

    Attachments

    georgius

    Retired Team Member
  • Premium Supporter
  • October 31, 2010
    1,376
    654
    Bratislava
    Slovakia Slovakia
    OK, what can I see is, that you have installed filter 2.1.15.5684, but protocols and parsers seems to be latest. In other words, it's mess. I recommend to uninstall filter and make some clean up. I suppose that you have MP and TV server installed in default location, so after uninstalling please check:
    1. TV server folder: C:\Program Files (x86)\Team MediaPortal\MediaPortal TV Server\MPUrlSourceSplitter - if folder exists, remove it and all its content
    2. MP folder: C:\Program Files (x86)\Team MediaPortal\MediaPortal\MPUrlSourceSplitter - if folder exists, remove it and all its content
    3. if you wish, you can clean up also cache folders (if they exist):
    C:\ProgramData\Team MediaPortal\MPUrlSourceSplitter
    C:\ProgramData\Team MediaPortal\MPIPTVSource

    Now you can try to install latest 2.2.10.5911 version. If crash still persists, then first attach logs. If crash dump file will be needed, I'll ask for it.
     

    Brownard

    Development Group
  • Team MediaPortal
  • March 21, 2007
    1,953
    1,307
    United Kingdom United Kingdom
    Country flag
    • Thread starter
    • Moderator
    • #4
    OK, what can I see is, that you have installed filter 2.1.15.5684, but protocols and parsers seems to be latest. In other words, it's mess. I recommend to uninstall filter and make some clean up. I suppose that you have MP and TV server installed in default location, so after uninstalling please check:
    1. TV server folder: C:\Program Files (x86)\Team MediaPortal\MediaPortal TV Server\MPUrlSourceSplitter - if folder exists, remove it and all its content
    2. MP folder: C:\Program Files (x86)\Team MediaPortal\MediaPortal\MPUrlSourceSplitter - if folder exists, remove it and all its content
    3. if you wish, you can clean up also cache folders (if they exist):
    C:\ProgramData\Team MediaPortal\MPUrlSourceSplitter
    C:\ProgramData\Team MediaPortal\MPIPTVSource

    Now you can try to install latest 2.2.10.5911 version. If crash still persists, then first attach logs. If crash dump file will be needed, I'll ask for it.
    :whistle: That seems to have done the trick, sorry, my installation must have got messed up somewhere along the line.

    While you're here though :) sometimes an ITV stream will stop midway through playback, the attached logs are from a playback that stopped after a couple of seconds, followed by me restarting the same stream. Not critical but would be nice to know whether it's something that can be fixed or its an ITV issue.

    Thanks again
     

    georgius

    Retired Team Member
  • Premium Supporter
  • October 31, 2010
    1,376
    654
    Bratislava
    Slovakia Slovakia
    Probably something between RTMP and ITV. RTMP library is not developing (latest commit is from December 23rd, 2015) and probably the RTMP best times are over. Anyway, RTMP library is written with reverse engineering, not with some official documentation.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    A MediaPortal crash (and restart) on LiveTV after Windows Update (Sep 2020) driver update for Intel HD Graphics 4600 General Support 0
    F MediaPortal 1.16 server crashing due to user error? General Support 5
    L Service keeps crashing General 5
    U [solved] MediaPortal crashing on startup General Support 10
    RoChess Weird GPU crash -- possible cause: resizing media MediaPortal 1 Talk 8
    torone Dritter versuch mit Mediaportal 2 Allgemeines Support- und Diskussionsforum 1
    W [solved] MP suddenly Crashes when starting live TV on most channels and on recordings from the same channels General Support 20
    W [solved] MP suddenly Crashes when starting live TV on some channels and on some recordings Television (MyTV frontend and TV-Server) 1
    D [solved] Changed username in Win10, now TV Server config crashes on fresh install Installation, configuration support 1
    ajs Trakt error when start with MP crash Trakt 1
    R TV server crash with WintTV quadHD General 0
    Dark Eyes TVService locks up or fails to restart on resuming from sleep, and crashes when grabbing EPG Installation, configuration support 7
    atlantic [solved] MP1.24 Pre released crash in TV General Support 12
    RoChess Random GPU crash leads to MePo restart, but works fine afterwards MediaPortal 1 14
    R [fixed] [MP2-819] MP2 Server crashes on ATSC OTA channel scan Submit: Bug Reports 33
    doskabouter 1.23.0 Crash when skipping in a dvd Bugreports 3
    J [fixed] [MP2-833] 2.2.2 server crash during import Submit: Bug Reports 50
    P MP2 TV Server crashes when starting - throws error remoting exception General 2
    G MP Crashed during setting up recording. Newcomers Forum 1
    Rob Hexenmeister DVD Skip steps causing crash General Support 2
    badboyxx MP 1.22 final is crashing when jumping forward while playing DVD-Iso watch/edit Videos 26
    Terra Crash when opening ACTORS list My TVSeries 3
    Terra Crash when searching movies, reproducable Moving Pictures 2
    KlausWirn Music crash Bass crash no change to play music Installation, configuration support 2
    cladinshadows85 [solved] Audio playing mutiple times over video and crashing General 8
    Similar threads

























    Top Bottom