Direct3D Problems after resume with MP 1.0 (1 Viewer)

4log

New Member
January 21, 2007
1
0
120
My last upgrade from MP 1.0 RC2 to MP 1.0 was not a good decision:

With the new version there are many problems:

1.) After a wakeup from standby (by remote or automatically) the MP freezes.
So I tried the option to restart MP after resume without success.
The log files shows a problem with Direct3D initialization:

2009-03-26 08:01:39.640625 [ERROR][MPMain]: D3D: Exception: Warning: Nothing will be rendered.
The reference rendering device was selected, but your
computer only has a reduced-functionality reference device
installed. Please check if your graphics card and
drivers meet the minimum system requirements.

2009-03-26 08:04:01.046875 [ERROR][MPMain]: Exception :Error in the application.
-2005530518 (D3DERR_NOTAVAILABLE)
at Microsoft.DirectX.Direct3D.Device..ctor(Int32 adapter, DeviceType deviceType, Control renderWindow, CreateFlags behaviorFlags, PresentParameters[] presentationParameters)
at MediaPortal.D3DApp.InitializeEnvironment()

I did not have this problems with the RC2 or the 0.2.3 version.
So there must be a change in code which causes this.


2.) Automatic wakup for scheduled recordings sometimes does not work
I use the TV-Server with the power scheduler.
Before the 1.0.0 I never had a problem with a "forgotten" recording.
But with the new version sometimes it will not resume. I enabled extensive logging for that
but there was no error. The only thing which maybe have something todo with is an entry in the eventlog:

DCOM got error "The service cannot be started, either because it is disabled or because it has no enabled devices associated with it. " attempting to start the service ehSched with arguments "-Service" in order to run the server:
{4B635ECB-0887-4015-8CA6-D621362F98D1}

But I do not think that MP uses this component from the XP Media Center.

Just some information about my system:
- AMD Athlon X64 4200+
- 4 GB RAM
- ATI X1600
- Windows XP Media Center Edition
- .NET Framework 3.5 SP1 (which also was installed together with the RC2 version)

I hope the 1.0.1 version will fix all the problems which occured with the 1.0.0 release version.

Markus
 

Glenn UK

Portal Member
July 3, 2009
19
0
Basildon, Essex
England England
HI Markus

was your problem solved?

i am getting a similar error with MP or at least i get the message re rendering device not working.

I am using MP and TV server config in conjunciton with 4tr to record from DVB-S card.

I am not sure what changed but up until a couple of weeks ago everyhitng worked fine, i have also manged to get the pc to wake up and go back to s/by with no problems then this problem starts. trouble is i cant pin point the start of the problem to a specific issue and seeing your post wondered if you had a fix?

Incidentally i also have aproblem with MP not 'seeing' the DVB-S card at times and i havent even begun to work out why that is yet.

Glenn
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

OP Similar threads Forum Replies Date
F Problems with new install of MP2 Newcomers Forum 3
A [solved] DiseqC problems after upgrade to 1.25 General Support 1
M Problems with VFD Display after standby- Futaba DM140GINK Mini Display 0
R Connection (api) problems with thetvdb.com General 3
123vak123 [solved] 5008: The problem with scrolling text in the "listcontrol" in 4K General Support 22
framug 1.24.0 1.25.0 pre : problem with build ? 1.24 Pre Release 75
J Problems with 1.24 StreamedMP 19
Rob Hexenmeister Navigation problems adding menu buttons to EPG General Support 1
404 [solved] EPG problem after Win10 'upgrade' General Support 1
framug [EPG] Some problems with DVB EPG Improvement Suggestions 49
C strange tuner(?) problem TV-Cards 0
R Problems accessing MySQL database remotely MediaPortal 1 Talk 0
T [solved] Startup problem General 6
G Problems with DRR MediaPortal 1 Talk 1
rsbrux 1.23.0 MPE Manager Problem with LAV Filters Bugreports 2
S Problem with Remote Control One-for-all Streamer Newcomers Forum 6
joecrow Default Wide HD Xmas Theme Problem General Support 3
K Sleep mode problem after formating General Support 2
P IPTV Channel Problem TV-Server 0
C Problem playing videos created on IPhone X and Samsung S9 General Support 2
nominefi Problem scanning channels. General Support 0
E Swedish subtitles problem General 2
G Newb trying MP2, trouble with guide data General 5
G MP1 TV Server "failed to upgrade the database" using MS Sql Server Installation, configuration support 3
geotwticher [solved] Fatal Error 0x80070643 during MP2 installation General 7
Top Bottom