Disable Vertical Sync (1 Viewer)

Ozy

New Member
November 18, 2005
3
0
Hello All,

Thanks for providing such wonderful software. I have converted to it over the MCE software even though i'm still running it on an MCE box!

I have a few questions, maybe simple, maybe not, and besides that everything seems great.

I'm running Snapshot mediaportal-cvs-11-08-2005--22-53 with .net2.

I am running this on an Asus A8N-VM CSM nForce 430 6150 MB on an AMD 3000+ CPU , 512mb RAM, and 40GB IDE HD. I have it attached to my 62" Mitsubishi 62725 TV via the VGA input. No problems there. I am running the current WQHL 81.94 video drivers. I use an Audigy2 ZS for SPDIF passthru via the AC3 Filter codec.

I have an extensive movie collection that I've ripped and encoded into Divx6 format while maintaining the AC3 stream using GK & AutoGK.

Simply put, vsync is OFF on my machine. I'm experiencing heavy heavy tearing when watching movies. It does not appear when I play the movie in WMP10 directly using overlay mode. I am using the VRM9 method in MP. I tried forcing VSYNC enabled in the "general" section of the nvidia drivers and it has no effect. Is there any switch or configuration option i'm missing?

I am using the USA MCE Remote on MP. It works fine. When playing back a movie in MCE, you can press the Windows key to go back to the menu, and if you want to go back to the movie full screen, you simply move over and select the movie window in the bottom left and hit select. When I press the Windows key on MP, it goes to the menu just like normal. I can't go back to fullscreen unless i hit "back" and go back to it kinda like a browser. If i dig into menus or what not and then want to return to full screen, i can't select the video to go full screen again. Is there something obvious i'm missing?

Thanks ahead of time!
 

Ozy

New Member
November 18, 2005
3
0
I have determined that the skin is what is allowing or not allowing the MCE-like toggling to occur.


I also would like to add that if i switch to VRM7 mode, there is no vertical sync tearing. It has something to do with VRM9 mode for sure. Does this help?
 

KRA

Portal Pro
July 5, 2005
145
5
44
Home Country
Norway Norway
This is a known problem, running MP in DX exclusive mode would fix it (it's an option in the main setup) Unfortunatly then you are not able to use alt-tab when a video/tv is playing. All resources go to MP.

People say it's because gfx card is not fast enough, but I'm pretty sure that is not the case, I believve it's a programming error. But it may be on MS part and not the MP developers, as all programs I've seen that use WMR9 has the same problem.

When you run MP in exclusive mode, and turn on vsync the tearing is gone. If you turn off vsync, exclusive mode doesn't help. So clearly it's not a resource issue. But the fact that the vsync option has no effect on MP when it's not in exclusive mode.
 

Ozy

New Member
November 18, 2005
3
0
KRA said:
This is a known problem, running MP in DX exclusive mode would fix it (it's an option in the main setup) Unfortunatly then you are not able to use alt-tab when a video/tv is playing. All resources go to MP.

People say it's because gfx card is not fast enough, but I'm pretty sure that is not the case, I believve it's a programming error. But it may be on MS part and not the MP developers, as all programs I've seen that use WMR9 has the same problem.

When you run MP in exclusive mode, and turn on vsync the tearing is gone. If you turn off vsync, exclusive mode doesn't help. So clearly it's not a resource issue. But the fact that the vsync option has no effect on MP when it's not in exclusive mode.

That did fix the problem. I do not agree that its a video card issue. The 6150 + Athlon 64 3000+ is more than enough to play a divx stream without stressing.
 

Users who are viewing this thread

Top Bottom