diseqc motor not working with skystar 2 card (1 Viewer)

ben001

Portal Member
May 23, 2007
38
0
34
Canada Canada
TV-Server Version: RC2
MediaPortal Version: RC2
MediaPortal Skin: Default
Windows Version: TV-Server: Windows server 2003 / Client: Vista Ultimate 32 bit
CPU Type: Athlon 3000+
HDD:
Memory: 2 GB
Motherboard: AOpen K8HTB-8237
Video Card:
Video Card Driver:
Sound Card:
Sound Card AC3:
Sound Card Driver:
1. TV Card: Skystar 2 Rev 2.3
1. TV Card Type: DVB-S
1. TV Card Driver: 4.4.3 WDM
2. TV Card:
2. TV Card Type:
2. TV Card Driver:
3. TV Card:
3. TV Card Type:
3. TV Card Driver:
4. TV Card:
4. TV Card Type:
4. TV Card Driver:
MPEG2 Video Codec:
MPEG2 Audio Codec:
h.264 Video Codec:
Satelite/CableTV Provider: NA Stuff
HTPC Case:
Cooling:
Power Supply:
Remote:
TV:
TV - HTPC Connection:

I cannot get my motek sge2100 motor to move with tv-server. i have tried many different driver versions including mibi's patched skynet drivers, all 4 versions of enhanced drivers that come with mytheatre, technisat 4.4.0, 4.3.2, 4.2.11, 4.4.1 RC2, 4.41 BETA, etc. nothing works to drive the motor. My motor does however drive fine with dvb dream with the majority of the above drivers along with mytheatre and mibi's ss2dieqc.exe application/plugin.

i have read many threads on this forum and have never come across anyone confirming that motor control works in tv-server with a skystar card, despite it being clearly advertised in the wiki under supported tv cards that it does work.

since the 4.4.3 WDM AND 4.4.3 BDA drivers support diseqc commands can we get this working properly in tv-server? the skystar 2 card is a very common card and it would be great if it was properly supported. i have also posted in the support forums trying to get any indication as to why this is not working or to get some confirmation that it does work, i received little response.

I can post the log files however i do not believe these will offer to many clues, the log file does clearly state "diseqc: moving 15 steps west" or "diseqc: moving to position 1" but nothing moves.

This cannot be chalked up to "well its a cheap dvb card, you get what you pay for" as the card works without error in other dvb applications.

Any help would be great.

thanks,
 

infinite.loop

Retired Team Member
  • Premium Supporter
  • December 26, 2004
    16,163
    4,133
    127.0.0.1
    Austria Austria
    does your motor move with any other TV-Application?
    or the tools which come with the Skystar2 (setuppc)

    sadly noone in the team has a motor controled sat dish, so we can't check.
     

    ben001

    Portal Member
    May 23, 2007
    38
    0
    34
    Canada Canada
    Yes it works fine with many other applications including DVB dream, mytheatre, progdvb, Mibi's ss2diseqc program. the application that comes bundled with the technisat drivers cannot be run at the same time as tv-server but must be installed for even basic skystar functionality within tv-server, from my experiences anyway.

    Mibi offers a DLL that could perhaps be retrofitted into tv-server. unfortunately i am not a very good programmer.

    also i am not sure how the scanning is suppose to work even if the motor did move. from my experiences so far an lnb must be setup and a satellite selected. enabling the diseqc motor should somehow override the satellite being selected under lnb (lnb type stays the same but satellites are now selected under motor controls)

    example: trying to point to 82 Nimiq2 sat. currently i have to do the following:

    - move motor to 82 with another application
    - change lnb setting satellite to 82
    - change diseqc motor satellite to 82
    - scan

    if lnb satellite setting is set to the default 2.0 astra the scan completes with 0 transponders scanned (even though diseqc motor satellite is set to 82 and position is stored), over riding the lnb settings also results in a scan of 0 transponders.

    playing around with moving the satellite with another application, then storing with tv-server, moving with the third party app again and trying to move back to the stored position in tv-server results in no motor moves (even though the log states that it is trying to move)

    i hope this all made sense.
     

    infinite.loop

    Retired Team Member
  • Premium Supporter
  • December 26, 2004
    16,163
    4,133
    127.0.0.1
    Austria Austria
    so the setup works, thats good to know.

    i can not make any promises because, as i said, noone in the team has a motor setup right now.
    but please attach all TV-Server log from an "respoition" try, maybe it makes some sense for some of our devs who can then help.
     

    ben001

    Portal Member
    May 23, 2007
    38
    0
    34
    Canada Canada
    The attached logs capture the following procedure, no error.log is generated.


    selected 91

    stored position (pos 1)
    moved east 15 steps (twice)

    selected 82

    store position (pos 2)
    selected 91

    selected go to (stated moving to pos:1)


    while doing all of this the motor did not move at all, i have tried with a larger and smaller step size, moving west/east/up/down. nothing works to move the motor.

    Also i do not know why but signal quality is listed as 0, however i can tune to and watch the unencrypted channels just fine.
     

    pirlone

    Portal Pro
    October 21, 2005
    221
    5
    Croatia Croatia
    any news on this issue?
    i have skystar2 and motorised dish (stab hh 100) but mp 1.0rc4 won't move my dish.
    other apps are moving my dish successfully (mytheatre,..)

    rgs,
    pirlone
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    A [solved] DiseqC problems after upgrade to 1.25 General Support 1
    C Hauppauge HVR-1265 -- does it work with MP1? MediaPortal 1 Talk 0
    Rob Hexenmeister ITV Player still not working for me OnlineVideos 2
    V Do you have to have a smart tv for it to work? Newcomers Forum 4
    M [solved] WTV Files does not play on client, MPEG files works well General 1
    D Does Schedules Direct work with mp 1.24? General Support 3
    J [solved] Blu-ray disc playback does not work. Bugreports 13
    P MP2: US user, OTA - can NOT get SchedulesDirect plugin to work on MP1 or MP2 --> how do I get OTA schedule? General 5
    ratata [solved] Can't get two virtual IPTV cards to work side by side... General Support 6
    S TV-Server MP1 - Automatic search doesn't work Installation, configuration support 2
    T [solved] Green Button start MP not working....but box ticked in config. General Support 1
    mickb [solved] Mediaportal Stops working General Support 5
    C Importer works super slow My TVSeries 5
    D [solved] Movie artwork download stopped working Submit: Bug Reports 9
    A 1.24.0 CD art grabber not working in Shares view 1.24 Pre Release 17
    RoChess Random GPU crash leads to MePo restart, but works fine afterwards MediaPortal 1 14
    Dark Eyes Updated to Windows 10, now TVServer won't work Installation, configuration support 1
    D [solved] EPG Buddy for MP2 - Does it work? General 5
    D Please help with getting Schedules Direct to work Newcomers Forum 10
    B MP 1.23 First time click TV or Recorded TV fails, 2nd ... it will work General Support 5
    M MP 2.2.3 Unable to play .ts recordings and MediaPortal stops working for TV viewing General 31
    rsbrux IR has stopped working Remotes 4
    thepahakurki TVDB import not working My TVSeries 3
    Rob Hexenmeister Work arounds for an alternative home screen General Support 3
    A Working server, no video playback on client General 5
    Similar threads

























    Top Bottom