DLLs can not be found when starting MP2 Server from outside of the ProgramFiles folder (1 Viewer)

hafblade

Portal Pro
January 19, 2011
675
290
Trier, Germany
Germany Germany
Hi guys,

I wanted to write my first plugin for MP2 (NFO movie/series/music videos/... file extractor) and had some problems compiling the MP2 Server.

I had two days ago some complete reinstall of my Windows 7 Ultimate and so all my installations are completely new. I installed VS 2010 Expree C# Edition and GIT and downloaded the newest version of MP2.

After starting the MP2 Server sln file in VS2010 I setup the starting project, compiled and wanted to debug but I always get the same error message that it is not possible to connect to the SQL Server 4 Compact Edition which is shipped with the source code.

I asked Morpheus and we copied the dlls to the root folder of the compiled debug version. Than it worked.
We tried to set some registry fix like here : https://forum.team-mediaportal.com/threads/client-unable-to-load-freetype6-dll.91798/#post-699991
But this did not work.

And than we copied the compiled debug version to the program files/team mediaportal folder. Than it worked.

So it seems that some installations of Windows 7 need the MP2 Server in the ProgramFiles folder or some folder which lies in the PATH or there is some path problem in Windows 7.

At the moment I'm searching for some better solution then using the ProgramFiles folder as workspace but I haven't found any. If you've got some idea I would be really happy. ;)

Thx guys.
 

hafblade

Portal Pro
January 19, 2011
675
290
Trier, Germany
Germany Germany
Ok. It's even stranger than I thought.
I copied my workspace into the Programfiles folder and compiled it again. It even doesn't work there.
It only works when I take the bin/.../debug folder and put it directly into my ProgramFiles (x86) or my ProgramFiles (x86)/team mediaportal folder...

Perhaps it has something to do with the following article...
http://www.samlogic.net/articles/32-64-bit-windows-folder-x86-syswow64.htm
 
Last edited:

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

OP Similar threads Forum Replies Date
horned_reaper [solved] Thumbs not found for Artists Fanart Handler 12
doskabouter Exceptions found due to improved logging General Support 11
N [Finished] Focus problems - I think I've found the bug MediaPortal 2 30
rexdog [solved] no channel's found General 2
N [solved] MediaPortal do not show TV Channels, although Channels found in TV-Server Configuration Television (MyTV frontend and TV-Server) 7
N [solved] MediaPortal do not show TV Channels, although Channels found in TV-Server Configuration Codecs, External Players 2
D Getting Started General Support 30
horned_reaper [Music] 5012: Start current music track from the beginning Improvement Suggestions 37
T [solved] Green Button start MP not working....but box ticked in config. General Support 1
W [solved] MP suddenly Crashes when starting live TV on most channels and on recordings from the same channels General Support 20
W [solved] MP suddenly Crashes when starting live TV on some channels and on some recordings Television (MyTV frontend and TV-Server) 1
vvulture UNKNOWN ERROR when starting live TV General Support 6
ajs Trakt error when start with MP crash Trakt 1
F Recording starts at second time only MediaPortal 1 Talk 6
tano_grasa Movie cover not showing when starting a movie aMPed 0
ajs [solved] 4982: Why this error hard stop when Mediaportal start? MediaPortal 1 3
joecrow AMD Radeon Settings app. won't start after hibernation. General Support 0
Icaro Close MP when the external player is started General Support 13
M MP1 stops responding after Starting Plugins General Support 14
joecool70 Fehlermeldung Error invoking action "Start Timeshift" Allgemeines Support- und Diskussionsforum 1
P MP2 TV Server crashes when starting - throws error remoting exception General 2
P [solved] MP2 fails to install: "Insufficient privileges to start services" General 11
T MP bricht Videos und Serien beim Start ab. Allgemeines Supportforum 4
D Enhance "wake on lan" feature (on demand, not on start) Feature Requests 6
joecrow No Audio after MP Start/Resume from Sleep General Support 0
Similar threads

























Top Bottom