1.12.0 - Dynamic Refresh Rate Changer not working

Discussion in 'Archive' started by spenca, August 5, 2015.

  1. spenca

    spenca Portal Pro

    Joined:
    December 19, 2006
    Messages:
    245
    Likes Received:
    8
    Ratings:
    +10 / 1
    Home Country:
    Austria Austria
    MediaPortal Version: 1.12.0

    Description
    Hi all,



    since Version 1.12 the dynamic refresh rate changer is simple not working any more. Please see "steps to reproduce" for further Information. I've tried some 23.9 Hz movies, every the same.

    Thanks for your help!!

    Mario

    Steps to Reproduce:
    Go to "Moving Pictures", select a movie with different refresh rate than the actual Desktop refresh rate (my case a 23.9 Hz movie); start it, you will see that no refresh rate Change is done.
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. edterbak
    • Team MediaPortal

    edterbak Test Group

    Joined:
    March 4, 2008
    Messages:
    2,114
    Likes Received:
    736
    Gender:
    Male
    Occupation:
    Researcher
    Ratings:
    +1,178 / 5
    Home Country:
    Netherlands Netherlands
    Show System Specs
    I see what could be a double entry in your mediaportal.xml

    <entry name="refreshrate010_name">CINEMA2</entry>
    <entry name="CINEMA2_fps">23.975</entry>
    <entry name="CINEMA2_hz">23</entry>
    <entry name="refreshrate010_ext">
    </entry>

    AND

    <entry name="refreshrate01_name">CINEMA</entry>
    <entry name="CINEMA_fps">23.976</entry>
    <entry name="CINEMA_hz">23</entry>
    <entry name="refreshrate01_ext">
    </entry>

    Is this something you added yourself? I dont have that (23.975) in the xml.
    If so, you can try removing that one, as it might in theory confuse MP.
    Also, you could try enabling the Force Refreshrate option.

    Did you try the 23.9 hz option from within windows? Does it work?

    [edit]
    Could you also try this without Auto3D plugin enabled?
     
    Last edited: August 5, 2015
    • Like Like x 1
  4. spenca

    spenca Portal Pro

    Joined:
    December 19, 2006
    Messages:
    245
    Likes Received:
    8
    Ratings:
    +10 / 1
    Home Country:
    Austria Austria
    Hi,

    2nd option is from myself, delete is no difference.

    23Hz mode within desktop is working.

    Forcing refresh rate is not working, think its a detection problem.

    Will try to disable auti3d and report back.

    Mario
     
    • Like Like x 1
  5. spenca

    spenca Portal Pro

    Joined:
    December 19, 2006
    Messages:
    245
    Likes Received:
    8
    Ratings:
    +10 / 1
    Home Country:
    Austria Austria
    Hi,

    did all the desired changes above, also disabled auto3d plugin, no change. See logs please.
    Thx,
    Mario
     
    • Thank You! Thank You! x 1
  6. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,230
    Likes Received:
    6,191
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,184 / 9
    Home Country:
    France France
    Show System Specs
    Can you manually set Debug in MP configuration, (Watchdog has an issue with 1.12 and it will be already corrected in next MP version). ?
    And try again to get fresh log.
    Thanks :)
    upload_2015-8-6_10-19-32.png
     
  7. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,230
    Likes Received:
    6,191
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,184 / 9
    Home Country:
    France France
    Show System Specs
    But in info log, we get something interesting :

    Code (Text):
    1. [2015-08-06 09:43:51,998] [Log    ] [MPMain   ] [INFO ] - MediaInfoWrapper.MediaInfoWrapper: Inspecting media : D:\Filme\Alice Im Wunderland (2010) (Tt1014759) .mkv
    2. [2015-08-06 09:43:52,029] [Log    ] [MPMain   ] [INFO ] - RefreshRateChanger.AdaptRefreshRate: unable to guess framerate on file D:\Filme\Alice Im Wunderland (2010) (Tt1014759) .mkv
    3. [2015-08-06 09:43:52,029] [Log    ] [MPMain   ] [INFO ] - RefreshRateChanger.SetRefreshRateBasedOnFPS: could not find a matching refreshrate based on 0 fps (check config)
    Mediainfo can detect the fps from the video. So refresh can't act lol.

    You can install mediainfo standalone app and see if it give you the same result.

    To resolve it, you need to recode your movie into the mkv or maybe remux your current mkv and set the correct FPS while muxing :)

    But it should happen only on this video or all your muxed mkv are broken because your muxed tools is buggy somehow :)
     
  8. spenca

    spenca Portal Pro

    Joined:
    December 19, 2006
    Messages:
    245
    Likes Received:
    8
    Ratings:
    +10 / 1
    Home Country:
    Austria Austria
    Hi, youre right. Seems that some files are corrupted.

    Thx for help!

    Mario
     
    • Thank You! Thank You! x 1
  9. edterbak
    • Team MediaPortal

    edterbak Test Group

    Joined:
    March 4, 2008
    Messages:
    2,114
    Likes Received:
    736
    Gender:
    Male
    Occupation:
    Researcher
    Ratings:
    +1,178 / 5
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Ok, Seems 'solved' then.
    I tagged the thread as [no bug].
    If the results after remuxing are still faulty, please continue here. I (or anyone else) will change the prefix accordingly.
    greets
     
    • Thank You! Thank You! x 1
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!