Tools and other software EPG-Buddy a new EPG Tool with easy usage. (1 Viewer)

Lehmden

Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,413
    3,848
    Lehmden
    Home Country
    Germany Germany
    Hi.
    Sadly this is no issue from EPG-Buddy, it's a bug in TVSpielfilm API. So we can not do anything against this. Normally people are not having two year old data laying around disturbing the grabbing process. In regular use cases you will get aware of the issue very soon. But this issue is a rare thing nevertheless. Ever since EPG-Buddy exists this is the third time. First was the renaming of N24 to Welt and RTL Nitro to Nitro. Second was as TVSpielfilm abandoned the local versions of the "Dritte Programme" to offer only one set of data for each station (e,g, no more SWR BW and SWR RP only SWR) and now that SR and SWR are merged together. This time the issue affected users of SR only. SWR only users (like me) are still having a working EPG all the time... I even did not add the fix to my productive installation until today. But of course it will be implemented in the next version of EPG-Buddy with support for TVMosaic.

    BY the way, if the grabber would stop on this it will prevent other sources from being scrapped at all. E.G- if you are using Clickfinder and only use TVSpielfilm as additional source for a few channels it will destroy the complete EPG data including the Clickfinder data. This is no option imho.

    The logging capabilities of the grabber module are not the best. That's tue, But you need to catch every possible error individually. And there are tons of them... A lot of work for not that much effect, that's why this very rare and external caused issue is not captured in the logs, I fear...
     

    ge2301

    Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    7,941
    2,969
    Stuttgart
    Home Country
    Germany Germany
    Hi.
    Sadly this is no issue from EPG-Buddy, it's a bug in TVSpielfilm API. So we can not do anything against this. Normally people are not having two year old data laying around disturbing the grabbing process. In regular use cases you will get aware of the issue very soon. But this issue is a rare thing nevertheless. Ever since EPG-Buddy exists this is the third time. First was the renaming of N24 to Welt and RTL Nitro to Nitro. Second was as TVSpielfilm abandoned the local versions of the "Dritte Programme" to offer only one set of data for each station (e,g, no more SWR BW and SWR RP only SWR) and now that SR and SWR are merged together. This time the issue affected users of SR only. SWR only users (like me) are still having a working EPG all the time... I even did not add the fix to my productive installation until today. But of course it will be implemented in the next version of EPG-Buddy with support for TVMosaic.

    BY the way, if the grabber would stop on this it will prevent other sources from being scrapped at all. E.G- if you are using Clickfinder and only use TVSpielfilm as additional source for a few channels it will destroy the complete EPG data including the Clickfinder data. This is no option imho.

    The logging capabilities of the grabber module are not the best. That's tue, But you need to catch every possible error individually. And there are tons of them... A lot of work for not that much effect, that's why this very rare and external caused issue is not captured in the logs, I fear...
    I didn't mean that additional issues should be captured by EPGBuddy, that would be indeed too much effort. It's enough to add a "pause" in the the grabber script, so one "enter" confirmation is needed to close the console :)
    Then it is guarantieed one can read the last state of the grabber. I was not able to cature the failure myself, because the console closed directly (just a quarter second flashing". I needed 3 times to catch it by pressing "print" in the right moment.
     

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,413
    3,848
    Lehmden
    Home Country
    Germany Germany
    It's enough to add a "pause" in the the grabber script, so one "enter" confirmation is needed to close the console :)
    Normally there is no console you can enter something. It would be terrible if the automated grabbing process will pop up a console window every time,. This only is for a setup scenario, not for usage. Aside it's a Windows feature. If you run any console process from external, the console closes immediately after the running process has ended, no matter if it ends regular or crashes. The only way to catch this is to catch the error and we're at the same state as before. The console window only stays open if you enter the command to execute in the console window by hand.
     

    AdHu86

    Portal Member
    January 14, 2022
    24
    32
    Berlin
    Home Country
    England England
    Hi. I've installed TVMosaic CE today and I found the channel list used by TVMosaic. It's a xml file named "tvmosaic_channels.xml" found in the installation folder. I need to parse this XML file to extract all channel names from and compare it with another xml file "tvmosaic_favorites.xml" where only the internal channel ID for all favorites are stored. More work than expected so most likely it will last longer than thought, sorry...
    Great, glad to read you’ll implement support.
     

    mbb

    Portal Pro
    November 20, 2004
    374
    15
    Home Country
    France France
    Hi there
    Sorry to bother you with my demand
    Could you please add an entry in Setup TV Database with the conbination ArgusTV / MSSQL like with Mediaportal

    You already have all the queries from the mySQL version. It would be no so complicated to add a new connection string
    This link with ArgusTV.bak and DB creation script will last for 7 days
    I will renew it if needed.
     

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    2,099
    1,470
    Home Country
    Germany Germany
    I have no EPG on my MP2 set up and on my MP1 HTPC the EPG is not being updated, both have been working well but something seems to now be broken, at least with TV Spielfilm, I get nothing even with a "Grab now". Attached are the logs for an MP2 manual grab, hope you can fix it.

    UPDATE:-
    Apologies the problem seems to be confined to the TV-Mosaic version of MP2 I was running, I went back to the regular version and the EPG is all OK. I also have rechecked the MP1 HTPC and all is ok there to, very sorry a false alarm.
     

    Attachments

    • EPG-Buddy.zip
      2.7 KB
    Last edited:

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    2,099
    1,470
    Home Country
    Germany Germany
    Contrary to my update on the previous post my MP1 HTPC has not updated and the EPG is now showing no data and as far as I can tell the MP2 setup somehow picked up an old (14-2-2222) grab which is also now showing no data. Looking at the German thread it looks like the problem with TV Spielfilm has already been reported and investigated but would very much appreciate a response here.
     

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,413
    3,848
    Lehmden
    Home Country
    Germany Germany
    Hi.
    Good news. It'S working again...
    We found the error in TVSpielfilm thanks to active help from the forum. Since February 17, TVSpielfilm has deleted the categories without replacement.

    EPG-Buddy3.jpg


    As a result, you can no longer make settings in groups, but have to configure each individual transmitter separately, but it's better that way than not at all. For people who still have their old EPG-Buddy configuration, the default settings will be taken from it. For newcomers or people who have already deleted everything, they have to start from scratch.

    The other two problems, ignoring changed station names at Rytec and crashes when the cache is too full, have not yet been fixed. The first problem can be avoided by mapping in the TV engine and there is a workaround for the second...
    EPG-Buddy4.jpg


    At the bottom left in the settings there is now a checkbox with which you can have the cache cleaned automatically after each run. The checkmark is set by default, so that you don't actually have to worry about it. If you don't check the box, the download may be much faster for a day or two. But after a few days everything crashes again, guaranteed. You should definitely leave the check mark activated.

    The download can be found where it can always be found:


    See also first post.

    I hope it's only now working again. I'm running the full cycle that usually runs in the morning. So far everything works, hey, hey, hey.
     

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    2,099
    1,470
    Home Country
    Germany Germany
    Working again for me with new version, many thanks. Just one problem I have no program data for SWR. How should I set that up, all the other channels worked from the original settings. After the new install SWR entry in the EPG data section was blank so I set it back to SWR BW HD which what the channel name is but there is nothing in the EPG though there seems to be program data in the TVGuide_1.xml?

    UPDATE:-
    I have subsequently again installed the TV Mosaic MP2 version on the PC that exibited this problem and completely removed EPG Buddy. The TV Mosaic EPG is good so I can no longer produce the problem and since it seems no one else has it and everything is working well on my MP1 HTPC I guess we don't have to worry about further.:unsure:
     
    Last edited:

    mbb

    Portal Pro
    November 20, 2004
    374
    15
    Home Country
    France France
    Hi Lehmden,
    I just noticed that the sources were included with EPG-Buddy package.
    It was not too dificult to add the missing Setup TV Database with entry.
    here the link to the modified EPG-Buddy.au3 file based on the latest 7.1.11 version
    Capture.PNG
     

    Users who are viewing this thread

    Similar threads

    Hi. Ja leider. Das Problem haben alle. Es sieht so aus als ob TVSpielfilm am 17.2.2022 seinen Dienst entweder eingeschränkt oder gleich ganz eingestellt hat. Zur Zeit wissen wir auch nichts weiteres. Wenn es schlecht läuft, war es das mit dem EPG-Buddy, leider... Wenn es etwas neues gibt, werden wir das im EPG-Buddy Strang einstellen...
    Hi. Ja leider. Das Problem haben alle. Es sieht so aus als ob TVSpielfilm am 17.2.2022 seinen Dienst entweder eingeschränkt oder...
    Hilfe: seit 17.2.22 stürzt EPG-Grabber nach wenigen Sekunden mit folgender Meldung ab: EPG-Grabber v0.150.326 (22.11.2020), ©...
    Replies
    4
    Views
    452
    Thanks for all of the hard work @kvanc ! To anyone who has not yet tested this out and has the means to, I strongly recommend it. I did not fully understand just how powerful and capable this tool was originally, but this is an amazing piece of work and as kvanc has said, it is capable of grabbing guide data from literally anywhere.
    Thanks for all of the hard work @kvanc ! To anyone who has not yet tested this out and has the means to, I strongly recommend it...
    Hi everyone. My name is Kivanc and I am the developer of Tempest EPG Generator which is a single php file xmltv formatted epg...
    Replies
    43
    Views
    3K
    TV Mosaic was already set up as a share and doing a re-import did not bring in the recording also tried removing and re-adding the source and although the import arrow showed up my recording folder remains empty.
    TV Mosaic was already set up as a share and doing a re-import did not bring in the recording also tried removing and re-adding the...
    The current TV engine (TVE3) for Media Portal 1 and 2 was developed long time before and is not state of the art any more...
    Replies
    232
    Views
    19K
    Having used MP1 since 15 years, these epg related problems occuring after a fresh install stumble me. Needed to change a system hdd and decided it was time for a clean install anyway. Other hardware (C2D, 8 Gb ram, no tv cards - IP only) unchanged. Was running an earlier Win10 version with MP 1.24 which had been updated for years...
    Having used MP1 since 15 years, these epg related problems occuring after a fresh install stumble me. Needed to change a system...
    Having used MP1 since 15 years, these epg related problems occuring after a fresh install stumble me. Needed to change a system...
    Replies
    0
    Views
    802
    Hi doskabouter I only use the line jump for the description. I modify the XmlTV file from EPG-Buddy with WebGrabPlus (rex) only in the description with \n. My new description is: Genre, year of production \n Original description \n Actors
    Hi doskabouter I only use the line jump for the description. I modify the XmlTV file from EPG-Buddy with WebGrabPlus (rex) only...
    Just installed 1.28, and the new XML EPG importer refuses to import the xml spit out by EPG-Buddy. Older versions of MP1 ingest it...
    Replies
    23
    Views
    3K
    Top Bottom