EPG Data off by -20 hours? (3 Viewers)

Dementia Dog

Portal Member
January 15, 2020
16
2
62
United States of America United States of America
Country flag
I'm using EPG Buddy to import data from TV Guide.com into MP2. Everything seems to be working (e.g. no error messages are displayed), but the end result is the guide data is off by 20 hours. For example, what it shows as on TV right now is actually not on until 20 hours later.

In the Plugin Settings for xmlTV I tried setting "Apply time compensation when loading tvguide.xml" but still the same problem. Tried with this setting off; set on with 20 hours; set on with -20 hours; and set on with 20- hours. Each time I selected Force Import but the end result is the same in each case.

Any suggestions?
 

Jasmeet_181

Portal Pro
September 5, 2007
403
326
United Kingdom United Kingdom
Country flag
It's not obvious from the interface but those are two separate settings, have you tried setting your hours to 0 and leaving "Apply time compensation..." unchecked? Also, are the programme start/stop times in your tvguide.xml correct and does it specify a timezone compensation?

From the wiki:
Apply timezone compensation when loading tvguide.xml
Normally timezone information inside tvguide.xml is ignored; it is assumed that all programme times are local times.

If this option is ticked, the timezone information inside tvguide.xml will be used to convert programme times to local times. This allows you to use data that is intended for another timezone without any hassles. Daylight savings changes should be handled automatically.

Example:

You live in New Zealand (UTC+12).

You receive some channels from Australia via satellite.

The tvguide.xml for the Australian channels contains times like YYYYMMDDhhmmss + 1000 (Australia Eastern Standard Time).

Ticking this option will convert the programme data to New Zealand standard time.

The hours and minutes fields described below should be set to 0 and 0.
Hours and Minutes
The two text boxes (Hours and Minutes) provide a way to specify additional compensation, regardless and independent of the Apply timezone compensation setting. The offset specified here will be added to (or subtracted from) all times in tvguide.xml.

It should not be necessary to use these fields unless your tvguide.xml does not contain timezone information.

Example:

You live in New Zealand (UTC+12).

You receive some channels from Australia via satellite.

The tvguide.xml for the Australian channels contains times like YYYYMMDDhhmmss (ie. no timezone information, times are assumed to be Australia Eastern Standard Time).

AEST is UTC+10.

Ticking apply timezone compensation will have no effect.

The hours and minutes fields should be set to 2 and 0
.
 

Dementia Dog

Portal Member
January 15, 2020
16
2
62
United States of America United States of America
Country flag
Thank you for the reply and for the information on those parameters.

Yes, I have tried with the "Apply time compensation..." parameter unchecked and Hours and Minutes each set to 0.

I ran another test this morning, starting with a manual grab of data from within EPG Buddy. The TVGuide xml file shows an offset of -0400 for every program.

1589904241111.png


Next I requested a "Force import" on the xmlTV parameter page. It appears that xmlTV is ignoring the -0400 offset. You can see from the screen shots below that the program "News 6 at 9 AM" displays within the MP2 Guide at 13:00, rather than at 09:00.

1589904595349.png


1589904607446.png



Am I doing something wrong? Or is this possibly a bug?
 

TLD

Portal Pro
October 26, 2007
708
125
Rainy Washington
United States of America United States of America
Country flag
You need to put the hours that your guide is off by in the hours box (-4) will move the info in the epg back 4 hours (4) will add 4 hours to the info in the epg. or the other way around it's been a while since i set mine up. Then force import to apply.
 

Dementia Dog

Portal Member
January 15, 2020
16
2
62
United States of America United States of America
Country flag
OK, so I unchecked the "Apply time compensation..." parameter and entered -4 for Hours and now it works! Yay!

Thank you for the replies!
 

TLD

Portal Pro
October 26, 2007
708
125
Rainy Washington
United States of America United States of America
Country flag
OK, so I unchecked the "Apply time compensation..." parameter and entered -4 for Hours and now it works! Yay!

Thank you for the replies!
You need to keep the (Apply time compensation) checked. That setting is only applied after you save and leave the plugin.
 

Dementia Dog

Portal Member
January 15, 2020
16
2
62
United States of America United States of America
Country flag
Thank you TLD, but now I'm really confused! The text from the Wiki (see post above) says (Apply time compensation) is independent of Hours and Minutes. I could not get a correct guide when that parm was checked...it only worked once I put in -4 Hours. I don't think I tried it with the parm checked and -4 Hours, but I did try with it checked and 0 Hours.
 

TLD

Portal Pro
October 26, 2007
708
125
Rainy Washington
United States of America United States of America
Country flag
That's how mine is setup, and it's the only way it works for me.
My guess is that when you put the -4 hours in the hour box and unchecked the "Apply time compensation" you didn't save and leave the plugin, so when you forced the import the unchecked "Apply time compensation" setting had not been saved.
 

Dementia Dog

Portal Member
January 15, 2020
16
2
62
United States of America United States of America
Country flag
Yeah, at this point I certainly no longer know what I did when! ;) I have it scheduled to run every morning at 1am so I think I will just leave it until tomorrow & see what happens. Thank you again for your help!
 

Users who are viewing this thread

Similar threads
OP Title Forum Replies Date
D Problem getting Schedules Direct EPG to load data Installation, configuration support 4
D EPG No Data General Support 2
T Freeview EPG-Anyone know what channel sends the guide data? Electronic Program Guide 10
G Newb trying MP2, trouble with guide data General 5
J EPG data recheck? Feature Requests 0
Z EPG-Buddy / xmltv-plugin - zwei Quellen, selber Sender Elektronischer Programmführer (EPG) 2
S Epg does not open at the last watched channel + epg grab stuck if not manually deleted first Electronic Program Guide 0
ge2301 MP2 - V2.4 [MP2-867] Dynamic font scaling for EPG programs in relation to number of rows MediaPortal 2 2
F EPG/Scheduler case sensitive Feature Requests 14
Andy_2639 Few "Continuity error..." after EPG scan General Support 2
R 1.27.0 Digiguide for epg for DVBS Electronic Program Guide 0
CyberSimian Split programmes in the UK DVB-T EPG TV-Server 0
C MP2 - V2.3.1 EPG view: incorrect displayed fonts Submit: Bug Reports 2
R Deadlock in TV Server if recording while importing EPG TV-Server 10
C MP2 - V2.3 Nereus: EPG context menu not available anymore at a running program General 8
P MP2 - V2.3 EPG Frustration................ General 26
cbr954rr Clickfinder epg import wrong channels? General 0
cbr954rr EPG Genre map categories do not match tv server categories General 4
cbr954rr Rename epg-genre category General 5
M Add Radio channels and EPG to Mediaportal xmlTV 3
M EPG color by length of TV-show MediaPortal 1 Talk 1
D Downloading EPG XML file: Installation, configuration support 0
G Q about scheduling weekly series when epg lists duplicate back to back episodes each week General Support 2
F Mini EPG more information? WMC Skin 4
N No TV or EPG on fresh install General 0

Similar threads

Top Bottom