Epg does not open at the last watched channel + epg grab stuck if not manually deleted first (1 Viewer)

sortie

New Member
April 7, 2021
1
0
Home Country
Sweden Sweden
Country flag
Having used MP1 since 15 years, these epg related problems occuring after a fresh install stumble me.

Needed to change a system hdd and decided it was time for a clean install anyway. Other hardware (C2D, 8 Gb ram, no tv cards - IP only) unchanged. Was running an earlier Win10 version with MP 1.24 which had been updated for years without problems, more than the M$ related ones of course. Server/client with one external client.

With the fresh Win10 (Pro) 20H2 + MP 1.27 setup sorted and running, I have two problems not seen before.

1) I have used the webepg + power scheduler plugins for a very long time, without major problems. Usually set the system to grab late night once a week but now it gets stuck - every time. A few channels are updated and then the grabber stalls (deadlocks) from some sort of delete problem, according to logs. I have tried repairing the database multiple times without improvement. Now I did notice the new (?) manual section in tv server configuration. Never seen or tried it before but after a refresh epg command, manual grabbing works perfectly fine. Have repeated this multiple times and it is a fact - automated grabbing hangs, manual grabbing hangs in a similar way, but if the epg is refreshed manually first, manual grabbing works perfectly fine. Webepg checkbox is ticked to delete before writing new program info, as usual.

2) With this install, there is also a (major!) problem with the epg always opening with and returning to the first channel in the list, no matter what was watched previously. Extremely annoying with long epgs and the most interesting channels somewhere in the middle. It does not matter if the epg is entered from the tv home section or returned to after stopping a watched channel - it always reverts to the first channel. This is not related to MP not saving the last watched channel - it is correctly displayed in the tv home section and also saved (including group) in the mediaportal xml. You just will not get there when entering the epg, no matter what you do.

What really makes this interesting is that I reinstalled the single seat setup on my laptop at the same time (cleaned out every trace of the old MP 1.24 install because of a hopeless mess after testing MP2) and guess what: entering the epg, always at the last watched channel, works perfectly fine - with the very same settings. MP 1.27 and webepg as well, with the major difference that this Win10 (Pro) system has not updated to 20H2 yet.

Edit: I have now tried grabbing epg in the laptop system and it does stall the same way as the stationary computer, with an identical fault log about the webepg deadlocking at delete after a few channels. Please observe that although the behaviour is the same, it does not stall at the very same channel - this system grabs the list in reverse direction (don't ask me why, channel sorting in mptv...). Anyway: after a manual epg refresh, this system also grabs perfectly fine.

Because of the similar behaviour in my two systems, I have to conclude that these problems relate to late (1.25-1.27) MP versions. If nobody has a clue here, I guess I will just have to try and reinstall 1.24 as a fault tracing measurement but with 200 channels to scan and map for epg + grabbing this really is a headache.

Please excuse me for not entering system details in any separate section but it was a long time since posting and the forum entry link does not work. Log after the webepg deadlock is provided. Just tell me if anything else is needed.
 

Attachments

  • SetupTv-Error.1.log
    2.1 KB · Views: 0
Last edited:

Users who are viewing this thread

Similar threads

Sorry for the late response. In my experience, the EPG grabbing of a single transponder takes 2 to 3 minutes. Afterwards it takes 1 to 2 minutes to write the data to disk. To speed up the EPG stuff (not only writing but also reading the EPG guide in MediaPortal), I changed the program table (and only that table) from InnoDB to...
Sorry for the late response. In my experience, the EPG grabbing of a single transponder takes 2 to 3 minutes. Afterwards it takes...
I get a few "Continuity error..." after the EPG scan finished: [2021-01-30 18:56:10,278] [4c45530] [18c8] - mhw reset [2021-01-30...
Replies
2
Views
1K
Pre Releases are provided as a way for the community to test and give feedback on all the exciting things we have lined up for the next release. We allocate about one month for Pre Release testing. In that time we will only fix bugs, after which comes the final release! Highlights of this release Bugfixes: [MP1-4969] - Fix typo in...
Pre Releases are provided as a way for the community to test and give feedback on all the exciting things we have lined up for the...
Pre Releases are provided as a way for the community to test and give feedback on all the exciting things we have lined up for the...
Replies
0
Views
2K
Good work guys!
Good work guys!
We are proud to present MediaPortal 2.2.1 After the release of MediaPortal 2.2 Final the team focussed on improving usability and...
Replies
1
Views
3K
Ah ok, I thought you ment from FullEPG. For MiniEPG the problem is known (therefore I just use FullEPG). Root cause is, that the MiniEPG is only an overlay and not indepentent screen, so it's not part of the workflow history. ESC is defined to bring you back one step in the workflows. In your case this would be the screen before...
Ah ok, I thought you ment from FullEPG. For MiniEPG the problem is known (therefore I just use FullEPG). Root cause is, that the...
After many years with MP1, I gave MP2 a try. Reasons: - I like the centralized media management - constant problems with freezing...
Replies
3
Views
951
How are things going Jamie? Have you given up, or are you just busy?
How are things going Jamie? Have you given up, or are you just busy?
I have so many symptoms that I am wondering if I shouldn't just uninstall and wipe everything and start over. #4 below is the only...
Replies
11
Views
3K
Top Bottom