Error getting playback urls for video

Discussion in 'OnlineVideos' started by fritzelly, July 19, 2015.

  1. fritzelly

    fritzelly Portal Member

    Joined:
    January 17, 2011
    Messages:
    20
    Likes Received:
    0
    Ratings:
    +0 / 0
    "Error getting playback urls for video"

    Seems about the only sites that work are YouTube and NASA

    Log attached, SAF latest version installed along with the URL splitter.
    This is a brand new install

    Thanks for any help


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. eetaylog

    eetaylog Portal Pro

    Joined:
    March 6, 2007
    Messages:
    874
    Likes Received:
    32
    Gender:
    Male
    Occupation:
    Electronics technician
    Location:
    South London
    Ratings:
    +44 / 2
    Home Country:
    England England
    Show System Specs
    Also have this issue. Affects all of my sites apart from Youtube. Can navigate around and see links to content, but when you click to play something it stays at 0% buffering and then craps out with "Error getting playback urls for video".

    Im running Win7 with MP1.12 and latest version of Online Videos.
     
    • Missing System Logs and/or Specs Missing System Logs and/or Specs x 1
  4. doskabouter
    • Premium Supporter

    doskabouter Community Plugin Dev

    Joined:
    September 27, 2009
    Messages:
    2,922
    Likes Received:
    859
    Location:
    Nuenen
    Ratings:
    +1,254 / 1
    Home Country:
    Netherlands Netherlands
    Show System Specs
    I see you've tried 2 sites (svtplay and filmon). Don't know if svtplay is/was broken but I definitely can confirm that filmon is broken, so that you're unable to playback from filmon is to be expected.

    There is a section in the onlinevideos configuration where you can test if codecs and such are properly installed
     
  5. fritzelly

    fritzelly Portal Member

    Joined:
    January 17, 2011
    Messages:
    20
    Likes Received:
    0
    Ratings:
    +0 / 0
    Had already checked the codecs and they were all fine.
     
  6. doskabouter
    • Premium Supporter

    doskabouter Community Plugin Dev

    Joined:
    September 27, 2009
    Messages:
    2,922
    Likes Received:
    859
    Location:
    Nuenen
    Ratings:
    +1,254 / 1
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Then you just may have had some bad luck testing just those sites that were broken.
    Are there any particular sites you want to watch and are not working?
     
  7. eetaylog

    eetaylog Portal Pro

    Joined:
    March 6, 2007
    Messages:
    874
    Likes Received:
    32
    Gender:
    Male
    Occupation:
    Electronics technician
    Location:
    South London
    Ratings:
    +44 / 2
    Home Country:
    England England
    Show System Specs
    Please see attached for my logs on the same issue. YouTube works fine, but trying to watch something on iplayer throws a URL error.

    Looking at the logs shows that the Warning is coming from the line...

    Code (Text):
    1. [08-10 21:01:27,256] [OnlineVideos] [WARN ] System.Runtime.InteropServices.COMException (0xFFFFFFEC): Exception from HRESULT: 0xFFFFFFEC
    2.    at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)
    3.    at System.Runtime.InteropServices.Marshal.ThrowExceptionForHR(Int32 errorCode)
    4.    at OnlineVideos.MediaPortal1.Player.OnlineVideosPlayer.BufferFile(SiteUtilBase siteUtil)
    Not sure what this exception is, any pointers would be appreciated.

    TIA :)
     
  8. doskabouter
    • Premium Supporter

    doskabouter Community Plugin Dev

    Joined:
    September 27, 2009
    Messages:
    2,922
    Likes Received:
    859
    Location:
    Nuenen
    Ratings:
    +1,254 / 1
    Home Country:
    Netherlands Netherlands
    Show System Specs
    First thing you have to do is let autoupdate do it's job. That pulls in the newest dll's of the site (hint: in onlinevideos.log is stated that my dll (OnlineVideos.Sites.doskabouter) is from june, but it should be from august.
    Sitemanager is explained here https://code.google.com/p/mp-onlinevideos2/wiki/SiteManager for manual updates, but the easiest thing is to go to the onlinevideos configuration and tell it to "update sites on first load" only every couple of hours.

    If that's already configured correctly, it could be that mediaportal hasn't sufficient rights to update the dll's in the program files directory.
     
  9. eetaylog

    eetaylog Portal Pro

    Joined:
    March 6, 2007
    Messages:
    874
    Likes Received:
    32
    Gender:
    Male
    Occupation:
    Electronics technician
    Location:
    South London
    Ratings:
    +44 / 2
    Home Country:
    England England
    Show System Specs
    Just did an automatic update and also changed the update settings to every couple of hours for future use but still the same problem. New logs attached :(
     
  10. doskabouter
    • Premium Supporter

    doskabouter Community Plugin Dev

    Joined:
    September 27, 2009
    Messages:
    2,922
    Likes Received:
    859
    Location:
    Nuenen
    Ratings:
    +1,254 / 1
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Compiletime of OnlineVideos.Sites.doskabouter is still from june. Next guess would be insufficient rights on the onlinevideos directory in c:\program files
     
  11. eetaylog

    eetaylog Portal Pro

    Joined:
    March 6, 2007
    Messages:
    874
    Likes Received:
    32
    Gender:
    Male
    Occupation:
    Electronics technician
    Location:
    South London
    Ratings:
    +44 / 2
    Home Country:
    England England
    Show System Specs
    So basically Onlinevideos isnt updating its sites on update. How do i fix the issue of rights? It was all working up until a few months ago, not sure what could have changed.

    Thanks again.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!