Error loading several EPG channel icons (1 Viewer)

civikdude

Portal Pro
March 17, 2005
110
0
U.S.A.
Several of the EPG channel icons downloaded using the xmltv.exe tool are not loading in MP. An error is logged for each "bad" icon. The only difference I can see is that the image properties differ slighly from those of other "working" icons.

Image properties for all "bad" icons:
WxH: 30x30 pixels
Resolution: 96 dpi
Bit Depth: 8

It looks like all other "working" icons have a resolution of 72 dpi, and a bit depth of 24.

Receiving the following error in error.log:
9/19/2005 11:04:03 AM TextureManage:LoadGraphic(thumbs\tv\logos\ESPN2.jpg) failed:Error in the application.
-2005529767 (D3DXERR_INVALIDDATA)
at Microsoft.DirectX.Direct3D.TextureLoader.FromFile(Device device, String srcFile, Int32 width, Int32 height, Int32 mipLevels, Usage usage, Format format, Pool pool, Filter filter, Filter mipFilter, Int32 colorKey, ImageInformation& srcInformation, PaletteEntry[]& palette)
at Microsoft.DirectX.Direct3D.TextureLoader.FromFile(Device device, String srcFile, Int32 width, Int32 height, Int32 mipLevels, Usage usage, Format format, Pool pool, Filter filter, Filter mipFilter, Int32 colorKey, ImageInformation& srcInformation)
at MediaPortal.GUI.Library.GUITextureManager.LoadGraphic(String strFileName, Int64 lColorKey, Int32 iMaxWidth, Int32 iMaxHeight, Int32& iWidth, Int32& iHeight)


Steps to recreate:
1. copy attached image "ESPN2.jpg" to MediaPortal\thumbs\tv\logos\[name].jpg, where [name] is a valid channel name in MP Setup > Television > TV Channels.
2. open mediaportal, navigate to MyTV > TVGuide.
3. scroll down the EPG listing until the channel line is displayed
4. graphic is gray in color (blank)
5. exit mediaportal
6. view error.log for error text

Regards,
Aaron
 

civikdude

Portal Pro
March 17, 2005
110
0
U.S.A.
Can someone take a look into this? MP should be able to handle the channel icons that are delivered by zap2it.com (xmltv).

FYI, looking at the first post, the paste of code separated the file name (ESPN2.jp<space>g). The log file does not have this space, nor does the actual file name. I just wanted to clarify in case that might throw somebody.

Repaste:
(thumbs\tv\logos\ESPN2.jpg)

Regards,
Aaron
 

civikdude

Portal Pro
March 17, 2005
110
0
U.S.A.
Haven't heard anything on this. It fills the error log up fairly quickly. These are not custom images, they are downloaded directly from zap2it.com. Can someone please test and confirm?

Regards,
Aaron
 

scoop

Retired Team Member
  • Premium Supporter
  • November 14, 2004
    614
    7
    Country flag
    Hi civikdude,

    I just tried the logo you posted on my MP installation 0.2.0.0-RC1. I can confirm the problem you see. I've renamed the logo to "Nederland 1.jpg" to match a station I got here. Here's the (same) error from MediaPortal.log:

    Code:
    4-10-2005 21:49:55 TextureManage:LoadGraphic(thumbs\tv\logos\Nederland 1.jpg) failed:Fout in de toepassing.
    -2005529767 (D3DXERR_INVALIDDATA)
       at Microsoft.DirectX.Direct3D.TextureLoader.FromFile(Device device, String srcFile, Int32 width, Int32 height, Int32 mipLevels, Usage usage, Format format, Pool pool, Filter filter, Filter mipFilter, Int32 colorKey, ImageInformation& srcInformation, PaletteEntry[]& palette)
       at Microsoft.DirectX.Direct3D.TextureLoader.FromFile(Device device, String srcFile, Int32 width, Int32 height, Int32 mipLevels, Usage usage, Format format, Pool pool, Filter filter, Filter mipFilter, Int32 colorKey, ImageInformation& srcInformation)
       at MediaPortal.GUI.Library.GUITextureManager.LoadGraphic(String strFileName, Int64 lColorKey, Int32 iMaxWidth, Int32 iMaxHeight, Int32& iWidth, Int32& iHeight)
    Can you confirm this worked on previous versions? Or did it never work?

    Kind regards,
    Michel
     

    civikdude

    Portal Pro
    March 17, 2005
    110
    0
    U.S.A.
    scoop said:
    I can confirm the problem you see.
    Thanks for testing!!

    scoop said:
    Can you confirm this worked on previous versions? Or did it never work?
    This I'm not sure of. I'm under the impression that all channel icons worked when I was using version 0.1.1.0, but even so I'm not sure whether the icons themselves are the same (downloaded from zap2it.com) or have been added/updated since using 0.1.1.0. I cleared everything on my system since then, and have only recently added the channel icons.

    I think it comes down to graphics support?!

    Image properties for all "bad" icons:
    WxH: 30x30 pixels
    Resolution: 96 dpi
    Bit Depth: 8

    Image properties for all "good" icons:
    WxH: 30x30 pixels
    Resolution: 72 dpi
    Bit Depth: 24

    Regards,
    Aaron
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    G [solved] timeshift error Newcomers Forum 2
    C Can't install any extensions - DLL error Installation, configuration support 19
    horned_reaper Errors in FH log ... Fanart Handler 1
    joecrow 1.25.0 5031: Error on Install. Bugreports 24
    M MediaPortal2 TV Config Error on Install (0x80004005) General 7
    J Blue Screen Error Submit: Bug Reports 0
    G Q about scheduling weekly series when epg lists duplicate back to back episodes each week General Support 2
    Rob Hexenmeister Dependency error on install v2.3.2.0 OnlineVideos 28
    catavolt [WiP] When changing theme in my skins, I always get this error message in logs MediaPortal 1 9
    F Error invoking action 'GetNowNextProgramForGroup' Submit: Bug Reports 3
    B MP 2.2.3 Error playing videos from NAS Submit: Bug Reports 2
    vvulture UNKNOWN ERROR when starting live TV General Support 6
    doskabouter Build errors MediaPortal 1 9
    ajs Trakt error when start with MP crash Trakt 1
    horned_reaper MediaPortal configuration error log message General Support 1
    horned_reaper MiniDisplayStatus error log messages General Support 7
    horned_reaper [solved] GUITextureManager Load2 log error messages Fanart Handler 1
    horned_reaper MediaPortal.LastFM.LastFMException error log message General Support 1
    R [solved] No Response from Home Page - Error Newcomers Forum 0
    globaldonkey Music Database Error Listen Music 1
    ajs [solved] 4982: Why this error hard stop when Mediaportal start? MediaPortal 1 3
    thepahakurki Trakt error: Invalid or missing file Trakt 8
    Z Error when attempting to play Blu Ray General 1
    F Audio render and font error in my logs General Support 2
    geotwticher [solved] Fatal Error 0x80070643 during MP2 installation General 7
    Top Bottom