Failed to upgrade the Database (TVServer) (1 Viewer)

frankytv

Portal Pro
November 17, 2009
56
4
Germany Germany
Hi,

on updating from 1.23 to 1.30b it gaves me an error while installing the TV Server
"unable to update Database". (yes, i killed the TVService before)
I can't open the TV-Server Configuration, because i get the same error again.

Edit: the Popup is "Failed to upgrade the Database"

Here are the two Logfiles
 
Last edited:

frankytv

Portal Pro
November 17, 2009
56
4
Germany Germany
It can't update the Database. I get the Error also if i try to open the TVServer Config.

Thanks, but it has nothing to with the stopped TVService.
(Like i said, it was stopped 100%)
 
Last edited:

legnod

MP Donator
  • Premium Supporter
  • September 24, 2011
    1,115
    323
    Stuttgart
    Germany Germany
    is the mysql service running at the moment? it sounds that maybe there is a problem. Open the *.err file inside the "data" folder (normally located in ProgramData\mysql\mysql Server 5.1\) or something.
     

    frankytv

    Portal Pro
    November 17, 2009
    56
    4
    Germany Germany
    well, if the SQL wouldn't run, I couldn't watch TV.
    Like i said, everything else is working, only the TV SERVER Config can't be opened cause of the Database upgrade error.
     

    singer36

    Portal Pro
    October 11, 2006
    64
    4
    France France
    Hi all,

    just got the same problem... what i did is very easy in fact :
    - stop TV service
    - stop MySQL Service
    - rename or delete MySQL data (c:\program data\lysql\mysql 5.1\data\mptvdb)
    - restart 'TV Server config'
    - start over the manual configuration...

    hope that'll help !
     

    frankytv

    Portal Pro
    November 17, 2009
    56
    4
    Germany Germany
    thanks for reply,
    but then all Channels etc. lost, isn't it ? Then its like i do a clean install.

    EDIT:
    i guess i found a fix for it.
    After you renamed the mptvdb to mptvOLD.
    Start over to generate a new one.

    If the new one is generated, kill Mysql and TV Service
    Copy all Files from the OLD Folder to the NEW one EXCEPT the 3 VERSION. Files.Restart MySQL, start TV Server Config and everything should be fine. :)
     
    Last edited:

    astrapowerrr

    Portal Pro
    May 21, 2008
    180
    13
    43
    ijsselstein
    Netherlands Netherlands
    I reinstalled totally new tvserver for this because I thought I messed up MySQL bad!.... hmmmm
    but I still have managed to save my old mptvdb folder...
    only one thing I would like to use are my schedule recordings.
    can I get these out of my old folder and import them into my new database?
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    G MP1 TV Server "failed to upgrade the database" using MS Sql Server Installation, configuration support 3
    joecrow Online Videos fails after MP 1.23 upgrade. 1.23 Pre Release 37
    D Upgrade to MP2.2 pre release fails with failure to start service 2.2 Archive 32
    joecrow 1.25.0 Radio Time plugin fails after Resume from Sleep with MP 1.25 Bugreports 3
    M MovingPictures: Hang at retrieving details (connection fails) ? Moving Pictures 23
    Grisu002 Failed to startup - TV Server funktioniert nicht Allgemeines Support- und Diskussionsforum 0
    Dark Eyes TVService locks up or fails to restart on resuming from sleep, and crashes when grabbing EPG Installation, configuration support 7
    T [solved] failed to-startup tvservice Installation, configuration support 1
    B MP 1.23 First time click TV or Recorded TV fails, 2nd ... it will work General Support 5
    W Setup data connection - mySQL connection failed Installation, configuration support 1
    BrownGhost MP-TVSeries, Failed to save xml to cache, and not adding any info to tvseries from tvdb My TVSeries 4
    C Setup failed: 0xfffffff7 Allgemeines Support- und Diskussionsforum 1
    B TV tuner fails to initialise Watch / Listen Media 0
    P [solved] MP2 fails to install: "Insufficient privileges to start services" General 11
    J DVB-S2 card fails to tune? Subchannel count increasing Television (MyTV frontend and TV-Server) 3
    joecrow Scheduled Recordings Failed (MP 1.22) General Support 12
    rexdog [solved] MP2 Instal failing on WIN10 General 2
    porky996t DVB Sat card possibly failed General Support 1
    joecool70 [solved] Installationsprobleme: MP2-Server failed to start Allgemeines Support- und Diskussionsforum 25
    Ralph Holmes [solved] MP2 fails to start after re-boot 2.2 Archive 8
    Holzi [solved] MediaPortal 2 will not install - Failed to start services MediaPortal 2 1
    B [further infos missing] Install failed Exit code: 0xfff7, restarting: No 2.2 Archive 1
    S Display driver failed to start, using microsoft basic display driver instead General Support 23
    Frans Nijhuis [further infos missing] Deleting all TV channels and all channel groups in "MP 2 TV configuration" fails 2.2 Archive 1
    Stéphane Lenclud [fixed] libbluray submodule update fails MediaPortal 1 3
    Similar threads

























    Top Bottom