Filme-Import in Mediaportal 2x (1 Viewer)

Andreas Schneider

Portal Pro
August 6, 2012
90
5
47
Germany Germany
Country flag
Ich hatte in folgendem Thread Link nach dem Import von Filmen, die in unterschiedlichsten Formaten vorliegen, gefragt. Antwort war (in Kurzform): geht so nicht.

Meine Frage ist: warum funktioniert der Import in MP2 nicht so wie in MP1? Das ist ein absoluter Rückschritt. Ich habe alle Filme in Moving Pictures drinn. Für jeden Film habe ich eine nfo-Datei angelegt, inclusive Bilder, Beschreibung usw..

Ich kann nun wirklich nicht mehrere Hundert Filme umwandeln, nur weil MP2 in dieser Hinsicht ein Rückschritt ist.

Kann man den Import nicht wieder genau so wie in MP1 bzw. Moving Pictures machen?
 

HTPCSourcer

Retired Team Member
  • Premium Supporter
  • May 16, 2008
    11,431
    2,334
    Germany Germany
    Country flag
    Ich hatte in folgendem Thread Link nach dem Import von Filmen, die in unterschiedlichsten Formaten vorliegen, gefragt. Antwort war (in Kurzform): geht so nicht.
    Das ist nicht die Antwort, die dir gegeben wurde, bzw. diu hast sie nur falsch interpretiert.

    Für jeden Film habe ich eine nfo-Datei angelegt, inclusive Bilder, Beschreibung usw..
    Ja ist doch großartig. Diese Daten werden direkt eingelesen.

    Ich kann nun wirklich nicht mehrere Hundert Filme umwandeln, nur weil MP2 in dieser Hinsicht ein Rückschritt ist.
    Ich weiß nicht, was dich auf den Gedanken bringt, die Filme umwandeln zu müssen. Bisher hat jeder, der sich MP2 näher angeschaut hat, hier eher von Fortschrit gesprochen.

    Ich schlage vor, dass du dir zunächst selbst ein Bild machst, bevor du auf Grundlage falscher Annahmen unzutreffende Schlusfogerungen ziehst. MP2 lässt sich leicht testen. Deaktiviere den MP1 TVService, installiere MP2, richte deine Medienquellen ein - lass dem Programm genügend Zeit zum Import (Medien, Fanart, usw. kommt alles automatisch) und mach dir dann ein Bild.
     

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,115
    3,697
    Lehmden
    Germany Germany
    Country flag
    Hi.
    warum funktioniert der Import in MP2 nicht so wie in MP1?
    Ich selbst nutze MP1 ja schon seit Jahren nicht mehr. Trotzdem habe ich zufällig gestern mal wieder versucht, versuchen müssen, eine menge Filme in Moving Pictures einzulesen, für einen Bekannten, nicht für mich.. Die reinste Katastrophe, ehrlich. Obwohl alle Filme mit .nfo versehen waren, wurde ca 1/3 erst gar nicht erkannt. Und es gab auch keine einfache Möglichkeit die Filme manuell einlesen zu lassen. Das einzige was ging war, für jeden Film einzeln einen leeren DB Eintrag zu erzeugen und alles per Hand einzutragen.... Bei Hunderten von Filmen ein ganz schlechter Witz... Bei einer schnellen Gegenprobe mit MP2 wurden alle Filme zu 100% korrekt eingelesen. Wenn .nfo (auch solche von Moving Pictures) vorliegen, so werden die Filme garantiert fehlerfrei in MP2 eingelesen. Bei Moving Pictures dachte ich, wäre das auch so, aber das war wohl nichts, warum auch immer...

    Was das "Umwandeln Müssen" betrifft, das hast du schlicht falsch verstanden. Ich habe lediglich gesagt, das DVD und/oder ISO grundsätzlich eine extrem ungünstige Art sind, Filme im PC zu lagern/verwenden. Das ist völlig unabhängig von MP 1 oder 2 oder Kodi oder,... immer der Fall... Das heißt nicht, das man sie nicht nutzen kann, nur das es viel umständlicher ist (was auch bei MP1 der Fall ist).
     

    Helios61

    Retired Team Member
  • Premium Supporter
  • January 30, 2008
    4,587
    871
    58
    NRW
    Germany Germany
    Country flag
    Obwohl alle Filme mit .nfo versehen waren, wurde ca 1/3 erst gar nicht erkannt.
    Dann hast du was falsch gemacht.
    Und es gab auch keine einfache Möglichkeit die Filme manuell einlesen zu lassen.
    Ist problemlos möglich.

    Letzte Woche habe ich ein HW Upgrade bei meinem HTPC durchgeführt, danach Win10 und MP1 komplett neu installiert. Lief alles komplett problemlos und geschmeidig. Das neue Einlesen meiner Filme in MovingPictures ging schnell und nahezu fehlerlos. Lediglich einige Sortierungen waren falsch (Die Hobbit Filmreihe wurde als "Herr der Ringe" Filmreihe sortiert). Ähnlich gings mit meinen TV-Serien (188). Bis auf einige Dokus, die als Terra X Episoden einsortiert wurden, anstatt als eigenständige Serie ging alles absolut problemlos. Kurz noch den Watched Status importiert und alles war gut.

    Ich finde es mittlerweile schon ziemlich gewagt und auch ärgerlich, ständig MP2 als fertiges Produkt hinzustellen, dass wie MP1 "out of the box" einsetzbar ist. Das ist es definitiv noch nicht. Dazu hakt es noch an viel zu vielen Enden. Und ihr schadet mit diesen ständigen, falschen und nicht haltbaren Statements nicht zuletzt dem sicherlich irgendwann mal großartigen Produkt MP2.
     

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,115
    3,697
    Lehmden
    Germany Germany
    Country flag
    Hi.
    MP1 "out of the box"
    und
    TV-Serien
    ist schon mal ein Widerspruch in sich da "MP1 out of the box" erst gar keine Serien unterstützt... Das ist das, was mich an solchen Kommentaren aufregt. MP1 ist alles andere als Komplett, es ist ein Bausatz, aus dem man erst mal ein funktionsfähiges Programm zusammen basteln muss. Nix funktioniert "ab Werk" alles muss erst umständlich hinzu installiert werden. Und das, obwohl der Installer fast dreimal so groß ist, wie der von MP2. Die ganzen uralten Runtimes aus der XP oder Vista Ära, die man nachinstallieren muss und mit denen man sich sein Windows 10 vollmüllt noch gar nicht mit gerechnet... Für mich ist das alles andere als ein komplettes, fertiges Programm. Es ist ein Bausatz, mehr nicht. Und dazu noch nicht mal ein besonders leicht fertig zu stellender. Wer behauptet MP1 ist Komplett und funktioniert "out of the Box" der hat schon eine sehr seltsame Auffassung davon, was diese Begriffe eigentlich bedeuten. Das einzige, was bei MP1 von Haus aus (noch) wohl besser als bei MP2 funktioniert, ist der Musik Teil. Bei TV ist es etwa Gleichstand aber bei allen anderen Sachen ist ein "out of the box" MP1 einem "out of the box" MP2 massiv unterlegen.

    Dann hast du was falsch gemacht.
    Möglich, sogar wahrscheinlich, aber was? Alle Filme waren mit .nfo ausgestattet, die mit anderen Programmen tadellos funktionieren. Und ich habe alle verfügbaren Scrapper für Offline Daten ausprobiert. Aber Moving Pictures war nicht in der Lage, einen beachtlichen Teil der Filme einzulesen. Das habe ich mir nicht ausgedacht, sondern ist genau so passiert. Wenn ich die Filme trotzdem "approved" habe, hatten sie keine Namen, keine Beschreibung und auch sonst gar nichts. Die andere Alternative war für jeden nicht erkannten Film einen neuen, leeren DB Eintrag zu erzeugen. Dann war wenigstens der Filmname mit dem Dateinamen gefüllt. Beides resultiert in tagelanger Handarbeit, die ich mich geweigert habe, zu machen. So ist das jedenfalls nicht zu gebrauchen, obwohl ich das von früher her anders, besser funktionierend in Erinnerung habe...

    nahezu fehlerlos.
    würde mir nicht reichen. Bei MP2 geht das schon länger völlig fehlerfrei, bei 30.000 Filmen und Serien- Episoden nicht ein einziger Fahler. Zumindest bei Filmen und Serien. An Musik sind wir aktuell dran, bis zur 2.1 Final wird auch das zu 100% fehlerfrei funktionieren. Da bin ich mir sicher.
     

    Andreas Schneider

    Portal Pro
    August 6, 2012
    90
    5
    47
    Germany Germany
    Country flag
    Vielen Dank für eure Antorten!

    @HTPCSourcer:
    Ich installiere mir ca. alle 6 Monate MP2 um mal zu sehen, wie der Fortschritt inzwischen ist.

    @Lehmden:
    Ich habe meine Videosammlung nach DEINER Anleitung in Moving Pictures eingepflegt. Die Filme liegen in den unterschiedlichsten Formaten vor, je nachdem, zu welcher Zeit ich mir die mit welchen Programmen angelegt habe. Aber jeder Film ist in einem eigenen Verzeichnis, das Verzeichnis beinhaltet den Filmnamen und die tt-Nummer. Direkt indem Verzeichnis liegt die nfo-Datei und die verschiedenen jpegs.
    Wenn ich den Import in Moving Pictures mache (nur von nfo lesen) werden alle Filme zuverlässig erkannt und die nfo Dateien eingelesen. Und mit MP2 funktioniert der Import überhaupt nicht.

    Umständlicher ist da übrigens gar nichts. egal in welchem Format der Film vorliegt, die nfo-Datei kommt in das Hauptverzeichnis des Films. Bei Bluray oder DVD gibt es weitere Unterverzeichnisse, das stört aber nicht.

    Also: der Import in MP1 funktioniert, MP2 funktioniert nicht => ImportSoftware unterschiedlich
     

    HTPCSourcer

    Retired Team Member
  • Premium Supporter
  • May 16, 2008
    11,431
    2,334
    Germany Germany
    Country flag
    Aber jeder Film ist in einem eigenen Verzeichnis, das Verzeichnis beinhaltet den Filmnamen und die tt-Nummer. Direkt indem Verzeichnis liegt die nfo-Datei und die verschiedenen jpegs.
    [..]Und mit MP2 funktioniert der Import überhaupt nicht.
    Meine Filme liegen entweder als ts/mkv als eigenständige Datei vor (Name + tt im Dateinamen) oder bei wenigen DVD-Rips in einem separaten Unterverzeichnis. Alls wird korrekt eingelesen.

    Kannst du mal dein Server-Log hochladen?
     

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,115
    3,697
    Lehmden
    Germany Germany
    Country flag
    Hi.
    ImportSoftware unterschiedlich
    Das ist auf jeden Fall richtig.

    Ich habe meine Videosammlung nach DEINER Anleitung in Moving Pictures eingepflegt.
    Die Anleitung ist viele Jahre alt, da ich schon seit vielen Jahren kein Moving Pictures mehr verwende. Ich weiß nicht mal mehr, was ich da beschrieben habe. Allerdings hat sich die Software- Landschaft massiv verändert seitdem. Selbst wenn ich noch MovingPictures verwenden würde, würde ich es mit 100% Sicherheit nicht mehr so machen wie damals beschrieben...

    Deine Probleme haben aber sicher nichts mit MP2 selbst zu tun. Der Import läuft normalerweise absolut perfekt, wenn gültige .nfo vorliegen... Du musst etwas grundsätzliches falsch machen, beim Anlegen der Medienquellen. Anders ist das nicht zu erklären. Aber ohne weitere Daten und Logs, kann man nicht raus finden, welchen grundsätzlichen Fehler du machst...

    Habe ich doch gerade erst wieder gestern meine Datenbank komplett löschen müssen, um neue Features zu testen. Der Import von 30.000 Serien- Episoden und 2000 Filmen lief bei 100% Trefferquote ohne jegliches Eingreifen meinerseits. Kein manuelles "Approven" oder händische Korrekturen nötig. Und das selbst bei Serien, die nicht auf TVDB geführt werden oder bei Filmen, die nicht auf IMDB vorhanden sind. Ist schon fast langweilig wie schnell, einfach und fehlerfrei das funktioniert.

    Ob inzwischen auch bei Musik eine 100% Quote erreicht wird (was wir anstreben, aber bisher noch nicht erreicht haben), ist der Grund für den Test gewesen, der dahingehend aber noch nicht abgeschlossen ist. Da der "Rest" halt so super perfekt funktioniert, habe ich keinerlei Bedenken, selbst die komplette Datenbank zu "killen" und ganz von vorne anzufangen. 5 Mausklicks und etwas warten und alles ist wieder exakt genau so, wie es vorgesehen ist.
     

    Andreas Schneider

    Portal Pro
    August 6, 2012
    90
    5
    47
    Germany Germany
    Country flag
    - Mediaportal 2.1 pre 2 installiert
    - Import gestartet

    Hier sind die Logs.

    Ich sehe in den Logs, dass da alle möglichen Filme eingelesen werden. In MP2 werden allerdings nur 20 Filme angezeigt.
    ???
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    P Recording films that have an "intermission" General 3
    T [solved] Filme müssen zweimal angeklickt werden, bevor sie abspielen Video & DVD 1
    cerberus Moving Pictures zeigt Film Spezifikationen nicht richtig Plugins & Erweiterungen 12
    C MP 1.19: Filme / Videos starten nicht Video & DVD 2
    F My Films and .nfo grabber don't grab all the covers Newcomers Forum 0
    cbr954rr Movie sets in films General 20
    Patrik-See Sortierung der Filme auf der Festplatte in Ordnern (Struktur) Allgemeines Supportforum 3
    D Large xml database in My Movies Management. I remain unclear on use My Films as bridge to MP2.2 General 9
    R Mp restarts when scrolling down list of films Moving Pictures 8
    T [solved] Filme/Videos werden nicht abgespielt Allgemeines Support- und Diskussionsforum 10
    hounddog How to get My Films working in MP 1.20 My Films 5
    L TV-Series unvollständiger Import Plugins & Erweiterungen 5
    toricred Using TMM, How to Stop Importer From Going to The Movie Database for Data General 1
    Lichloathe MP2 importing keyart instead of poster General 0
    P Recordings not showing up unless re-imported and not possible to delete General 0
    C Importer works super slow My TVSeries 5
    C Imported media doesn't show up immediately? General 1
    X Recording import hängt Allgemeines Support- und Diskussionsforum 0
    J [fixed] Import issue with alternate movie title matching the name of another movie Submit: Bug Reports 7
    B xmltv - cannot import tvguide.xml australia Installation, configuration support 0
    B [solved] tvguide.xml not importing australian channels Electronic Program Guide 10
    J [fixed] Importer confused on specific movies with the same title, different years and different NFO's Submit: Bug Reports 3
    azzuro [fixed] [WIP MP2.3] - Audio files not imported to MP MediaPortal 2 18
    thepahakurki TVDB import not working My TVSeries 3
    T I cannot get a basic media import-what is the best configuration? General 10
    Similar threads

























    Top Bottom