Firewall on server blocking client (1 Viewer)

Ronski

MP Donator
  • Premium Supporter
  • June 21, 2008
    43
    7
    England England
    Country flag
    I'm just in the process of setting up and trying MP2, I have a WHS2011 server with MP2 server installed - this has my tuner card in it as it's on 24/7.

    I've installed the client on another PC, but it can't find the server unless I disable the firewall on the server, once disabled the client finds the server.

    There are firewall inbound rules setup on the server as below, but no outbound rules.

    1601756917314.png


    The one highlighted doesn't have a program associated with it, no idea whether its supposed to or not.

    Googling has revealed that MP2 uses dynamic ports, so it's not just a case of opening up a port, any suggestions please?
     

    ge2301

    MP2 Design
  • Team MediaPortal
  • January 11, 2014
    7,005
    2,504
    Stuttgart
    Germany Germany
    Country flag
    I've installed the client on another PC, but it can't find the server unless I disable the firewall on the server, once disabled the client finds the server.
    Do you have log files of the failed communication with the server?

    Googling has revealed that MP2 uses dynamic ports, so it's not just a case of opening up a port, any suggestions please?
    Which firewall are you using, did you try another one? Your settings seem to be ok.
     

    Ronski

    MP Donator
  • Premium Supporter
  • June 21, 2008
    43
    7
    England England
    Country flag
    @ge2301 just the standard Windows one built into WHS2011, nothing else installed. Switch the firewall off and the client can connect, turn it on and they loose the connection.
     

    ge2301

    MP2 Design
  • Team MediaPortal
  • January 11, 2014
    7,005
    2,504
    Stuttgart
    Germany Germany
    Country flag
    @ge2301 just the standard Windows one built into WHS2011, nothing else installed. Switch the firewall off and the client can connect, turn it on and they loose the connection.
    Instead of looking for ports, have you set the general options like below? Normally the MP2 installer does this automatically. Try to set "public" as well.
    Sorry, screenshot is in German:
    Öffentlich = Public
    Privat = Private
    1601802857548.png
     

    ge2301

    MP2 Design
  • Team MediaPortal
  • January 11, 2014
    7,005
    2,504
    Stuttgart
    Germany Germany
    Country flag
    I've attached the client log files. I'll also investigate you're last reply, thank you for your help.
    Thanks, I can not see any attempt to connect to the server. Can cou try to bind it to the server from the settings to fill the logs with the problem.
    Thanks.
     

    Ronski

    MP Donator
  • Premium Supporter
  • June 21, 2008
    43
    7
    England England
    Country flag
    Instead of looking for ports, have you set the general options like below? Normally the MP2 installer does this automatically. Try to set "public" as well.
    Sorry, screenshot is in German:
    Öffentlich = Public
    Privat = Private
    WHS2011 doesn't seem to have the option as in your screenshot, but I did change them in the firewall settings to include both private and public, this made no difference.

    I found an option on the client to enable debug logging, so deleted the existing logs and started MP2 and tried to find a server - logs attached.

    I've also turned on logging for dropped packets on the server, 192.168.0.11 being my PC with the client on, some of the dropped packet appear to coincide with clicking the search for server button. I pressed it at exactly 12:00, and the server logs a dropped packet 33 seconds later, the two clocks are in sync.

    Code:
    #Version: 1.5
    #Software: Microsoft Windows Firewall
    #Time Format: Local
    #Fields: date time action protocol src-ip dst-ip src-port dst-port size tcpflags tcpsyn tcpack tcpwin icmptype icmpcode info path
    
                                                                                                                                                                                                                    2020-10-04 11:52:11 DROP ICMP ::131.19.196.68 ff02::1 - - 80 - - - - 130 0 - RECEIVE
    2020-10-04 11:52:51 DROP TCP 192.168.0.12 192.168.0.20 5200 54077 40 R 1462072272 0 0 - - - RECEIVE
    2020-10-04 11:54:17 DROP ICMP ::130.155.254.68 ff02::1 - - 80 - - - - 130 0 - RECEIVE
    2020-10-04 11:54:59 DROP TCP 192.168.0.11 192.168.0.20 29997 55555 52 S 4051362025 0 64240 - - - RECEIVE
    2020-10-04 11:55:00 DROP TCP 192.168.0.11 192.168.0.20 29997 55555 52 S 4051362025 0 64240 - - - RECEIVE
    2020-10-04 11:55:01 DROP UDP 192.168.0.11 192.168.0.20 5355 53867 210 - - - - - - - RECEIVE
    2020-10-04 11:55:01 DROP TCP fe80::8db8:13a8:25ea:f863 fe80::d024:dc3a:b12f:4b6c 30011 55555 72 S 2589105696 0 64800 - - - RECEIVE
    2020-10-04 11:55:02 DROP TCP fe80::8db8:13a8:25ea:f863 fe80::d024:dc3a:b12f:4b6c 30011 55555 72 S 2589105696 0 64800 - - - RECEIVE
    2020-10-04 11:55:02 DROP TCP 192.168.0.11 192.168.0.20 29997 55555 52 S 4051362025 0 64240 - - - RECEIVE
    2020-10-04 11:55:04 DROP TCP fe80::8db8:13a8:25ea:f863 fe80::d024:dc3a:b12f:4b6c 30011 55555 72 S 2589105696 0 64800 - - - RECEIVE
    2020-10-04 11:55:06 DROP TCP 192.168.0.11 192.168.0.20 29997 55555 52 S 4051362025 0 64240 - - - RECEIVE
    2020-10-04 11:55:08 DROP TCP fe80::8db8:13a8:25ea:f863 fe80::d024:dc3a:b12f:4b6c 30011 55555 72 S 2589105696 0 64800 - - - RECEIVE
    2020-10-04 11:55:14 DROP TCP 192.168.0.11 192.168.0.20 29997 55555 52 S 4051362025 0 64240 - - - RECEIVE
    2020-10-04 11:55:16 DROP TCP fe80::8db8:13a8:25ea:f863 fe80::d024:dc3a:b12f:4b6c 30011 55555 72 S 2589105696 0 64800 - - - RECEIVE
    2020-10-04 11:56:22 DROP ICMP ::135.57.136.68 ff02::1 - - 80 - - - - 130 0 - RECEIVE
    2020-10-04 11:58:28 DROP ICMP ::131.86.32.68 ff02::1 - - 80 - - - - 130 0 - RECEIVE
    2020-10-04 12:00:33 DROP ICMP :: ff02::1 - - 80 - - - - 130 0 - RECEIVE
     

    Attachments

    Ronski

    MP Donator
  • Premium Supporter
  • June 21, 2008
    43
    7
    England England
    Country flag
    @ge2301 I've now found this, and ticked the public option, but it made no difference. I noticed I don't have "Mediaportal UPnP/HttpServer" as you do, should I have that?

    1601810663119.png
     

    ge2301

    MP2 Design
  • Team MediaPortal
  • January 11, 2014
    7,005
    2,504
    Stuttgart
    Germany Germany
    Country flag
    I just done the following, then restarted MP2. Then generated new logs, which I've attached. Is there an option to clear all logs?
    No, but you can manually delete them. Old logs are automatically removed by time, the counting index goes only until 4, so after 5th restart of the application the last logs are removed.

    @ge2301 I've now found this, and ticked the public option, but it made no difference. I noticed I don't have "Mediaportal UPnP/HttpServer" as you do, should I have that?
    No, you don't need that. I'm using a unreleased version with new features.

    Generally your settings seem all fine and I've no clue why the firewall makes such trouble. The logs how denied access or wrong a wrong IP address (198.168.0.20). Can you deactivate the firewall and connect to the server without manually setting an IP-address, but connecting to the server by searching for it. After that turn on the firewall with alt/tab, leave MP2 client running all the time in the background.
     

    Users who are viewing this thread

    Similar threads
    OP Title Forum Replies Date
    M Firewall woes, mostly. General 12
    C 1.25.0 Need explanation - TV Servers/Scan settings TV-Server 1
    G MP2 - V2.3 Tv Server information General 1
    R Deadlock in TV Server if recording while importing EPG TV-Server 10
    W MP2 - V2.3 MP2 Server stürzt immer nach kurzer Zeit ab Allgemeines Support- und Diskussionsforum 85
    W TV Server didn't show Magic-Pro ProHDTV Diamond2 card TV-Server 2
    JimCatMP Problems with TV Server on dual homed host. General Support 0
    cbr954rr EPG Genre map categories do not match tv server categories General 4
    E [solved] TV-Server Configuration Missing TV-Server 9
    F MediaPortal 1.16 server crashing due to user error? General Support 5
    E TV-SERVER control TV-Server 3
    CanadianEh MP TV server rebuild with Colossus 2 - Kodi clients receive PMT error when playing videos recoreded by Colossus 2 TV-Server 2
    M 1.25.0 Tv Server Configuration Italian Dvb-t2 test channel preview error Television (MyTV frontend and TV-Server) 8
    M TV Server Preview Window is blank, sounds works Television (MyTV frontend and TV-Server) 3
    catalpa ...immer mal wird der Server abgekoppelt :( Allgemeines Support- und Diskussionsforum 0
    A Keine Verbindung mit Kodi auf Server Allgemeines Support- und Diskussionsforum 11
    CyberSimian Unhandled exception in TV Server TV-Server 0
    Grisu002 Failed to startup - TV Server funktioniert nicht Allgemeines Support- und Diskussionsforum 0
    ajs [WiP] 5030: Add UHD Thumb size to TV Server MediaPortal 1 0
    toricred [solved] Configuring TV Server to use NAS General 5
    T Client / Server slow channel-to-channel change (zapping) General Support 1
    T Server / client channel logo location Installation, configuration support 6
    framug [solved] Some changes/fix in MP1 configuration client and server Submit: code patches (MediaPortal/TV-Server/etc.) 14
    S TV-Server MP1 - Automatic search doesn't work Installation, configuration support 2
    M TV Server can't tune to some DVB-S multiplexes while other software can General 0

    Similar threads

    Top Bottom