[Approved] Fix for stuttering/corrupted streaming of live tv

miroslav22

Development Group Member
  • Premium Supporter
  • September 4, 2009
    703
    63
    Warwick
    Country flag
    Admittedly it would help if you can upgrade to 1.1.2 (it's only a service release so there's no earth shattering differences from 1.1.0/1.1.1 that are likely to break anything on your setup)

    It's no problem if not, I can patch and compile binaries in 10 minutes if i'm quick :)
     

    mundy5

    Portal Member
    September 17, 2010
    26
    3
    Quick update,


    Will include binaries for versions:

    1.2.0 Latest SVN
    1.2.0 Alpha
    1.1.2

    If anyone would like binaries for another version please post a request.
    Thank you miroslav for working on this for us. I have version 1.1. Is it possible for binaries for that version? I am having continuity errors and I believe that your solution might fix this. I was tempted to try your patch for my MP 1.1 but it looks like it might not work for it. Please post binaries for version 1.1.
    Why can't you upgrade to 1.1.2? Do you have any idea how much work it is to provide binaries for every single version?
    Rik, no, I do not know how much it takes to provide binaries, however, miroslav offered (see the bold quote above) so please do not speak in such a condescending tone to me. If miroslav did not offer, I would not have requested. Case closed. So unless you are the one creating the binary, please leave me alone. I didn't ask you to do this.
     

    riksmith

    Portal Pro
    April 18, 2009
    1,856
    83
    Thank you miroslav for working on this for us. I have version 1.1. Is it possible for binaries for that version? I am having continuity errors and I believe that your solution might fix this. I was tempted to try your patch for my MP 1.1 but it looks like it might not work for it. Please post binaries for version 1.1.
    Why can't you upgrade to 1.1.2? Do you have any idea how much work it is to provide binaries for every single version?
    Rik, no, I do not know how much it takes to provide binaries, however, miroslav offered (see the bold quote above) so please do not speak in such a condescending tone to me. If miroslav did not offer, I would not have requested. Case closed. So unless you are the one creating the binary, please leave me alone. I didn't ask you to do this.
    Well it are just two normal questions :confused: Perhaps the interpretation is a difference between me being dutch and you being american.
     

    mundy5

    Portal Member
    September 17, 2010
    26
    3
    Admittedly it would help if you can upgrade to 1.1.2 (it's only a service release so there's no earth shattering differences from 1.1.0/1.1.1 that are likely to break anything on your setup)

    It's no problem if not, I can patch and compile binaries in 10 minutes if i'm quick :)
    hold off on that miroslav. I replaced the tsreader.ax and tswriter.ax in their respective directories submitted by chemelli back on post #18, and it seems to have significantly reduced the number of seek times on the hdd in the brief test I did earlier today. I'll test it some more, but it looks like the binaries offered seems to be working for my 1.1 version. If this is the case, then there is no need to compile one for 1.1

    Why can't you upgrade to 1.1.2? Do you have any idea how much work it is to provide binaries for every single version?
    Rik, no, I do not know how much it takes to provide binaries, however, miroslav offered (see the bold quote above) so please do not speak in such a condescending tone to me. If miroslav did not offer, I would not have requested. Case closed. So unless you are the one creating the binary, please leave me alone. I didn't ask you to do this.
    Well it are just two normal questions :confused: Perhaps the interpretation is a difference between me being dutch and you being american.
    If that is the case, rik, no hard feelings. I was simply responding to miroslav's post. I am hesitant to upgrade after reading a lot of issues with customized setting etc. I'm happy right now with 1.1. But if you look at my earlier post, it seems like one of the binaries seems to work with my version so maybe all of this is moot.
     

    miroslav22

    Development Group Member
  • Premium Supporter
  • September 4, 2009
    703
    63
    Warwick
    Country flag
    First post updated with version 3.

    Apologies it only includes binaries for the latest SVN (27238) at the moment. The patch will not merge into earlier versions so I will have to do this manually which is a bit more time consuming. These binaries will not work with a version earlier than 27231.

    Remaining binaries tomorrow evening :)

    Thanks again to all testers :)
     

    regeszter

    Retired Team Member
  • Premium Supporter
  • October 29, 2005
    5,335
    113
    Hi,

    If you make binarys for 1.1.2 i will test with dvb-t and analog cards too. Does this patch useful for multi seat or useful for single seat too?
     

    miroslav22

    Development Group Member
  • Premium Supporter
  • September 4, 2009
    703
    63
    Warwick
    Country flag
    It was originally developed for multiseat, but you should also notice an improvement in channel zapping times on single seat. It should also help if you get stuttering caused by the disk being overworked.
     

    mylle

    Portal Pro
    April 14, 2005
    574
    28
    Denmark
    Hi,

    Updated to SVN27238 today and applied you patched and then build the installer. Now i get an unknown error when trying to tune a channel :(

    It might not have anything to do with your pache but hopefully someone could look at my logs and see whats going on?

    Thanks
    Mylle
     

    Attachments

    miroslav22

    Development Group Member
  • Premium Supporter
  • September 4, 2009
    703
    63
    Warwick
    Country flag
    Are you sure you replaced all the files? I did test the replacement process and it seemed ok.

    The error is an access violation which probably means the exports from one of the native filters doesn't match the C# interfaces.

    Did you stop tvservice before you did the replace? (sorry should have mentioned that). Try again with it stopped if not.
     

    mylle

    Portal Pro
    April 14, 2005
    574
    28
    Denmark
    Are you sure you replaced all the files? I did test the replacement process and it seemed ok.

    The error is an access violation which probably means the exports from one of the native filters doesn't match the C# interfaces.

    Did you stop tvservice before you did the replace? (sorry should have mentioned that). Try again with it stopped if not.
    Sorry,

    I just patched latest SVN with DiscontinuityFixV3.patch. and did a build and then updated my setup. Do I also have to replace all the binaries afterward?

    regards
    Jacob
     
    Top Bottom