[Approved] - Fix for stuttering/corrupted streaming of live tv | Page 15

Discussion in 'Archive' started by miroslav22, December 22, 2010.

  1. disaster123
    • Premium Supporter

    disaster123 MP Donator

    Joined:
    May 14, 2008
    Messages:
    3,546
    Likes Received:
    417
    Ratings:
    +431 / 2
    Home Country:
    Germany Germany
    AW: Fix for stuttering/corrupted streaming of live tv



    Has anybody else noticed a slower start of live tv like me? Is this possible?
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. regeszter
    • Premium Supporter

    regeszter Retired Team Member

    Joined:
    October 29, 2005
    Messages:
    5,335
    Likes Received:
    2,863
    Ratings:
    +5,152 / 18
    Home Country:
    Hungary Hungary
    Hi,

    there are not TvLibrary.Interfaces.xml and TVLibrary.XML in my 1.1.2 system to over write. Are these new files?
     
  4. romuz
    • Premium Supporter

    romuz Retired Team Member

    Joined:
    July 26, 2008
    Messages:
    1,045
    Likes Received:
    125
    Location:
    Moskau
    Ratings:
    +126 / 0
    Home Country:
    Russian Federation Russian Federation
    Today i have done more complex test: same time connections to one channel from server(local) and client(remote)
    with various connection siquence and after that i starting to think something not good with start timeshifting is happens
    Best viewing results on client when timeshifting was started before connection from client.

    Test patterns:
    All tests done on one channel

    connect2third.rar - first i started timeshifting from tvsetup manual control, then i started timeshifting of that channel on server and remote client(unc)

    connect from client.rar i started timeshifting on remote client(unc) then on server


    connect from server.rar first connect on tvserver then on remote client(unc)

    connect from client with streamingserver.rar first connect from remote client(streamingserver) then on server

    In all cases when client timeshifting was done after anything else i getting beautiful clear tsreader log without any issues
    worstest results when connect fromclient first time to render drifting discontinuetes(connect from client.rar)
    best is connect from server.rar no any issue

    I dont know what is the root of that issue but maybe it helps more knowledgeable person to identify the issue
    :D
     

    Attached Files:

    • Like Like x 1
  5. miroslav22
    • Premium Supporter

    miroslav22 Development Group Member

    Joined:
    September 4, 2009
    Messages:
    703
    Likes Received:
    459
    Gender:
    Male
    Location:
    Warwick
    Ratings:
    +459 / 0
    Home Country:
    United Kingdom United Kingdom
    Hi,

    Don't worry too much about the xml files, you don't actually need them.
     
  6. miroslav22
    • Premium Supporter

    miroslav22 Development Group Member

    Joined:
    September 4, 2009
    Messages:
    703
    Likes Received:
    459
    Gender:
    Male
    Location:
    Warwick
    Ratings:
    +459 / 0
    Home Country:
    United Kingdom United Kingdom
    Thanks Romuz that's a great help :D I should be able to determine what's going on from those logs.
     
  7. Snader
    • Premium Supporter

    Snader MP Donator

    Joined:
    September 5, 2007
    Messages:
    270
    Likes Received:
    10
    Location:
    Aalsmeer
    Ratings:
    +10 / 0
    Home Country:
    Netherlands Netherlands
    I'm on single seat over here and after 2 upgrades of my video card (now a gt220 nvidia) that did not solve my stuttering... the stuttering in HD channels seems to be gone thanks to this patch (v1.1.2).
     
    • Like Like x 1
  8. Maschine
    • Premium Supporter

    Maschine Retired Team Member

    Joined:
    June 15, 2004
    Messages:
    768
    Likes Received:
    78
    Location:
    Germany
    Ratings:
    +84 / 0
    Home Country:
    Germany Germany
    Hi, I just did some short tests with your 1.1.2 binaries on my singleseat setup. Results are quite good and I didn't experience negative side results. I watched for dropped frames until the counter reached 25000 drawn frames (well, not really professional testing, but ok for first results ;)):

    SD (1.1.2 default): 8 dropped frames
    SD (your version): 2 dropped frames

    HD (1.1.2 default): 17 dropped frames
    HD (your version): 5 dropped frames

    I'll let you know my further results during the daily tv watching ;) Thanks for your work so far!
     
    • Like Like x 1
  9. Ponyriemen
    • Premium Supporter

    Ponyriemen MP Donator

    Joined:
    July 9, 2007
    Messages:
    2,570
    Likes Received:
    111
    Gender:
    Male
    Location:
    /root/home
    Ratings:
    +111 / 0
    Home Country:
    Germany Germany
    AW: Fix for stuttering/corrupted streaming of live tv

    Sorry if my Question is weird, but wich Version of Post#1 i have to take, if i use the 1.2.0 Alpha, just downloaded from Sourceforge? I have`nt used SVN`s, i am only using the 1.2.0 Alpha from first Date, it was released.

    P.S.: And sorry for my bad english... :oops:
     
  10. miroslav22
    • Premium Supporter

    miroslav22 Development Group Member

    Joined:
    September 4, 2009
    Messages:
    703
    Likes Received:
    459
    Gender:
    Male
    Location:
    Warwick
    Ratings:
    +459 / 0
    Home Country:
    United Kingdom United Kingdom
    Hi,

    The binaries for 1.2.0 Alpha are in the zip archive which is the last file in the post:

    StreamingDiskIOFix-V3-Binaries (1.2.0 Alpha).zip
     
  11. Ponyriemen
    • Premium Supporter

    Ponyriemen MP Donator

    Joined:
    July 9, 2007
    Messages:
    2,570
    Likes Received:
    111
    Gender:
    Male
    Location:
    /root/home
    Ratings:
    +111 / 0
    Home Country:
    Germany Germany
    AW: Fix for stuttering/corrupted streaming of live tv

    if i take these "StreamingDiskIOFix-V3-Binaries (1.2.0 Alpha).zip", i cant get into TVServer-Konfig and from Client i cant tune a Channel, the TVService seems to be not reachable...

    //edit: i am using 4TR, if that is important. And the Logs only shows "an unexpected Error occured", nothing detailed...
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!