[fixed] MMS playback with BASS Player locks up MediaPortal (1 Viewer)

level20peon

MP Donator
  • Premium Supporter
  • January 4, 2007
    1,082
    100
    38
    Aachen
    Germany Germany
    Country flag
    Hola,

    I just updated my Internet-Radio "portfolio" inside MediaPortal. There are some MMS streams included in my setup now. I am using BASS player for playback of all my files so it also handles internet Radio-Streams. When I start an MMS stream I can hear sound after some time but MediaPortal locks up after starting playback. So I continue hearing the stream but cannot control MediaPortal anymore. It doesn't matter whether visualization is enabled or not. The MediaPortal.log file contains dozens of the following entries (up to 20 of them per second !):

    Code:
    2007-11-29 17:00:22.310042 [Info.][MPMain]: Exception   :Fehler in der Anwendung.
    -2005530516 (D3DERR_INVALIDCALL)
       bei Microsoft.DirectX.Direct3D.Device.BeginScene()
       bei MediaPortalApp.Render(Single timePassed)
    2007-11-29 17:00:22.310042 [Info.][MPMain]: Exception   :Fehler in der Anwendung.
    2007-11-29 17:00:22.310042 [Info.][MPMain]:   site      :Void BeginScene()
    2007-11-29 17:00:22.325653 [Info.][MPMain]:   source    :Microsoft.DirectX.Direct3D
    2007-11-29 17:00:22.325653 [Info.][MPMain]:   stacktrace:   bei Microsoft.DirectX.Direct3D.Device.BeginScene()
       bei MediaPortalApp.Render(Single timePassed)
    (I attached the full log... run MediaPortal, start stream playback, killed MediaPortal)
    All other stream types playback is fine, as well as "normal" MP3 playback. DirectX is up to date (directx_nov2007_redist) so I have no idea what I am facing here. I attached the MMS streams I tested.

    Any suggestions ?


    -level20peon
     

    level20peon

    MP Donator
  • Premium Supporter
  • January 4, 2007
    1,082
    100
    38
    Aachen
    Germany Germany
    Country flag
    So I am the only one with this problem ? Seriously, any answer would be appreciated... even if it is "dude stop bothering me, works fine over here".




    -level20peon
     

    level20peon

    MP Donator
  • Premium Supporter
  • January 4, 2007
    1,082
    100
    38
    Aachen
    Germany Germany
    Country flag
    Strange, forum search didn't return this... However the "fix" described there was implemented quite some SVN's ago and I am not able to play MMS streams with the latest SVN. None of them, all work fine in Winamp, so the stations servers are up and running...


    So, did you solve this?
    No, I would not keep it secret ;)


    -level20peon
     

    level20peon

    MP Donator
  • Premium Supporter
  • January 4, 2007
    1,082
    100
    38
    Aachen
    Germany Germany
    Country flag
    You forgot to post something into the changelog ;) It is fixed for me though, thanks again hwahrmann :D


    -level20peon
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    framug [solved] Some changes/fix in MP1 configuration client and server Submit: code patches (MediaPortal/TV-Server/etc.) 14
    framug [Approved] Fix Irtrans config bug Submit: code patches (MediaPortal/TV-Server/etc.) 4
    W [solved] [FIXED] Survivor season 40 not automatically matching My TVSeries 1
    P [solved] ATSC subtitles not fixed yet? General 2
    framug [Rejected] Fix PowerScheduler plugin for MP2 single seat Submit: Code Patches 9
    M [Pending] Fix for Inconsistent date display in TV Guide Submit: code patches (MediaPortal/TV-Server/etc.) 1
    doskabouter [Proposal] Merge PR Fix for source directory with spaces MediaPortal 1 15
    CyberSimian Fixes for Amped aMPed 5
    CyberSimian Fixes for Amped skin MediaPortal 1 10
    S Resume Playback Annoyance Newcomers Forum 4
    K Flickering live TV playback Newcomers Forum 3
    J [solved] Blu-ray disc playback does not work. Bugreports 13
    morpheus_xx [WiP] OnlineVideos: New browser based playback support using WebDriver, new Amazon siteutil MediaPortal 2 6
    doskabouter [Help Me!] Playback of iTunes Movie Trailers Developer Discussions 0
    I Video Playback Stuttering General Support 45
    horned_reaper [solved] Music playback hangs General Support 58
    bta489 [solved] System goes to Standby during Amazon Prime Playback OnlineVideos 2
    A 1.24.0 1.24 Kills 3D MVC playback on MadVr 1.24 Pre Release 66
    Z [solved] DVD playback is super glitchy General 2
    A Working server, no video playback on client General 5
    L MP Playback Freezes When Unpausing from Minimized Screen General Support 6
    Cowboy Playback Problem with CTD or sometimes BSOD watch/edit Videos 0
    Glith Sound stops working after first playback 1.21 88
    G Mediaportal2 supported formats General 1
    W Playback stuttering after upgrade from MP1 on Windows 7 to MP2 on Windows 10 General 2
    Similar threads

























    Top Bottom