Glitches in TV streams, not sure of problem source

Discussion in 'General Support' started by wakkawakka, September 7, 2017.

  1. wakkawakka

    wakkawakka Portal Member

    Joined:
    June 28, 2013
    Messages:
    14
    Likes Received:
    1
    Ratings:
    +1 / 1
    Home Country:
    Australia Australia
    Hi,

    I have 2 HDHomeRun connects recording with MediaPortal 1 and for the life of me cannot work out why I'm getting glitches on captured TV.



    MEGA

    Above is a capture of an example glitch. It is over 1 minute so something appears to be drastically wrong. I've tried alternating between the HDHomeRun tuners and it appears to happen on both tuners. I've replaced antenna cables, installed the latest (and multiple different) version/s of the HDHomeRun software/drivers, installed a few different MediaPortal 1 versions, checked connections, power cycled equipment, replaced TV server entirely, everything I can think of to check. I'm hoping the nature of the glitch sheds some light on why it may be occurring.

    Many thanks for your help.
     
    Last edited: September 7, 2017
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,541
    Likes Received:
    4,752
    Ratings:
    +8,221 / 17
    Home Country:
    New Zealand New Zealand
    Hello

    It doesn't.

    Please can you:
    1. Tell us when the problem started, and did you make any changes to the setup (including your network) at that time (?). (Presumably you haven't had this issue the whole time you've been using MediaPortal. So, something that changed must have caused it to start.)
    2. Use the provided Watchdog tool with option 3 ("export...") to capture full log files on the machine that TV Server is installed on. Please do this immediately after a glitch happens.
    3. Do the glitches occur:
      1. ...on all channels with equal probability of occurrence, or just some, or are some more likely than others?
      2. ...with the HDHR viewing software?
      3. ...at all times of day with equal probability of occurrence, or are certain times of day worse than others?
    4. If you run any security software (anti-virus, Windows defender etc.), have you configured it to skip MediaPortal/TV Server program, timeshift and record folders?
    5. Are there any wireless network links between the HDHRs and the machine that TV Server is installed on?
    6. How full are the HDDs you have your timeshift and record folders on, and are those folders on HDDs that are directly connected to the machine (as opposed to [for example] on a Network Attached Storage device)?
    7. Have you checked the DPC latency on the machine that TV Server is installed on?
     
  4. wakkawakka

    wakkawakka Portal Member

    Joined:
    June 28, 2013
    Messages:
    14
    Likes Received:
    1
    Ratings:
    +1 / 1
    Home Country:
    Australia Australia
    1.) Its been happening for a few months, sorry I didn't think to isolate the change made before the glitches started to occur. I'll try and trace back my steps
    2.) I'll try and capture something tonight
    3.) It seems to have occurred on all channels. I haven't seen it occur with the HDHR software. It seems to occur more often in peak hours.
    4.) I setup the exclusions recently, however the glitches still occured
    5.) No there aren't any wireless links between the tuners and TV server
    6.) The TV server is a NUC with a local M2 SSD recording drive
    7.) Apologies, how do I check that?

    My latest theory is the glitches only occur on the second consecutive recorded stream. The last, maybe 10+ times I've been recording a single show, there has been no glitches. However, the last couple of times I have started recording a second show at the same time, the glitch has occurred on the second stream, while the first show captured fine. I tried swapping around the priorities of the HDHR tuners but the issue still occurred.
     
    • Missing System Logs and/or Specs Missing System Logs and/or Specs x 1
  5. wakkawakka

    wakkawakka Portal Member

    Joined:
    June 28, 2013
    Messages:
    14
    Likes Received:
    1
    Ratings:
    +1 / 1
    Home Country:
    Australia Australia
  6. wakkawakka

    wakkawakka Portal Member

    Joined:
    June 28, 2013
    Messages:
    14
    Likes Received:
    1
    Ratings:
    +1 / 1
    Home Country:
    Australia Australia
  7. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,541
    Likes Received:
    4,752
    Ratings:
    +8,221 / 17
    Home Country:
    New Zealand New Zealand
    Sorry, missed your log files until now.

    First impressions are interesting.

    Continuities start at 9:38 PM on 18 October. At that time you have 3 active recordings:
    • tuner 3 - SBS ONE HD 8:01 PM-9:29 PM Sunshine [your post record setting is 30 minutes, so this actually stops at 9:59 PM]
    • tuner 4 - TEN HD 8:09 PM-10:42 PM The Wrong Girl 9
    • tuner 5 - 9HD Sydney 8:11 PM-9:48 PM Doctor Doctor - Final
    Note that the start of the continuities does not correlate with the start or end of any of these recordings. That's really important, because it means that whatever is causing this is external to MediaPortal's TV Server.

    The network traffic associated with 3 Australian DVB-T streams is going to be roughly 70 Mbps. At that level there's a very real risk of hitting network link limits for older wireless and 100 Mbps wired network links. It wouldn't take very much other traffic (downloads, other streams etc.) to tip you over the limit.

    Anyway, given that the cause appears to be external to MediaPortal's TV Server, it's not easy for me to offer any additional insight. My advice would be: when you notice the problem happening, do the maths on the network bandwidth. Each live TV or recording stream to TV Server requires approximately 23 Mbps... and don't forget to factor in the other programs which might be using your network at the time.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!