[confirm] GUI Settings -> Skip step configuration not localized (1 Viewer)

pilehave

Community Skin Designer
  • Premium Supporter
  • April 2, 2008
    2,566
    521
    Hornslet
    Denmark Denmark
    • Thread starter
    • Moderator
    • #1
    Current SVN;

    GUISettingsSkipSteps.cs is using hardcoded labels, even though localized versions are defined in english (and other languages):

    Code:
        private string verifySkipStep(string newStep)
        {
          int step;
          //int multiplyer = 1;
          //if (newStep.IndexOf('s') == (newStep.Length - 1) || newStep.IndexOf('S') == (newStep.Length - 1))
          //{
          //  newStep = newStep.Substring(0, newStep.Length - 1);
          //}
          //else if (newStep.IndexOf('m') == (newStep.Length - 1) || newStep.IndexOf('M') == (newStep.Length - 1))
          //{
          //  newStep = newStep.Substring(0, newStep.Length - 1);
          //  multiplyer = 60;
          //}
          //else if (newStep.IndexOf('m') == (newStep.Length - 1) || newStep.IndexOf('M') == (newStep.Length - 1))
          //{
          //  newStep = newStep.Substring(0, newStep.Length - 1);
          //  multiplyer = 3600;
          //} -- This doesn't really help the user a lot, so it's not worth the trouble
          try
          {
            step = Convert.ToInt16(newStep);
          }
          catch (Exception)
          {
            return "Not a valid integer";
          }
          //step *= multiplyer;
          if (step < 0)
          {
            return "Postive values only!";
          }
          else if (step == 0)
          {
            return "Zero skip is not allowed!";
          }
          else if (step > 10800)
          {
            return "3 hour skip is maximum!";
          }
          else
          {
            // Check that whole minutes are entered
            if (step > 60 && (step % 60) != 0)
            {
              return "Enter whole minutes only!";
            }
          }
          if (CheckExists(step))
          {
            return "Skip step already defined";
          }
          return null;
        }
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    R MP2 GUI Issues General 7
    ajs [fixed] 5022: Improving the MPE Installer, providing nicer GUI :) MediaPortal 1 42
    ajs [fixed] 5015: Improving the MP1 installer, providing nicer GUI :) MediaPortal 1 138
    ltfearme Exception thrown when SetText in GUI Notification dialog Titan Skin Feedback 3
    F GUI incredibly slow Performance General 22
    S Hard crashes in gui when sending to importer Moving Pictures 2
    azzuro [Help Me!] Improve duration times of GUI List items MediaPortal 2 37
    da3dsoul [Request] An MVP Plugin example for custom settings in MP2 Plugin Development 2
    M.Hulot MP plays in Internal Blu-ray-Player-mode always first audio stream not the one I chosen in settings General Support 1
    R Correct setting for recordings on shared folder General 0
    J New computer with win10 and how will i set Mediaportal up ? Newcomers Forum 55
    M [fixed] [MP2-831] 12h time format shown in TV Guide with Swedish language settings Submit: Bug Reports 27
    joEhSuper Backup Setting - ErrorBackupFolder TV-Server 9
    Rob Hexenmeister [solved] Customising Fanart Handler settings Fanart Handler 3
    joecrow AMD Radeon Settings app. won't start after hibernation. General Support 0
    L [solved] Modifying programmed recording after setting it General 0
    B [solved] How to manually set MAC of TV Server for WOL Installation, configuration support 2
    X MadVR Settings Video & DVD 2
    J Resume from Standby Last Module TV Showing TV Server Settings Television (MyTV frontend and TV-Server) 2
    D Correct wake-on-lan settings General 3
    G MP Crashed during setting up recording. Newcomers Forum 1
    cbr954rr Overtake/overwrite settings for all clients Feature Requests 0
    cbr954rr Same settings on all Clients? General 6
    framug 1.22.0 BasicHome Editor settings for DefaultWide HD skin not kept when update 1.22 3
    N [Question] [MP2-493] Default culture not saved in settings MediaPortal 2 0
    Similar threads

























    Top Bottom