Hauppage IR Blaster not working after waking from hibernate

Discussion in 'General Support' started by Jon Beers, July 27, 2013.

  1. Jon Beers

    Jon Beers New Member

    Joined:
    May 25, 2013
    Messages:
    3
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +0 / 0
    Home Country:
    Mexico Mexico
    I am running MP 1.4.0.0, using a nVidia GeForce 8400GS as the video card, a Colossus capture card which has a Hauppauge IR blaster for controlling the Set Top Box. When the computer wakes from hibernate, the IR blaster will not change channels - nothing will happen. However, if I restart the MySQL and TVService services and try again, all works just fine.



    Any ideas on how I can get things working without having to go through these manual steps?
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. kiwijunglist
    • Team MediaPortal

    kiwijunglist Super Moderator

    Joined:
    June 10, 2008
    Messages:
    6,742
    Likes Received:
    1,417
    Occupation:
    Doctor
    Location:
    New Zealand
    Ratings:
    +1,846 / 9
    Home Country:
    New Zealand New Zealand
    Show System Specs
    You won't get detailed support without the following:
    - System Specs
    - Log Files (Reproduce problem in debug mode)
    - Comment as to what software you are using with blaster, ?IRSS? ?Other?

    PS.

    There is also a setting to delay tv-server on resume
    TVServer - General: Delay in seconds before tv-server detects cards (set this to 10 seconds)

    And the following setting under PS++
    TVServer - PS++: Reinitalize TV Controller on wakeup (Try with this both off and on)

    This might also delay the IR blaster on resume, worth a shot?
     
  4. Jon Beers

    Jon Beers New Member

    Joined:
    May 25, 2013
    Messages:
    3
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +0 / 0
    Home Country:
    Mexico Mexico
    Thanks, sorry we didn't include much information on the first time around.

    Specs:
    - Motherboard is a BioStar NF61S
    - CPU is a AMD Athlon 62 X2 Duo
    - 2GB RAM
    - Running Windows XP Pro SP3
    - Colossus Capture Device
    - Hauppauge WinTV HVR-1600 NTSC/ATSC/QAM Combo

    Tried the settings you recommended, but saw no change.
    Attempted to reproduce the issue using the WatchDog launcher, but that seems to prevent the machine from entering hibernation, which is required to reproduce the problem. Any suggestions for getting some good logs?

    Something else I noticed - after waking from Hibernation, if I start TV Server Configuration and go to TV Channels and select a channel to preview, the blaster does not work. However, if I start BlastCfg (which comes with the Hauppauge card), I can successfully send channel numbers via the Blaster. As I said above, if I restart the TVServer process at this point, then the preview function will use the Blaster for tuning.

    I also notice that often when doing the above after waking from sleep, SetupTV will frequently crash. All of the error logs I have for SetupTV are empty.

    I have included the logs from my last WatchDog run, which captured activity up through hibernation (I had to kill MediaPortal after asking it to hibernate, because it became unresponsive. After killing it, WatchDog collected logs and then the machine went into hibernation)
     
  5. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    You can use the 3rd watchdog option to collect logs after performing the test. That way the watchdog doesn't have to be used to start MP, and you can test your hibernate/resume cycle with blasting and collect logs when you want to. Please just make you set the log level to debug before performing the test.

    Note, my hunch is that the Colossus blaster interface is the issue here. If that has to be restarted after standby/hibernate + resume then probably the only solution is to create a scheduled task that restarts the TV service on resume.
     
  6. Jon Beers

    Jon Beers New Member

    Joined:
    May 25, 2013
    Messages:
    3
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +0 / 0
    Home Country:
    Mexico Mexico
    Great. I did this - got everything working, set MP debug level to "debug", started it, successfully changed channels, hibernated, woke the computer, then unsuccessfully changed channels twice. The logs are attached.

    My first thought on discovering that restarting TVService would fix the problem was to run a job on wake from hibernate. However, restarting TVServer while MP is running makes MP very unhappy. It first reports that it lost its connection to TV server, then locks up, then ultimately crashes. So that's not a workable solution.
     
  7. ultimatejoe

    ultimatejoe Portal Member

    Joined:
    October 14, 2007
    Messages:
    39
    Likes Received:
    0
    Ratings:
    +2 / 1
    Home Country:
    Canada Canada
    Show System Specs
    Has anyone solved for this issue? I have the exact same problem and haven't found a good solution, or any solution really.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!