Help with TV setup (1 Viewer)

CyberSimian

Test Group
  • Team MediaPortal
  • June 10, 2013
    2,346
    1,428
    Southampton
    Home Country
    United Kingdom United Kingdom
    Country flag
    The scan was really fast but it came up with all red channels (same as before).
    From reading mm's post in the thread I linked before, that outcome looks favourable. It found a total of 765 channels (which looks a believable number), and did not diagnose any errors. (y) :)

    If all of the channels found are red, it may be that you have not configured MP to use the CAM. mm in his post describes what you need to do; I will quote it here:
    1. Edit the settings for each CableCARD tuner (select, click "edit"...) - tick "CAM enabled and present for this card" and set "this card can decode..." to 1, then click save. For more information see -->here<--.
    2. Go to the "scan" tab in the "general" section of TV Server configuration.
    3. Change the SDT/VCT setting to roughly 120 seconds. You may need to increase this time if you find channels are missing or don't have proper names.
    4. Go to the "DVB EPG" section in TV Server configuration.
    5. Untick the the two "enabled" checkboxes for the timeshifting/recording and idle EPG grabbers. This EPG grabber will not help you to get EPG. If enabled it will use your tuners pretty much continuously, which is unnecessary power use, wear and tear.
    Looking at the screen shots shown in the "Edit Tuner Settings" section of this page in the Wiki, you need to ensure that use of the CAM is enabled, and that the number of channels that can be decoded is set to 1. The screen shot shows this value set to 0. If this is the value in effect on your system, it might explain why all of the channels found are red. :(

    -- from CyberSimian in the UK
     

    Old school Bob

    New Member
    August 13, 2020
    32
    1
    Home Country
    United States of America United States of America
    Country flag
    Edit the settings for each CableCARD tuner (select, click "edit"...) - tick "CAM enabled and present for this card" and set "this card can decode..." to

    How do I get there? Can't find that screen.
    Change the SDT/VCT setting to roughly 120 seconds. You may need to increase this time if you find channels are missing or don't have proper names.

    Again I can't find that screen.


    Untick the the two "enabled" checkboxes for the timeshifting/recording and idle EPG grabbers. This EPG grabber will not help you to get EPG. If enabled it will use your tuners pretty much continuously, which is unnecessary power use, wear and tear.


    That one I found:
    mp 30.JPG
    "Edit Tuner Settings" section


    Can't find that either - but it's getting late here. I'll try again tomorrow.

    Thanks for the help.

    Bob
     

    CyberSimian

    Test Group
  • Team MediaPortal
  • June 10, 2013
    2,346
    1,428
    Southampton
    Home Country
    United Kingdom United Kingdom
    Country flag
    Edit the settings for each CableCARD tuner (select, click "edit"...) - tick "CAM enabled and present for this card" and set "this card can decode..." to 1, then click save. For more information see -->here<--.
    How do I get there? Can't find that screen.
    Sadly, the Wiki is not clear here (because the screen shots are not showing complete panels). :(
    • Start "TV Server Config".
    • Expand the list of TV servers (left side menu).
    • Expand your TV server (mine is called "Dell"; yours is "Bob-PC").
    • Select "Bob-PC".
    You should get a panel that looks similar to this:

    tuner_list.jpg

    Notice that there is a greyed-out "Edit" button in the lower right corner. Now select one of the tuners. This will enable the "Edit" button:

    tuner_selected.jpg

    Finally, click the "Edit" button. The "Edit Tuner" panel will appear:

    tuner_edit.jpg

    The "Edit Tuner" panel that I see is for a DVB-T tuner, so its contents are slightly different from yours. You should see something like the following (I copied this from the Wiki):

    tuner_edit_cable_card.png

    Check that the settings are as I described previously (i.e. that CAM is enabled, and decodable channels=1), and then try scanning using that tuner. If that works, you will need to repeat the settings for the other tuner.

    I don't know where the SDT/VCT (timeout) setting is set. It is not shown on the "Edit Tuner" panel in the Wiki (but that screen shot may be out of date).

    -- from CyberSimian in the UK
     

    Old school Bob

    New Member
    August 13, 2020
    32
    1
    Home Country
    United States of America United States of America
    Country flag
    I've done everything as suggested and still get all red channels. I followed the Wiki as suggested.

    Why is this so difficult.
     

    CyberSimian

    Test Group
  • Team MediaPortal
  • June 10, 2013
    2,346
    1,428
    Southampton
    Home Country
    United Kingdom United Kingdom
    Country flag
    I've done everything as suggested and still get all red channels. I followed the Wiki as suggested.
    Regrettably I don't have any other suggestions for things to try :(. Perhaps others will have some ideas.

    Remember, it may be the case that your cable provider encrypts all channels in the way that MP cannot process. If this is the case, MP will never work with your cable TV signals.

    Since Hauppauge suggested "NextPvr" as a possible alternative to WMC, you might consider installing NextPvr to see if it will work. I have never used it, but from their web site it looks to have similar functionality to MP. However, if encryption is the problem, NextPvr will also be unable to process the cable TV signals.

    If you don't want to try NextPvr, or it also does not work with your cable provider, then the only solution that I can see is to remain using WMC.

    I am sorry that so far this has been a fruitless exploration of MP's abilities to handle your tuner. :(

    -- from CyberSimian in the UK
     

    Old school Bob

    New Member
    August 13, 2020
    32
    1
    Home Country
    United States of America United States of America
    Country flag
    I really wanted MP to work but I downloaded NextPVR and HDhomerun. HDhomerun picked up all my channels right away and I can watch them there. I don't have NextPVR working yet so I don't get any TV guide or able to record. But it's closer than I've been before.

    I don't understand why HDhomerun can pick up my channels and MP picks them up but there're all red. It sees the channels but just won't let me use them.

    Thanks

    Bob

    mp40.JPG
     
    Last edited:

    Users who are viewing this thread

    Similar threads

    So after a long search and a lot of experiments I did find out the culprit: I did disable events of the Common Information Model Object Manager. As soon as they are disabled TV server will always show "port 554 is already bound". Enabling/disabling events is done by this reg key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WBEM\CIMOM]...
    So after a long search and a lot of experiments I did find out the culprit: I did disable events of the Common Information Model...
    I've got a Digital Devices Cine S2 V7A Twin and a DigitalEverywhere FloppyDTV for Satellite TV. I've been running MediaPortal 1.4.0...
    Replies
    1
    Views
    298
    I found the resolution: I had set this registry value set to 0: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WBEM\CIMOM] "EnableEvents"="0" As soon as I set it back to the default value 1, TV server did no longer say port 554 is bound and TV was working. On MediaPortal 1.4.0 and earlier the reg value could be set to 0 without any problem...
    I found the resolution: I had set this registry value set to 0: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WBEM\CIMOM]...
    I've described my problem here: https://forum.team-mediaportal.com/threads/satellite-tv-not-working-in-mediaportal-1-28.140530/ And...
    Replies
    1
    Views
    654
    The "TV Server" part of MP is included in the MP download. However, it is installed only if you specify at install time that you will be using a TV tuner. If the install is successful, there are two config tools. You access these via shortcuts on the Windows desktop: MediaPortal Configuration TV Server Configuration -- from...
    The "TV Server" part of MP is included in the MP download. However, it is installed only if you specify at install time that you...
    I am a newbie coming over from MythTv. I have downloaded Media Portal 1.25 onto Win 10 Home. Installed OK but with no TV con fig. I...
    Replies
    1
    Views
    454
    It's described in WIKI. see last chapter here.
    It's described in WIKI. see last chapter here.
    OK, I'm not the best at software, I'd rather build computers. Anyway, I just want to use media portal as a TV tuner software. I...
    Replies
    2
    Views
    520
    Thanks CyberSimian, I'll see what I can find at the Green Button web site.
    Thanks CyberSimian, I'll see what I can find at the Green Button web site.
    Hi Folks, I have a Dell XPS Desktop computer that I've had an Analog Angel USB TV Tuner hooked up to for the past 5+ years that...
    Replies
    7
    Views
    1K
    Top Bottom