[solved] How to add TV setup to an already existing installation without breaking it? (1 Viewer)

makafre

Portal Member
January 5, 2010
22
1
Canada Canada
Country flag
Hello,

The title says it all, I have an existing setup with thousands of movies and songs that I maintain since several years but this installation doesn't include any TV setup. I however now need to add TV functionality as server and client; how do I do this without breaking my current installation? :)

Thanks!
 

JimCatMP

Documentation Group
  • Team MediaPortal
  • April 1, 2010
    649
    282
    Leeds
    United Kingdom United Kingdom
    Country flag
    Hi

    Actually should be very simple [MePo is VERY good at installing over existing install and maintaining ALL existing capabilities & setting] - but given you have invested lots of time already, taking it a bit steady is probably for the best [having ploughed ahead myself before now confident I knew exactly what I was doing and WHERE I was doing it, before hitting that 'oh smeg' moment:cry:

    All the really 'important' information you have is in the databases [these contain the info[ & thumbs [as it's a whole lot of pictures ] - protect these at all costs before you start - so make backup of c:/ProgramData/Team MediaPortal [assuming it's on C: - and you will have to make that directory visible, as c:/ProgramData is hidden by default in Windows] - this will also ensure your skin and any mods are also protected.

    While you doing that [which may take a while depending on size dir and speed of drives etc] - what version of MePo are you currently running? I ask as if your not on 1.12, it's a good point to upgrade MePo?

    Cheers - JCMP.
     

    makafre

    Portal Member
    January 5, 2010
    22
    1
    Canada Canada
    Country flag
    Hi JCMP and thanks for the assistance;

    So I followed your advice and just did a backup of C:\ProgramData\Team MediaPortal after upgrading to 1.12 along with updating to the latest Moving Pictures and LAV filters plugin.

    Whats next doc? :)
     

    JimCatMP

    Documentation Group
  • Team MediaPortal
  • April 1, 2010
    649
    282
    Leeds
    United Kingdom United Kingdom
    Country flag
    Hi.

    I've assume you're installing the TV server bit on existing client - in context Server == TVServer and Client == Full MePo other than TV server - and hence the TVServer is the smallest element:)

    Before going further - read <http://wiki.team-mediaportal.com/1_MEDIAPORTAL_1/13_Setup_Guides/2_TV_Setup>, it's worth the effort.

    In upgrading to 1.12 you've skipped a step I was relying on - no harm done, just would have made it less 'scary'.

    Re-install 1.12, do as a Fresh Install [as you have copy of the existing config, you will not loose anything].

    Select "YES" to' I will watch TV', then Perform "Advanced Install". [more so you can see what's happening].

    Select "SingleSeat" option, and unless you already have SQL install your happy with [and know your SQL server stuff] , select [its the default] MySQL 5.

    Now, just follow prompts, using default settings - NOTE, it's CRITICAL [really is if you want it work] that the PC your installing on has a FIXED IP address - no DHCP for this puppy [client and server elements are separate and communicate over network, even on same machine] - and make a note of this address.

    Once the install is complete, test it - ignore missing plugins and paths, just test as is - just run config & close, run MePo & close, then reinstall the MovingPictures and LAV plugins - don't worry that MovingPictures is 'empty' - all this simply ensures everything outside the ProgramData dir is correct.

    If TVServer is running, kill process.

    Make a copy of the MediaPortal.xml somewhere OTHER than where you have existing backup [just in case]. Copy backup files over the new setup.

    Rerun MePo config and enable the TV plugin, setting the IP address to the IP address of the machine - this is why NO DHCP.

    Install TV hardware & driver, then run the MePo TVServer config - this is entirely separate to MePo, so it's impossible to break main setup from here - now depending on hardware & location - it's back to the Wiki for detailed guidance <http://wiki.team-mediaportal.com/1_MEDIAPORTAL_1/13_Setup_Guides/2_TV_Setup> and remember, there a whole host of very skilled and supportive bods on this forum, if your hardware, drivers, location or just anything else is problematic, ask:)

    So take your time, read the Wiki, MePo is massively tolerant of problem [it may not work, but fix is typically simple IF it goes mental] & remember you have a local data backup & remote friends :cool:

    TTFN - JCMP
     

    makafre

    Portal Member
    January 5, 2010
    22
    1
    Canada Canada
    Country flag
    So just to clarify and we make sure we are on the same page (I dont want to mess it :)

    The PC I use is the server but I also want to watch TV on it, and allow future PC clients that will be on the same network to watch TV as well by connecting to the server.

    So knowing that you are saying that I can follow these steps for what regards the server side and that I don't need to preinstall the TV card yet as it can be done later on in the steps.
     

    JimCatMP

    Documentation Group
  • Team MediaPortal
  • April 1, 2010
    649
    282
    Leeds
    United Kingdom United Kingdom
    Country flag
    Hi

    Yes - your current machine will be the TVServer within your network - serving client installed on itself and additional clients in the future on your network - hence fixed IP is your friend.

    Install of TV cards - can be before or after installing MePo, but needs to be completed before you configure the TVServer - out of the box it will give you 2 IP streams 'tuners', once your real hardware is in place & driers installed - suggest you post details here, IF there are any known issues or specific recommendations, good chance someone will pick them up - all being well, TVServer will pick them up and make then available in the config for scanning and all the channel management/guide stuff.

    One recommendation, IF your servers has the capacity, suggest creating RAM disk for timeshift [saves on spinning the rust for standard hard drives or wearing the SSD] - as data is ephemeral, loss on reboot isn't really issue.

    http://wiki.team-mediaportal.com/1_...r/Ramdisk_for_Timeshifting?highlight=ram+disk

    TTFN - J.
     

    makafre

    Portal Member
    January 5, 2010
    22
    1
    Canada Canada
    Country flag
    Hello JCMP ,

    So I went through the steps that you listed:

    - Installed hardware
    - Created backup
    - Did fresh install with TV option, single seat and SQL5 (all defaults)
    - Started and closed MePo config and Mepo it self
    - Added Moving pictures and LAV plugins
    - Backed up new MediaPortal.xml
    - Overwrote MediaPortal.xml using original one

    Now if I open MePo I still see moving pictures and music as empty? Are there any other files we should copy from the backup folder?

    Thanks!
     

    JimCatMP

    Documentation Group
  • Team MediaPortal
  • April 1, 2010
    649
    282
    Leeds
    United Kingdom United Kingdom
    Country flag
    Hi.

    Copied the database/thumb files into database/thumb DIR - while MePo is not running?

    Cheers - JCMP.
     

    makafre

    Portal Member
    January 5, 2010
    22
    1
    Canada Canada
    Country flag
    It worked!

    We need to copy the database and thumbs folders; here are the complete steps:

    - Installed hardware
    - Created backup of mediaportal folder
    - Did fresh install with TV option, single seat and SQL5 (all defaults)
    - Started and closed MePo config and Mepo it self
    - Added Moving pictures and LAV plugins
    - Backed up new MediaPortal.xml, database and thumbs folders
    - Overwrote MediaPortal.xml using backed up one
    - Overwrote database folder using backed up one
    - Overwrote thumbs folder using backed up one

    This way I was able to retain settings for:

    - Moving pictures configuration and thumbs
    - Music configurations

    What I seem to have lost in the process:

    - Pictures configuration

    ...but that is not a problem, its easily configurable and for what regards the TV card side it is already up and running.

    So THANK YOU for helping me avoiding to go through movingpictures reconfiguration, it would have taken me a week otherwise! :)
     

    JimCatMP

    Documentation Group
  • Team MediaPortal
  • April 1, 2010
    649
    282
    Leeds
    United Kingdom United Kingdom
    Country flag
    Magic - VERY please it all worked out for you.

    Also, IF Pictures was a big consideration, you can copy segments between your backup mediaport.xml and current version [you have to remove the working backup copy - RENAME not delete, so if it's all goes bad, you revert to backup copy(y). Cut the the Pictures section from old file, paste into new file, remove existing Pictures config in new file - recommend side by side editing, so you can source & destination:) Only for the brave of heart or terminally desperate though:eek:

    TTFN - JCMP.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    ajs [solved] Add CI AppVeyour to github account MediaPortal 1 46
    M Add Radio channels and EPG to Mediaportal xmlTV 2
    horned_reaper [solved] Add support for Bluetooth events Improvement Suggestions 2
    ajs [WiP] 5030: Add UHD Thumb size to TV Server MediaPortal 1 0
    ajs [fixed] 5029: Add the ability to choose the type of pause for designers in the slideshow MediaPortal 1 4
    P MP 2 - Request to add an additional TV series Filename protocal Feature Requests 0
    raffe How to add 500+ streams? OnlineVideos 1
    T How to add missing buttons IR Server Suite (IRSS) 0
    R [solved] Moving pictures importer wont add files from a removable drive. Is there a work around ? Moving Pictures 8
    cbr954rr Possibillity to add more Movie Folders in Menu General 5
    ajs [solved] 4935: Add string.replace function to Skin engine MediaPortal 1 10
    haaitje Crashes when trying to add lyrics MPTagThat 0
    H Add site to home OnlineVideos 5
    E Can I add folder icons to my list of videos MediaPortal 1 Talk 9
    Timothy Cobb Mediaportal 2 Weather - Can't add Weather locations Plugin Development 5
    E How can I add some site to Online Video Plugin ? OnlineVideos 4
    O Help with TV setup Newcomers Forum 76
    D Hauppauge HDPVR 1212 quick setup ? Installation, configuration support 8
    J Where the heck is the Client side setup? General 2
    J TV Server setup question Newcomers Forum 0
    M Initial Setup MP2 (On Wndows 10) General 2
    W Setup data connection - mySQL connection failed Installation, configuration support 1
    A Client/Server Setup: Slow TV Startup Television (MyTV frontend and TV-Server) 0
    A MP2.2.2, understanding movies/videos/tv and WTV recordings. General 16
    C Setup failed: 0xfffffff7 Allgemeines Support- und Diskussionsforum 1
    Similar threads

























    Top Bottom