IMDB-Full script update -> Description field import fix (1 Viewer)

GaryMartynUK

MP Donator
  • Premium Supporter
  • June 12, 2012
    89
    77
    45
    Portsmouth
    United Kingdom United Kingdom
    I can't see this already mentioned in the forum so hope I am not wastefully creating a duplicate thread.

    I realised today that the last few films I have imported with the IMDB-Full script have received either blank description fields or have received "Cast Overview:" as the description. I ran an update on my scripts to get the latest versions but get the same results.

    I assumed the tags for the description field have changed so went and had a look and it seems they may have done. I've updated the key start to description" content=" and the key stop to " /> this may not be the best choice but it is working for me. Thought I would share as this may be affecting others and if an update IMDB-FUll script could be pushed out through the update process this could save others experiencing the problem.

    My first attempt at doing anything with the scripts beyond running them as-is. Hope this info helps and thanks for including a script editor... it has saved the day for me.
     
    Last edited:

    erichzann

    MP Donator
  • Premium Supporter
  • October 25, 2011
    244
    34
    Oxford
    United Kingdom United Kingdom
    Yes, I noticed that the description fields are empty using the IMDb-Full script as well.

    Would someone be able to update the online grabber script so that I can download the update?

    Thanks in advance.
     

    Guzzi

    Retired Team Member
  • Premium Supporter
  • August 20, 2007
    2,161
    747
    Country flag
    ... fixed description and ttitle here, but noticed, there is a lot of other stuff broken as well, so needs some more work before it can be posted as online update ... any help is welcome as always :)
     

    Dadeo

    Docs Group Manager
  • Premium Supporter
  • November 26, 2006
    5,340
    3,321
    Himalayas, India
    Canada Canada
    Hi z3us - thanks I can confirm your IMDB-Full update does grab descriptions, however, I still get extra spaces when there are multiple values in the Country or Languages fields (see Issue 331 in Tracker) It seems IMDB changed the format somewhat and we need to adjust the regex or strip something.

    I also have a lot more trouble getting covers now - they only download occasionally for me now. I suspect that is due to the much larger images on IMDB? Even in Grabber Engine the image won't display until I 'preview' the URL Cover parameter on the Detail Page. Though I am not 100% sure that is a 'new' issue ;)

    I also have some other issues with the Grabber Engine, probably due to the IMDB changes as well - See Issue 334 in Tracker - Can you confirm, or add any other issues in Grabber Engine you might have? When Guzzi fixes them he may as well do them all :p
     

    z3us

    Portal Pro
    December 4, 2007
    1,047
    123
    40
    Spain Spain
    Hi z3us - thanks I can confirm your IMDB-Full update does grab descriptions, however, I still get extra spaces when there are multiple values in the Country or Languages fields (see Issue 331 in Tracker) It seems IMDB changed the format somewhat and we need to adjust the regex or strip something.
    I tried, but I couldn´t fix the extra-spaces problem. Sorry

    I also have a lot more trouble getting covers now - they only download occasionally for me now. I suspect that is due to the much larger images on IMDB? Even in Grabber Engine the image won't display until I 'preview' the URL Cover parameter on the Detail Page. Though I am not 100% sure that is a 'new' issue ;)
    I´m not having any problems with covers. Which grabber and film are you using?

    I also have some other issues with the Grabber Engine, probably due to the IMDB changes as well - See Issue 334 in Tracker - Can you confirm, or add any other issues in Grabber Engine you might have? When Guzzi fixes them he may as well do them all :p
    No, I can´t confirm. Works fine here
     

    Attachments

    Dadeo

    Docs Group Manager
  • Premium Supporter
  • November 26, 2006
    5,340
    3,321
    Himalayas, India
    Canada Canada
    I tried, but I couldn´t fix the extra-spaces problem. Sorry
    Yeah same here - regex gives me a headache and I am sure it kills brain cells LOL
    We will probably have to wait for Master Yoda (Guzzi)
    I´m not having any problems with covers. Which grabber and film are you using?
    Many! Latest was Man of Steel using IMDB-Full and I checked again with your updated grabber and still no luck :( - even updating via GUI didn't grab it. I can't get anything via Cover manager either - but maybe it is related to my using relative paths? (my covers are all in a \pictures subfolder of my catalog folder).
    I also have some other issues with the Grabber Engine, probably due to the IMDB changes as well - See Issue 334 in Tracker - Can you confirm, or add any other issues in Grabber Engine you might have? When Guzzi fixes them he may as well do them all :p
    No, I can´t confirm. Works fine here
    Cool thanks - I am using Win 7 64 bit and often have some display issues in AMCU View Movies for images as well which Guzzi cannot reproduce, so will need further investigation/testing :cry: but good to know it does not affect everyone - thanks!
     
    Last edited:

    z3us

    Portal Pro
    December 4, 2007
    1,047
    123
    40
    Spain Spain
    I can´t reproduce any of your problems (except grabbing field country with several items). I also use w7 64, but I have the covers stored in the same path where my catalog is
     

    Dadeo

    Docs Group Manager
  • Premium Supporter
  • November 26, 2006
    5,340
    3,321
    Himalayas, India
    Canada Canada
    That's actually really good! (for you and other users! ;)) However, I might also be using a later test version than you z3us - V6.0.3.2868 ;). Anyway I posted logs in the issues, so I'm sure when Guzzi can take a look he will spot the problem(s).
     

    Guzzi

    Retired Team Member
  • Premium Supporter
  • August 20, 2007
    2,161
    747
    Country flag
    Hi z3us - thanks I can confirm your IMDB-Full update does grab descriptions, however, I still get extra spaces when there are multiple values in the Country or Languages fields (see Issue 331 in Tracker) It seems IMDB changed the format somewhat and we need to adjust the regex or strip something.


    I tried, but I couldn´t fix the extra-spaces problem. Sorry


    I also have a lot more trouble getting covers now - they only download occasionally for me now. I suspect that is due to the much larger images on IMDB? Even in Grabber Engine the image won't display until I 'preview' the URL Cover parameter on the Detail Page. Though I am not 100% sure that is a 'new' issue ;)
    I´m not having any problems with covers. Which grabber and film are you using?



    I also have some other issues with the Grabber Engine, probably due to the IMDB changes as well - See Issue 334 in Tracker - Can you confirm, or add any other issues in Grabber Engine you might have? When Guzzi fixes them he may as well do them all :p
    No, I can´t confirm. Works fine here
    I think there is some problems with the trunk version Dadeo is running - as I can confirm the problems as well. It might be related to some image resizing work I did some month ago - but I'll have to debug - just to confirm, that there is a problem in latest trunk version.
    However, this should not keep us from fixing the site issues - at least the grabber script editor of last public release does not have that issue.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom