Iptv source - discontinuities on specific hardware/os

Owlsroost

Development Group
  • Team MediaPortal
  • October 28, 2008
    5,538
    113
    Cambridge
    Country flag


    In 'MPIPTVSource.ini' can you change the 'LogVerbosity' value to 4 then run it and collect the logs.
    Then change 'LogVerbosity' to 5 and run it/collect the logs again.

    Zip up the the two sets of logs (all of the TV Server logs, not just the MPIPTV logs) and upload them here and I'll take a look.

    This isn't my code (and I've never looked at it before) and the original authors are no longer on the team (as far as I know), so I can't promise a fix - and it might take some time to understand what's going on.
     

    B0ycee

    Portal Member
    April 23, 2014
    11
    1
    Wondered if anyone managed to have a look at this?

    Do I need to open a bug or something?
     

    Owlsroost

    Development Group
  • Team MediaPortal
  • October 28, 2008
    5,538
    113
    Cambridge
    Country flag
    No they haven't yet (I'm the only one who might look at it).

    Just to explain - there are only a few people who are active devs working on MP1, and what gets worked on depends on available spare time/interest in the problem/how many users the problem might affect/how easy it might be to fix it. At the moment there are more important things to work on related to getting the next release of MP1 out...
     

    Owlsroost

    Development Group
  • Team MediaPortal
  • October 28, 2008
    5,538
    113
    Cambridge
    Country flag
    If you want to have a look into it yourself, all of the MP1 source code is here - MediaPortal/MediaPortal-1 - with the MPIPTVSource DirectShow filter code in this sub-folder - MediaPortal/MediaPortal-1

    It can be built using the free Microsoft VisualStudio 2015 'community edition' tools (you need the C++ compiler add-on and the DirectX SDK installed as well to build the DirectShow filters).

    A bit out of date now (as it doesn't cover building on Windows 10), but see this Wiki page for more info - Building MediaPortal from source
     

    B0ycee

    Portal Member
    April 23, 2014
    11
    1
    Thanks for the complete answer. I was half expecting this would be the situation.

    Just one question - given this "flow" is entirely contained within the TV server I'm guessing it is highly likely the same bug would be seen in MP2 (isn't the code for this component shared?) Would it get more traction if I prove the issue on that too?
     

    Owlsroost

    Development Group
  • Team MediaPortal
  • October 28, 2008
    5,538
    113
    Cambridge
    Country flag
    Just one question - given this "flow" is entirely contained within the TV server I'm guessing it is highly likely the same bug would be seen in MP2 (isn't the code for this component shared?) Would it get more traction if I prove the issue on that too?
    Unlikely - as it would probably end up back with me :)

    Yes, most of TV Server and the DirectShow filters are shared between the two projects.

    I did have a look at your logs and some of the relevant filter source code when you posted them, but nothing obvious was jumping out at me in terms of what might be causing the problem.
     

    B0ycee

    Portal Member
    April 23, 2014
    11
    1
    Hi,

    I don't think I'm able to work on the code, but I have spent some hours testing this. It doesn't appear to be hardware dependant at all, however the issue appears with Windows 8 and Windows 10 (i.e it works only on Windows 7). I've proved this by using other hardware altogether and installing the 3 OS. Works perfectly with Windows 7, and then the discontinuities with other newer OS. VLC works fine across all the OS.

    Additionally, on MP2.2 (tested on Windows 7 and 8) it fails during scanning for channels so I cannot even get to the discontinuities aspect. I attach what might be a relevant log, however this is likely a different issue altogether!

    Strange how it works absolutely as expected on Windows 7.
     

    Attachments

    Owlsroost

    Development Group
  • Team MediaPortal
  • October 28, 2008
    5,538
    113
    Cambridge
    Country flag
    A lot of the recent 'under the hood' changes in Windows were introduced in Windows 8, so I suspect that was when MS changed the network packet handling behaviour (in some way or other) which the MPIPTVSource filter is sensitive to.

    The basic filter codebase is actually quite old (more than 10 years) with very few changes since then, so basically it was developed back in Vista/Win7 days...

    There was a re-worked version of the IPTV source filter being worked on in the thread here (latest posts) - MERGING MediaPortal Url Source Splitter & IPTV Filter - but I have no knowledge of using it or building it.
     
    Top Bottom