IRSS ( or earlier) doesn't see remote (1 Viewer)


MP Donator
  • Premium Supporter
  • August 30, 2006
    Home Country
    Afghanistan Afghanistan
    PC is running MP 1.4 and Windows 7 64-bit.
    Have an IR receiver that is detected as an eHome infrared receiver. It came with an RC5 model remote in a Hauppauge TV tuner kit.

    Like many many people before me, I could not get the combination of IR receiver and remote to be seen by anything. I was finally able to get Girder 5 to see it by using their replacement MCE driver. It then works fine within Girder 5. Earlier versions of Girder do not have this replacement driver and you can't use the driver on earlier versions.

    I have tried the receiver/remote on my Windows 7 64-biit laptop and was able to get it working using IRSS, but cannot get it working on the main PC. On both PCs, the same default drivers get installed by Windows when the receiver is plugged in.

    I have checked the event logs but they don't show any system or application issues. The generic/default driver that gets installed when you first plug in the IR receiver is the same on both PCs. The laptop proves that this driver works fine with IRSS (both the test build of and the current released version). All device drivers within Device Manager do not show any yellow exclamations or other issues - they are all installed fine.

    I have made sure that Girder has been uninstalled and that there are no apps or services using the IR receiver and thus blocking it from IRSS. I have rebooted at every step of my diagnosis.

    I've made the registry setting changes to prevent Media Centre from intercepting the remote/buttons.

    I've tried the multitude of alternative IR drivers out there but they're extremely old (e.g. 2006) and don't work with Windows 7 and/or 64-bit. Note that the IR receiver is not identified as a Hauppauge proprietary one that requires IR.exe or IR32.exe - it identifies as en eHome infrared Receiver and works OK with Girder 5.

    I have ensured that the IRSS configuration has the Hauppauge remote ticked as well as the Windows keyboard ticked. I have used the "Detect" feature and it ticks those automatically. On both the working laptop and the problematic PC, the same devices are ticked and configured (default) identically. The debug client successfully connects to the localhost and the connection dialog logged in the window shows that it is using the Hauppauge device. Yet it does not register any key presses.

    Essentially, the IR receiver drivers are installed and known to work with this device (on my laptop) with IRSS. No other drivers or apps or services that I can find are trying to use the device. There are no errors anywhere that I can find.

    If I can't get IRSS working, I may be forced to use the Girder 5 solution. However, there is almost no discussion in the MP forums on using Girder with MP - at least, none in the last few years, which tells me that nobody needs to or simply won't use it. (I have also tried the latest version of "HIP" but that too does not see the receiver and does NOT work on Hauppauge remotes under Win 7 64-bit (confirmed)). There is one very old thread that someone put together to show how to get it working, but it uses very old versions of Girder and MP and the included files no longer work. So that's a dead end. After about 5 hours of intense debugging of all this, I don't have the willpower to spend several hours working out how to get Girder to control MP. The lack of any documentation on getting the two working together tells me that its either trivially easy (some tick box I've missed in Configuration.exe perhaps) or stupidly technical.

    So my questions are thus:

    - Is there any way to tell where the fault may lie:
    -- some sort of lower-level tool that would let me see if the device is being locked by another service
    -- some way to see exactly which device IRSS believes it is connecting to
    -- some way to enable tracing of what IRSS is doing

    - Is there some alternative driver I should be using on Win 7 64-bit, or additional driver, or additional configuration that I need to enable?

    Users who are viewing this thread

    Top Bottom