[ISSUE] TagReader failing on some file types (1 Viewer)

MegaPVR_Rack

Portal Member
December 11, 2008
38
2
Italy Italy
Hello all, I am restructuring my music collection using various encoding formats, and I just found out MP can't read tags from some music files.
Mpeg Layer 2 .MP2: No (ID3v1+v2.3)
Mpeg Layer 3 .MP3: Yes (all ID3 versions)
Windows Media .WMA: Yes (WMA tags)
AAC .M4A: Yes (MP4 tags)
Vorbis .OGG: Yes (Vorbis tags)
Vorbis .OPUS: No
Musepack .MPC: No (APEv2 and ID3v1)
Wavpack Lossy and Hybrid .WV: Yes (APEv2)
FLAC: Yes (Flac tags)

I am using MP 1.12.0 Stable with ASIO BASS (Asus Xonar ST). Should I upgrade to the latest? Strange since it reads i.e. APEv2 from Wavpack files but not from Musepack files and I remember getting ID3 on MP2 files to work years ago.

All files play back OK.

All I get is "Track information not available" on my HTPC front display.
 

MegaPVR_Rack

Portal Member
December 11, 2008
38
2
Italy Italy
Just downloaded, will try. One quick question regarding hybrid Wavpack files: will Bass play them losslessly if it finds the same-name WVC correction file near the WV?
 

MegaPVR_Rack

Portal Member
December 11, 2008
38
2
Italy Italy
Just upgraded to 1.14.0-PRE but no change. Same file types play fine but without tags.
:(:confused:[DOUBLEPOST=1458485878][/DOUBLEPOST]LOG:
Just checked MP Log and found the TagReader warning messages.

[Log ] [16 ] [WARN ] - TagReader: Exception reading file \\nas0\ld0\Music Collection 4\AJ MCLEAN Have It All\01TEENAG.mpc. Data does not begin with identifier.

For Opus files the playback chain does not throw any warning, simply because it just calls g_Player.Play() without calling TagReader first.
 
Last edited:

hwahrmann

Development Group
  • Team MediaPortal
  • September 15, 2004
    4,542
    2,333
    Vienna, Austria
    Austria Austria
    Country flag
    I just can confirm that the MPC files are not handled corectly, because we have only support for V7 specs and you have v8 specs.

    can you upload MP2 and OPus samples to some file hoster and post the link please?
     

    Memorix

    Portal Member
    May 1, 2012
    12
    4
    Germany Germany
    Country flag
    Hello,

    I can confirm this issue for opus files. I already reported it in this thread. In the attachment is a short fully tagged opus file for testing.

    With best regards

    Momorix
     

    Attachments

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    1gkar A Couple of {On-going} Issues Within Various MP Versions General Support 6
    R MP2 GUI Issues General 7
    morpheus_xx [WiP] WIP 2.3 Fanart issues? MediaPortal 2 13
    morpheus_xx [Help Me!] Build issues on TeamCity MediaPortal 2 1
    W Not finding/matching new series - thetvdb issue? My TVSeries 3
    J [fixed] Import issue with alternate movie title matching the name of another movie Submit: Bug Reports 7
    1gkar Latest Intel HD4600 Drivers Issue General Support 1
    J Odd issues with Freesat EPG - MP2 General 18
    DHosein Mediaportal & Antimalware Service High CPU issue General Support 2
    J MediaPortal TV Server and Kodi media source issues General 9
    S Movie navigation issues in MP2 General 8
    cbr954rr Issue BOOTSUWRNQ with online videos? Plugin Development 1
    2BitSculptor MP1.23 release mediainfo issue? MediaPortal 1 Talk 4
    A TV Channel Combination - case issue Television (MyTV frontend and TV-Server) 0
    Edwardfc [solved] Mp 2.2.1 Configuration Issues - Goes to Sleep while playing Music General 6
    G Amazon Prime (Online Videos) Issue Plugin Development 6
    joecrow 1.22.0 MPE Manager issues. 1.22 5
    M [solved] MP2 v 2.2.1 Issue - Registry Key not created General 5
    D [solved] Multiple issues with new MP2.2.1 install 2.2 Archive 7
    S [solved] Live TV subtitle issue if not using 100% font General 31
    T FF or Rewind video issue watch/edit Videos 0
    K server issue OffTopic 0
    T Issues with MediaPortal not starting correctly using versions after 1.20 Final General Support 6
    johns11 [solved] MP2.2 TV configuration issue General 4
    A Issues with new install of My Emulators 2 My Emulators 11
    Top Bottom