Issues connecting to database and starting Live TV.. (1 Viewer)

Jason Mcleod

New Member
April 25, 2012
3
0
40
United Kingdom United Kingdom
Hi,

I'm really hoping someone can help me with this issue (or issues) I'm having, as I think I've pretty much run out of ideas for this now...

Over the last couple of days, I've installed MediaPortal on a couple of PCs and TV4Home on my Windows Home Server whicn also contains the DVB-T tuner.

The issues I'm having are consistent on both PCs. When opening MediaPortal and going into the TV section, I can configure the connection to the server and it connects successfully, but fails to connect to the database, with a message like "Connected to TV-Server. Unable to connect to database. All IP ports seem to be fine". Although I am getting EPG information on now & next on the main TV page, I don't know if this is relevant.

The other issue (no idea if related or not) is that if I try to launch Live TV or select a channel to watch, all I get is "Unknown error occurred".

I've done a lot of searching around and tried all feasible fixes I found, including uninstalling and reinstalling pn both sides, I've checked MySQL passwords, firewalls, database corruption, host name, IP addresses and god only knows what else.

I'm new to MediaPortal, so if anyone can shed some light on ay of this I'd really appreciate it. And sorry for the long post :)
 

regeszter

Retired Team Member
  • Premium Supporter
  • October 29, 2005
    5,335
    4,954
    Hungary Hungary
    Check if add to your hosts file (c:\Windows\System32\drivers\etc\) "the server ip address" localhost

    for example:

    192.168.1.100 localhost

    if it do not resolve your problem, pl. restore the original state of the hosts file
     

    Jason Mcleod

    New Member
    April 25, 2012
    3
    0
    40
    United Kingdom United Kingdom
    OK, so the hosts file already contains an entry for the server where the TV4Home and MediaPortal TV server is installed, I did this quite a while ago for some other issues I had reaching other services on the server.

    Now, do you want error.log or MediaPortal.log? Error.log on the client only has this:

    2012-04-25 22:01:05.372371 [ERROR][MPMain(1)]: TvPlugin and TvServer don't have the same version.
    TvServer Version: 1.1.2.0
    TvPlugin Version: 1.2.3.0

    I should probably address that :)

    And the error.log on the server is a big one, so should I post it all or is there a way to attach it? I think it's too long to put into one post.

    Thanks for the help!
     

    Jason Mcleod

    New Member
    April 25, 2012
    3
    0
    40
    United Kingdom United Kingdom
    It's fixed!!!

    In the end I had to install and configure Windows Media Player 11 on the Windows Home Server, then update the TV-Server package to 1.2.3 so it matched the version of MediaPortal on the client. After that, it works like a charm :D

    All I need to do now is make some changes on the networking to clean up the stream a bit, then we're golden!

    Thanks for pointing me in the right direction!
     

    elliottmc

    Retired Team Member
  • Premium Supporter
  • August 7, 2005
    14,927
    6,061
    Cardiff, UK
    United Kingdom United Kingdom
    Country flag
    When you installed MediaPortal, did the installer warn you that your OS was not supported? There are very good reasons why WHS is not a supported OS for MP, even though some experienced users are able to get it to work.

    If there was no warning, this would be a bug.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    horned_reaper Issue with / character in artist name Fanart Handler 5
    1gkar A Couple of {On-going} Issues Within Various MP Versions General Support 25
    R MP2 GUI Issues General 7
    morpheus_xx [WiP] WIP 2.3 Fanart issues? MediaPortal 2 13
    morpheus_xx [Help Me!] Build issues on TeamCity MediaPortal 2 1
    W Not finding/matching new series - thetvdb issue? My TVSeries 3
    J [fixed] Import issue with alternate movie title matching the name of another movie Submit: Bug Reports 7
    1gkar Latest Intel HD4600 Drivers Issue General Support 1
    J Odd issues with Freesat EPG - MP2 General 18
    DHosein Mediaportal & Antimalware Service High CPU issue General Support 2
    J MediaPortal TV Server and Kodi media source issues General 9
    S Movie navigation issues in MP2 General 8
    cbr954rr Issue BOOTSUWRNQ with online videos? Plugin Development 1
    2BitSculptor MP1.23 release mediainfo issue? MediaPortal 1 Talk 4
    A TV Channel Combination - case issue Television (MyTV frontend and TV-Server) 0
    Edwardfc [solved] Mp 2.2.1 Configuration Issues - Goes to Sleep while playing Music General 6
    G Amazon Prime (Online Videos) Issue Plugin Development 6
    joecrow 1.22.0 MPE Manager issues. 1.22 5
    M [solved] MP2 v 2.2.1 Issue - Registry Key not created General 5
    D [solved] Multiple issues with new MP2.2.1 install 2.2 Archive 7
    S [solved] Live TV subtitle issue if not using 100% font General 31
    T FF or Rewind video issue watch/edit Videos 0
    K server issue OffTopic 0
    T Issues with MediaPortal not starting correctly using versions after 1.20 Final General Support 6
    johns11 [solved] MP2.2 TV configuration issue General 4
    Top Bottom