Issues with new install of My Emulators 2

Discussion in 'My Emulators' started by alexanderfoti, March 23, 2019.

  1. alexanderfoti

    alexanderfoti Portal Member

    Joined:
    July 15, 2010
    Messages:
    15
    Likes Received:
    2
    Ratings:
    +2 / 0
    Home Country:
    United Kingdom United Kingdom
    Hi all

    I am having a few issues with My Emulators 2.

    It would seem the online scraping/searching system is not working correctly. When I add an an emulator, it is unable to search for the profile online, instead giving a drop down that is blank.

    Then, when I import games, I get "Waiting for approvals 0/21" but have no way to approve any of the results. The title drop down is blank:
    upload_2019-3-23_7-46-7.png


    I have this in the logs as well:
    Code (Text):
    1. [2019-03-22 19:13:08,079] [Error  ] [Importer Thread] [ERROR] - Emulators2 Cornerstone: Scraper Script XPATH parsing failed: Root element is missing.
    2. [2019-03-22 19:13:08,165] [Error  ] [Importer Thread] [ERROR] - Emulators2 Cornerstone: Connection failed: URL=http://maws.mameworld.info/maws/srch.php?search_text=pokemon%20stadium%202, Status=NotFound, Description=Not Found.
    3. [2019-03-22 19:13:08,222] [Error  ] [Importer Thread] [ERROR] - Emulators2 Cornerstone: Connection failed: URL=http://thegamesdb.net/api/GetGamesList.php?name=super%20mario%2064&platform=Nintendo 64, Status=NotFound, Description=Not Found.
    4. [2019-03-22 19:13:08,226] [Error  ] [Importer Thread] [ERROR] - Emulators2 Cornerstone: Scraper Script XPATH parsing failed: Root element is missing.
    5. [2019-03-22 19:13:08,464] [Error  ] [Importer Thread] [ERROR] - Emulators2 Cornerstone: Connection failed: URL=http://thegamesdb.net/api/GetGamesList.php?name=tony%20hawks%20pro%20skater&platform=Nintendo 64, Status=NotFound, Description=Not Found.
    6. [2019-03-22 19:13:08,468] [Error  ] [Importer Thread] [ERROR] - Emulators2 Cornerstone: Scraper Script XPATH parsing failed: Root element is missing.
    7. [2019-03-22 19:13:08,489] [Error  ] [Importer Thread] [ERROR] - Emulators2 Cornerstone: Connection failed: URL=http://maws.mameworld.info/maws/srch.php?search_text=mempak1, Status=NotFound, Description=Not Found.
    I am running MP 1.21 on Windows 10.



    Any ideas would be much appreciated.
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. ajs
    • Team MediaPortal

    ajs Development Group

    Joined:
    February 29, 2008
    Messages:
    8,475
    Likes Received:
    2,566
    Gender:
    Male
    Occupation:
    IT
    Location:
    Kyiv
    Ratings:
    +4,494 / 29
    Home Country:
    Ukraine Ukraine
    Show System Specs
    Site http://maws.mameworld.info return:
    Code (Text):
    1. 403 - Forbidden - Access to this resource on the server is denied!
    Some forum message:
    Code (Text):
    1. August 21, 2010, 08:26:25 pm - looks like the whole *.mameworld.info has been suspended, not just MAWS.
     
    • Like Like x 1
  4. alexanderfoti

    alexanderfoti Portal Member

    Joined:
    July 15, 2010
    Messages:
    15
    Likes Received:
    2
    Ratings:
    +2 / 0
    Home Country:
    United Kingdom United Kingdom
    That explains that one

    However all the scrapers have issues. Some give errors in the logs such as:

    Code (Text):
    1. [2019-03-22 19:13:08,222] [Error  ] [Importer Thread] [ERROR] - Emulators2 Cornerstone: Connection failed: URL=http://thegamesdb.net/api/GetGamesList.php?name=super%20mario%2064&platform=Nintendo 64, Status=NotFound, Description=Not Found.
    2. [2019-03-22 19:13:08,226] [Error  ] [Importer Thread] [ERROR] - Emulators2 Cornerstone: Scraper Script XPATH parsing failed: Root element is missing
    Some give nothing in the logs. I have tried all scrapers one by one and they are all the same.

    so, is the issue with the scapers, or is the issue with My Emulators 2 plugin having outdated API config?
     
    • Like Like x 1
  5. ajs
    • Team MediaPortal

    ajs Development Group

    Joined:
    February 29, 2008
    Messages:
    8,475
    Likes Received:
    2,566
    Gender:
    Male
    Occupation:
    IT
    Location:
    Kyiv
    Ratings:
    +4,494 / 29
    Home Country:
    Ukraine Ukraine
    Show System Specs
    API for thegamesdb changed ... Swagger UI :(
     
    • Like Like x 2
  6. Brownard
    • Team MediaPortal

    Brownard Development Group

    Joined:
    March 21, 2007
    Messages:
    1,899
    Likes Received:
    772
    Gender:
    Male
    Ratings:
    +1,302 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    @alexanderfoti @ajs Exactly 1 day short of 6 years since I last updated this plugin, I've pushed a fix for TheGamesDb, you can get it from here, or from the extensions installer.
     
    • Like Like x 2
    • Thank You! Thank You! x 2
  7. alexanderfoti

    alexanderfoti Portal Member

    Joined:
    July 15, 2010
    Messages:
    15
    Likes Received:
    2
    Ratings:
    +2 / 0
    Home Country:
    United Kingdom United Kingdom
    Thanks very much. I am giving it a go now.

    Much appreciated.
     
  8. alexanderfoti

    alexanderfoti Portal Member

    Joined:
    July 15, 2010
    Messages:
    15
    Likes Received:
    2
    Ratings:
    +2 / 0
    Home Country:
    United Kingdom United Kingdom
    With just thegamesdb.net set, I get the following error:
    Code (Text):
    1. [2019-06-12 08:42:10,746] [Config ] [Importer Thread] [ERROR] - Emulators 2: Unhandled error in Importer - Could not load file or assembly 'Newtonsoft.Json, Version=12.0.0.0, Culture=neutral, PublicKeyToken=30ad4fe6b2a6aeed' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)
    I wonder what dependency is missing?

    I do have Netwonsoft.Json.dll in my plugins/windows directory, but its version 12.0.2.23222 and the plugin appears to be referencing an older version?
     
    Last edited: June 12, 2019 at 09:02
  9. Brownard
    • Team MediaPortal

    Brownard Development Group

    Joined:
    March 21, 2007
    Messages:
    1,899
    Likes Received:
    772
    Gender:
    Male
    Ratings:
    +1,302 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Thanks, I wondered whether that reference might cause some issues, I'll check it this evening. Can you tell me what other plugins you have installed?
     
    • Thank You! Thank You! x 1
  10. alexanderfoti

    alexanderfoti Portal Member

    Joined:
    July 15, 2010
    Messages:
    15
    Likes Received:
    2
    Ratings:
    +2 / 0
    Home Country:
    United Kingdom United Kingdom
    No probs.

    Plugins installed are:
    Moving pictures
    MP-TV Series
    My Emulators 2
    OnlineVideos
    Trailers
    Trakt

    otherwise standard
     
  11. Brownard
    • Team MediaPortal

    Brownard Development Group

    Joined:
    March 21, 2007
    Messages:
    1,899
    Likes Received:
    772
    Gender:
    Male
    Ratings:
    +1,302 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    @alexanderfoti I think I've pushed a fix, let me know. It was caused by the Trakt plugin referencing/installing a different version of Newtonsoft.Json, I've changed it so that the plugin now uses the same version in the same place.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!