Keine Verbindung mit Kodi auf Server (1 Viewer)

AndreasK

Portal Member
February 23, 2010
47
0
Germany Germany
Country flag
Hallo,
ich weiß nicht ob ich hier richtig bin.
Ich versuche mit Kodi auf den Mediaportal Server zuzugreifen. Es funktioniert aber nicht.
Kurze meine Basis:
  • Kodi 18.7 ist auf einem firetv Stick 4K installiert
  • PVR client ist die Version 3.5.18
  • Der Mediaportal Server (stand alone) 2.2.3 läuft auf Windows
  • Kodi Plugin für 2.2.3 Kodi TV Plugin for various MP2 versions... ist installiert und aktiv
  • Ich habe im Plugin keine Einstellungen (Port usw.) verändert

Wenn ich in Kodi nun auf TV gehe, bekomme ich nur die Meldung „PVR Manager wird gestartet...“. Aber es tut sich nichts.
 

BlueMax1916

Super User
  • Team MediaPortal
  • Super User
  • January 29, 2007
    700
    124
    Germany Germany
    Country flag
    Hallo,

    also einmal bitte prüfen ob in der MP TV Server Konfiguration auf Deinem Server bei Streaming die richtige IP Adresse Deines TV Servers steht. Oft steht da Auto drin und dann klappt's nicht. Das verstellt sich auch manchmal spontan ohne Nutzereinwirkung zurück auf 'Auto' (zumindest bei mir). Dann musst Du Du noch ein Recording Share per UNC-Pfad eingeben und für dieses Share die Rechte 'Jeder' setzen.

    Dann in den Kodi PVR Client Einstellungen auf jeden Fall die IP Adresse Deines Servers setzen, nicht den Namen. Des weiteren einen Useraccount Deines MP2 TV-Servers unter dem die Server-Software läuft angeben. Dann noch Wiedergabe -> Streaming Methode: TSReader einstellen.

    Probier das mal aus.

    Gruß

    Blue Max
     

    AndreasK

    Portal Member
    February 23, 2010
    47
    0
    Germany Germany
    Country flag
    @BlueMax1916
    Unter Streaming Server war Auto eingestellt. Das habe ich geändert.
    Recording Share meinst du im Plugin des Servers richtig? Dort sind die schon vorhandenen eingetragen gewesen.
    Ich habe ja schon ein funktionierendes Client-Server System auf Windows Basis. Ich wollte halt mal Kodi ausprobieren.

    Leider brachten deine Tipps keinen Erfolg :(
     
    Last edited:

    AndreasK

    Portal Member
    February 23, 2010
    47
    0
    Germany Germany
    Country flag
    Ich habe nun schon einiges rum probiert.
    Firewall am Server deaktiviert, da ich dachte, dass Ggf. der Port nicht durchgelassen wird.
    Brachte alles keinen Erfolg.
    Unter Kodi-Ereignisse bekomme ich die Meldung, dass der Server nicht erreichbar ist.
    Also ich glaube fast, dass das Kodi Mediaportal Plugin nicht läuft, oder der Port schon belegt ist.
    Wie kann ich eigentlich beides prüfen?
     

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,105
    3,689
    Lehmden
    Germany Germany
    Country flag
    Hi.
    Also ich glaube fast, dass das Kodi Mediaportal Plugin nicht läuft, oder der Port schon belegt ist.
    Wie kann ich eigentlich beides prüfen?
    Das Plugin läuft, wenn das so (ähnlich) im MP TV Konfigurationstool aussieht:
    1593325916823.png

    Du musst dort für jeden Tuner sowohl bei Recordings als auch bei Timeshift einen eigenen Eintrag stehen haben (die können aber jeweils gleich sein, so wie bei mir). Und es muss sich natürlich um einen UNC Pfad handeln. Also kein Pfad mit Laufwerksbuchstaben. Das muss man schon beim Einrichten der Timeshift und Recordings Ordner in der MP TV Konfiguration berücksichtigen...
    1593328156757.png

    Übrigens ist es auch ohne Kodi besser, hier UNC Pfade statt Laufwerksbuchstaben zu verwenden. Nur so kann man Aufnahmen aus einem MP2 Klient heraus löschen, auch wenn der nicht auf demselben System wie der Server installiert ist. Daneben ist der Zugriff über UNC minimal schneller als über Laufwerksbuchstaben. Man hat also keinerlei nachteile, aber einige Vorteile, wenn man das so einrichtet...

    Ports in Benutzung kann man mit Windows Bordmitteln feststellen. Dazu eine DOS Fenster mit Admin Rechten aufmachen und "netstat -an" eintippen. Dann werden alle Prozesse, alle Netzwerkzugriffe angezeigt. Der Port 9596 ist allerdings mit Sicherheit in Benutzung, weil das Plugin ja aktiv ist, sobald der MP2 Server läuft. Um zu sehen, ob etwas anderes diesen Port verwendet, müsstest du das Plugin deaktivieren und anschließend das System neu starten. Dann den "netstat -an" Befehl noch mal ausführen. Sollte der Port jetzt noch in Betrieb sein, zunächst mal kontrollieren, ob das Plugin nicht doch noch aktiv ist. Falls nicht, verwendet tatsächlich irgendein anderes Programm diesen Port und du müsstest entweder dieses andere Programm oder das Kodi Plugin so umstellen, das ein anderer Port verwendet wird.

    Ich vermute aber ein ganz anderes Problem... Hast du zufällig Medien- Shares auf deinem TV Server? Falls ja, kannst du die problemlos über SMB in Kodi ansprechen? Falls du auch nur eine dieser beiden Fragen nicht mit einem eindeutigen "Ja" beantworten kannst, dann könnte es am fehlenden SMB V1 Protokoll liegen. Denn meist ist Kodi da etwas seltsam und mag nur dann SMB Verbindungen zulassen, wenn neben SMB V2 und V3 auch das alte SMB V1 Protokoll aktiviert ist. Das ist aber standardmäßig in Windows 10 deaktiviert, da es ziemlich veraltet und unsicher ist. "Offiziell" soll Kodi auch ohne SMB V1 laufen, aber meist geht es dann doch nur vernünftig, wenn V1 aktiviert ist... Außerdem läuft selbst Windows 10 nicht immer problemlos ohne SMB V1. So basiert die Erkennung der verschiedenen Computer im Heim- Netzwerk auch heute noch auf SMB V1... Man kann zwar problemlos ohne V1 auf die einzelnen PC zugreifen aber sie werden meist nicht gefunden, wenn man die Netzwerkumgebung öffnet.
    So lange man ein rein privates Netzwerk betreibt und die Firewall im Router vernünftig konfiguriert hat (ist tausendmal wirkungsvoller als alles, was man auf dem PC als Software- Lösung einrichten könnte), kann man SMB V1 aber ruhig aktivieren... Bei einem geteilten Internet Zugang für mehrere Haushalte oder z.B in einer Zweck- WG (ala Studentenbude oder so was), würde ich mir eine extra Hardware- Firewall (z.B. auf einem Raspberry Pi) einzurichten, damit die Mitbewohner/Mitbenutzer nicht auf mein Netzwerk zugreifen können... Das hat dann denselben Effekt wie die eingerichtete Firewall im Router...
    SMb V1 aktiviert man in der "alten" Systemsteuerung unter "Programme und Features" und dann "Windows Komponenten aktivieren oder deaktivieren"...
    Zwischenablage-10.jpg


    Es nennt sich "Unterstützung für die SMB 1.0/CIFS-Dateifreigabe"

    Solltest du Kodi ebenfalls auf einem Windows PC laufen haben, müsste dort natürlich ebenfalls das SMB V1 aktiviert werden, falls es die Ursache für das Problem ist..
     

    BlueMax1916

    Super User
  • Team MediaPortal
  • Super User
  • January 29, 2007
    700
    124
    Germany Germany
    Country flag
    Hallo,

    SMB V1 braucht's normalerweise nicht aber Du kannst mal checken ob folgende Dienste aus folgendem Posting laufen und auch so eingestellt sind:



    Ich habe da ziemlich lange dran rumgepfriemelt bis die Windows 10 Netzwerkerkennung einigermaßen brauchbar war. SMB V1 ist halt total unsicher.

    Gruß

    Blue Max
     

    AndreasK

    Portal Member
    February 23, 2010
    47
    0
    Germany Germany
    Country flag
    @Lehmden + @BlueMax1916
    Danke für Eure Hilfe.

    Der Shares-Bereich im Kodi Plugin sieht bei mir auch so aus. Also die Links zu den Shares sind grün.
    Über netstat -an wird er Port 9596 aber nicht gezeigt. Das würde bedeutet, dass das Plugin nicht wirklich läuft und den Port belegt.
    Auch nach nochmaligen stoppen und starten des Dienstes "MediaPortal 2 Server Service" hat nicht verändert.
    Jetzt stellt sich natürlich die Frage, ob ich für einen Mediaportal 2.2.3 Stand alone Server die richtige Plugin Version verwende. Da der Server ja eigentlich auf Mediaportal 1 basiert. Oder verstehe ich da etwas falsch. Der Server hat ja die Version 1.21.100.0.
     

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,105
    3,689
    Lehmden
    Germany Germany
    Country flag
    Hi.
    Dann ist alles klar... Du musst auf jeden Fall die zu MP2 (in deinem Fall MP 2.2.3) passende Version des Plugins verwenden. Die Versionsnummern- Anzeige im Setup Programm hat nichts zu bedeuten. Die ist ein Überbleibsel von MP1 und für MP2 völlig bedeutungslos. Denn der "TV- Server" ist bei MP2 kein eigenständiger Server sondern nur ein Plugin für den MP2 Server. Das MP1 Plugin funktioniert nicht mit MP2 und umgekehrt...
     

    AndreasK

    Portal Member
    February 23, 2010
    47
    0
    Germany Germany
    Country flag
    Dann ist alles klar... Du musst auf jeden Fall die zu MP2 (in deinem Fall MP 2.2.3) passende Version des Plugins verwenden.
    Leider nicht für mich. Ich nutze aktuell dieses Plugin Version Kodi TV Plugin for various MP2 versions... vom 12.04.. Ist das die letzte funktionierende Version für 2.2.3?

    Da aber der Port nicht belegt wird und somit das Plugin scheinbar nicht funktioniert, habe ich nur nach dem Thema Server und seiner Version gefragt
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    S Programmierte Aufnahme in MP2 - kein Aufwachen des PC Allgemeines Support- und Diskussionsforum 5
    M.Hulot Interner Blu-ray-Player spielt nach Update auf 1.25 keine Discs mehr ab Allgemeines Supportforum 2
    R [solved] Kein Player registriert Allgemeines Support- und Diskussionsforum 1
    S myemulators kein download mehr Plugins & Erweiterungen 0
    E Kein Signal vom Satelliten Installationsprobleme? 3
    R kein Ton bei TV, Video, Aufnahme, Musik Allgemeines Support- und Diskussionsforum 0
    J Kein Rtl, Sat 1 Pro 7 ... mehr TV / Streaming 0
    k12158 [solved] Kein direkter Wechsel von TV-Kanal zu TV-Kanal mehr nach Update? Allgemeines Support- und Diskussionsforum 16
    k12158 [solved] Keine Zugriff auf NAS Ordner mit Recordings und TimeShift Allgemeines Support- und Diskussionsforum 6
    L TV-Series kein Import Plugins & Erweiterungen 6
    W Keine SD Sender mehr wie Pro 7, SAT 1 RTL Allgemeines Support- und Diskussionsforum 4
    M Online Video Plugin V.2.32 keine Installtion unter MediaPortal 1.22 ? TV / Streaming 3
    W Kein IPTV mehr Allgemeines Support- und Diskussionsforum 0
    W (Noch) kein TV-Anbieter verfügbar Allgemeines Support- und Diskussionsforum 3
    Scheibes Mediaportal 2.2 kein H265 Unterstützung? Allgemeines Support- und Diskussionsforum 8
    L Mediaportal 2 - Digital Devices Max M4 - kein Signal bzw. Cards busy Allgemeines Support- und Diskussionsforum 2
    L WinTV HVR 5500 HD mit Win TV V8.5 software findet keine Kanäle 3rd Party Software 0
    A Keine Aufnahmen nach Standby Allgemeines Supportforum 12
    Cahliban Keine vorschaubilder und dateinformationen Allgemeines Supportforum 1
    S [solved] Webradio, kein Sender kann aufgerufen werden Allgemeines Support- und Diskussionsforum 2
    H [solved] Dialogbox in Titanium Extended hat keine Zeilenmarkierung Allgemeines Support- und Diskussionsforum 9
    S Kein EPG kein TV-Programm Allgemeines Support- und Diskussionsforum 10
    H MP2.2 Netflix kein Player registriert OnlineVideos for MediaPortal 2 11
    II-IRON [solved] MP2 - 2.2 - Es ist kein Player für die Wiedergabe des Medien-Object 'stream 3.0' registriert Allgemeines Support- und Diskussionsforum 16
    D Keine Client-Ansteuerung mehr möglich nach Windows10-Updated Allgemeines Support- und Diskussionsforum 7
    Similar threads

























    Top Bottom