Codecs Lav filters now support DXVA2 (1 Viewer)

Caesium

MP Donator
  • Premium Supporter
  • September 8, 2011
    75
    6
    41
    Solihull
    United Kingdom United Kingdom
    Hey, I have a GT430 too so I replicated your tests. This is only using a £10 Maplin power meter so to be honest I'd take this +/- 5% :)

    Using LAV 0.47.

    Idle system, MP running but TV off, so MP in low fps mode: 55W
    TV turned on, MP starts rendering GUI: 68W

    CUVID, BBC2 SD (so 576i25?): 69W (perfect)
    CUVID, BBC1 HD (1080i25?): 74W (perfect)
    DXVA2 Native, 576i25: 70W (perfect, maybe my eyes aren't so good but I didn't notice any deinterlacing difference)
    DXVA2 Native, 1080i: 68W (perfect again, fluid picture)

    I also tried the P8 mode of Nvidia Inspector, with the following results:
    CUVID, 576i25: 62W (perfect)
    CUVID, 1080i25: 65W (many noticeable frame drops, not really what I'd call a good TV experience)
    DXVA2 Native, 576i25: 62W (perfect)
    DXVA2 Native, 1080i: 67W (perfect image, but the GPU clearly didn't have room to spare, my MP GUI was very sluggish)

    So P8 saves me some power but it can't cope on the HD channels. DXVA doesn't seem to save me any power on HD channels, and barely any on SD. I wouldn't read too much into the CUVID SD power being higher than the HD, it's probably just the meter.
     

    Spooky

    MP Donator
  • Premium Supporter
  • February 14, 2005
    1,187
    47
    void 4tl
    Austria Austria
    So P8 saves me some power but it can't cope on the HD channels. DXVA doesn't seem to save me any power on HD channels, and barely any on SD.
    Your numbers indicate that you save quite a bit of power, however they are inconsistent, since the DXVA SD measurements were 62W on the first run and 70W on the second.
     

    DragonQ

    Portal Pro
    August 30, 2011
    644
    79
    United Kingdom United Kingdom
    Country flag
    Hmm so with the same GPU, decoder and channels, DXVA2 works for you? That's annoying, I wonder why it's broken for me. :(

    Are you using EVR as your renderer? If not, DXVA2 mode won't work and it'll fall back to CPU decoding. Also, was this DVB-S2 (Freesat) or DVB-T2 (Freeview)?
     

    Caesium

    MP Donator
  • Premium Supporter
  • September 8, 2011
    75
    6
    41
    Solihull
    United Kingdom United Kingdom
    DragonQ, those figures were on DVB-T2. I use EVR - it's Win7 Pro x64.

    I can try a run with software render and compare power usage but I think it'll be quite a lot higher, confirming that DXVA is working.. last time I tried any software decoding on HD the power usage was 100W+.

    This is my GT430 if it makes any difference:
    http://www.component-warehouse.co.u...mb-ddr3-hdcp-dvi-hdmi-pci-e-dx11-passive.html


    Spooky, the second run was under forced P8 which is why the second numbers are generally lower.
     

    DragonQ

    Portal Pro
    August 30, 2011
    644
    79
    United Kingdom United Kingdom
    Country flag
    I see. I was using DVB-S2 but I can't see how it'd make a difference. Aside from the audio they should use the same encoding. I have a passive GT 430 too, as it happens.

    :(
     

    Caesium

    MP Donator
  • Premium Supporter
  • September 8, 2011
    75
    6
    41
    Solihull
    United Kingdom United Kingdom
    I suppose it might, aren't the bitrates different, especially for HD, on DVB-S2? Also did you use BBC1 HD or another one?
     

    Caesium

    MP Donator
  • Premium Supporter
  • September 8, 2011
    75
    6
    41
    Solihull
    United Kingdom United Kingdom
    Ok, I went back and retested this to confirm my findings. I tried software decoding and it does indeed use about 100W. However, I left DXVA playing for a bit longer this time and did observe some picture freezes on BBC1 HD, I guess I just didn't leave it long enough last night to see any.

    I ran the Nvidia Inspector graphing tool as well:
    http://telon.net/x/gt430_dxva_cuvid.png

    DVXA is a bit all over the shop, whereas CUVID is a much steadier line. CUVID also seems to use a bit more GPU power but less VPU power. The VPU line looks odd though, like it's some sort of rolling average over time, not a spot value.
     

    DragonQ

    Portal Pro
    August 30, 2011
    644
    79
    United Kingdom United Kingdom
    Country flag
    Aha, I think I found the problem. I only had RGB32 output ticked in the LAV Video Configuration window. If I leave all outputs ticked, I get smooth playback on ITV1 HD and Channel 4 HD but, like you, BBC One HD and BBC HD are troublesome. Sometimes it'll run fine for a minute or so, then it'll go crazy. Perhaps it's to do with the MBAFF encoding they use (AFAIK the other HD channels don't use this)?

    In any case, deinterlacing is definitely not as good with DXVA2. :(

    I have recorded a video of what happens on my phone, might get a chance to upload it later.
     

    Paranoid Delusion

    Moderation Manager
  • Premium Supporter
  • June 13, 2005
    13,062
    2,978
    Cheshire
    United Kingdom United Kingdom
    In any case, deinterlacing is definitely not as good with DXVA2. :(
    Nevcairiel has said this many many times, that Cuda's implementation using nvidia purevideo deinterlacing is far superior to dxva, btw LAV 0.48 is out as a interim bug fix :D
     

    Spooky

    MP Donator
  • Premium Supporter
  • February 14, 2005
    1,187
    47
    void 4tl
    Austria Austria
    Spooky, the second run was under forced P8 which is why the second numbers are generally lower.
    That makes no difference for DXVA. When using the video acceleration component of the video card (via DXVA for example), the GPU will only be in a power saving state, typically somewhere between full performance and its lowest power state (P8 for instance for NVidia cards), and not in its full performance state.

    Quote from nev on the subject:
    nevcairiel said:
    There is typically 3 states with NVIDIA cards that are used. P0 is the full 3D power mode, P8 is the "Video" mode at around half speed, and P12 is the 2D low-power mode (which seems to actually be even lower then your low state, just going by clocks).
    DXVA uses the P8 mode, unless the 3D load from post-processing is too high and forces P0. But CUDA always forces the P0 mode, unless you use a tool like NVIDIA Inspector to change the modes per-application or by some other rules.

    Recently, NVIDIA changed the way the P-state switching is done. However, in the upcoming 285 driver release, they went back to a more "conservative" P-state logic, because it apparently caused quite some issues.
    Using my DXVA-HD deinterlacer, it usually starts out in P0 mode, but if i let it run for a while, after 30s or so it goes into P8 (which can be seen in my debug timings, as the values double. :)
    http://forum.doom9.org/showthread.php?p=1525734#post1525734



    Nevcairiel has said this many many times, that Cuda's implementation using nvidia purevideo deinterlacing is far superior to dxva, btw LAV 0.48 is out as a interim bug fix :D
    If he is using deinterlacing only through the PureVideo component of the GPU via CUVID, deinterlacing should be the same as with DXVA, in theory.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    T MadVR + LAV Filters, Perfect in MPC-BE, Bad in MP1 MediaPortal 1 Talk 12
    rsbrux 1.23.0 MPE Manager Problem with LAV Filters Bugreports 2
    cbr954rr Videos flickering with lav Filter General 2
    A Audio sync problems on LAV filters 1.21 Pre Release 31
    D [Rejected] LAV filter setup wizard Feature Requests 1
    Sebastiii [WiP] Audio delay when using LAV Audio codec Area 51 - Testing Area 6
    A AAC 2.0 going out of sync Codecs, External Players 2
    A RTL2832U (REALTEK DTV Filter) re-appears with new card ID in TV server after something? General Support 3
    azzuro [fixed] [MP2-813] Album artist filter wrong display Submit: Bug Reports 75
    HTPCSourcer [fixed] [MP2-794] Genre filtering always displays English strings MediaPortal 2 9
    HTPCSourcer [Rejected] Replace "Filter by" by "Group by" MediaPortal 2 14
    N Option to "Filter" Images by folder name Feature Requests 8
    N [Rejected] Rename "Filter" to "Group by" Feature Requests 3
    S [solved] Library view and filters General 5
    B [MP2-745] Allow direct navigation to specified media item/filter Archive 7
    SpudR Custom filter for partially watched movies Moving Pictures 5
    TheBatfink IPTV Core Filter / No User Agent sent Television (MyTV frontend and TV-Server) 1
    C Is it possible to search or filter non-movie videos in Videos plug-in? General Support 4
    CyberSimian Support for control.isvisible() in expressions MediaPortal 1 8
    morpheus_xx [WiP] OnlineVideos: New browser based playback support using WebDriver, new Amazon siteutil MediaPortal 2 6
    M 2nd (Touch-)Display Support on MediaPortal 2 such MPDisplay++? General 2
    J Support waipu TV TV-Server 0
    doskabouter WebDAV support OnlineVideos 0
    K Multichannel audio and subtitles for TV not properly supported General Support 4
    CyberSimian Support pack for Ortek VRC-1100 and Hama 00052451 Remotes 6
    Similar threads

























    Top Bottom