MCE remote doesn't work properly in Windows 7? (1 Viewer)

floepie

Portal Pro
November 5, 2007
58
5
Home Country
United States of America United States of America
I've used MP on my previous Vista install flawlessly in conjunction with MPtraymod. However, in Windows 7, despite the ability for the MCE remote to control Windows 7 MC without a problem, the MCE remote control has problems in the video section of MP. It will not pause, rewind, go back, or bring up the subtitles dialog (right mouse click menu) while a video is playing. I can, however, scroll through the main MP modules menu with the MCE remote. Is there anything I can try? Thanks...
 

Melloware

Portal Pro
October 26, 2007
83
1
Home Country
United States of America United States of America
I have had many of my Intelliremote users report the same thing with Windows 7. Apparently Microsoft changed the driver and the signals being sent from Windows 7 are a lot longer than the codes for XP and Vista. So my guess is the MPTrayMod is looking for just the Vista and XP style codes and not the new Windows 7 codes.
 

FantaXP7

Portal Pro
February 3, 2009
204
1
floepie, so we meet again,

Check out this thread https://forum.team-mediaportal.com/newcomers-forum-240/mce-remote-issues-windows-7-a-55421/

Seems like we are having some similar problems. Someone got it working by changing the "localhost" to whatever your PC's name is withing IR Server Suite...So I went into IR Server Suites in my start menu, clicked on virtual remote option, selected a button and right clicked to change the host name. This is what I understood of what the instructions told. This worked for me, however when I opened Media Center 7 it went right back to the way it was before...Atleast it is some progress, but I need it to work for both applications as my tv tuner won't work under mediaportal.

EDIT: Also in MP config, under plugins, there is MP Blast Zone which I believe was installed when I installed IR Server Suite, you can change the host there.
 

floepie

Portal Pro
November 5, 2007
58
5
Home Country
United States of America United States of America
Yeah, thanks - saw that thread and installed the IR server. If you want to use both 7MC and MP, maybe someone could write a script that could stop and start the IR server service. At least, someone posted that this works, short of rebooting of course. That script or run command could be executed in a batch file followed by execution of MP. I'm no expert in writing batch commands, but I would imagine it could be relatively simple. That way, all you would have to do to start MP is start the batch file. Just a thought...
 

peely

Portal Member
November 25, 2007
34
0
Olney, UK
Home Country
United Kingdom United Kingdom
If you're running IR Server Suite then the Translator app can perform tasks on PC Resume. I use this to run a macro to "net stop inputservice" then "net start inputservice". You need to diable UAC in Windows 7 to allow the app to stop and start services.
 

Users who are viewing this thread

Similar threads

It is looking and working very well now and I am almost at the point of switching my HTPC to MP2, madvr would definitely push me over the edge for sure.;)
It is looking and working very well now and I am almost at the point of switching my HTPC to MP2, madvr would definitely push me...
We are proud to present MediaPortal 2.3 MediaPortal 2.3 is a full-blown media center software that addresses the most common user...
Replies
4
Views
2K
We are proud to present MediaPortal 2.3.1 MediaPortal 2.3.1 is a full-blown media center software that addresses the most common user requirements out of the box. Aside from its support for Live TV and Radio, it offers a complete media server for music, movies, and TV shows. Info is automatically downloaded from various sources to...
We are proud to present MediaPortal 2.3.1 MediaPortal 2.3.1 is a full-blown media center software that addresses the most common...
We are proud to present MediaPortal 2.3.1 MediaPortal 2.3.1 is a full-blown media center software that addresses the most common...
Replies
0
Views
977
Yes, your Centarea HID.xml but without AutoHotkey running (non-admin account). Then everything works fine, thank goodness.:D
Yes, your Centarea HID.xml but without AutoHotkey running (non-admin account). Then everything works fine, thank goodness.:D
Hi Folks, I've been using MP 1.20 for some time now, all was working well, except for dynamic refresh rate control would sometimes...
Replies
74
Views
7K
@CyberSimian I verified that the directories actually are present (I did not reaize at first that in explorer the name of paths is localized but in the CMD window it isn't). I removed the link in order to perform the test and ... it worked: install.bat copies the file in the right place and uninstall removes it. I do not know what...
@CyberSimian I verified that the directories actually are present (I did not reaize at first that in explorer the name of paths...
I've been using the Ortek MCE remote for years now. It's fine, but it's missing a lot. I can do the basics - start a video...
Replies
13
Views
2K
Thanks for this new release of MP. The link on the presentation page of the new version is incorrect. It goes on the MP 1.24 thread.
Thanks for this new release of MP. The link on the presentation page of the new version is incorrect. It goes on the MP 1.24 thread.
We have just released MediaPortal 1.25 Final - Summer 2020 Edition Highlights of this release Bugfixes: [MP1-4966] - Update...
Replies
1
Views
3K
Top Bottom