[solved] - Media Portal only working in single seat - network card only allows to select 127.0.0.1 / localhost

Discussion in 'General' started by ITSPecialist, July 11, 2017.

  1. ITSPecialist

    ITSPecialist New Member

    Joined:
    July 11, 2017
    Messages:
    2
    Likes Received:
    2
    Gender:
    Male
    Ratings:
    +2 / 0
    Home Country:
    Germany Germany
    Hi all...
    I'm new to mediaportal and need a little help.
    After my old ARGUS TV solution is not supported any more I decided to switch to media portal. I will mainly use it to record some shows and bring Live TV to some of my mobile devices (notebooks). I decided to install MePo 2, and started with a single seat installation (for testing, as the server machine is located in my cellar), later on I tried to install the MePo 2 client on one of my notebooks.

    When using server (Win 7 Pro 64 bit, 6GB RAM, Intel Core2 Quad CPU Q9550 @ 2.83GHz) and client on the same machine, all is working well - but then I installed a MePo 2 client on one of my notebooks and had to find out that the (MePo 2 )server is not available to other clients in the network. All other features (fileshare, syslog.. ) are working well an can be reached from any system in the network.

    I'm pretty sure it has to do with the fact that the netowrk card (integrated, Intel(R) 82566DM-2 Gigabit Network Connection) is not recognized properly by MePo. I did another installation inside a virtual machine and there I was able to select the right IP in the streming server settings.

    In the "MediaPortal 2 TV Configuration" I only have the option to use "auto" or "127.0.0.1" as the IP address used by the server for RTSP streaming.



    The server is assigned a reserved IP adress via DHCP.
    Please let me know what kind of logs I could / should provide to give you guys the chance to help me.

    All the best from Germany
    Michael
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. Timberwolf99

    Timberwolf99 Portal Pro

    Joined:
    November 20, 2015
    Messages:
    172
    Likes Received:
    25
    Gender:
    Male
    Ratings:
    +61 / 1
    Home Country:
    Australia Australia
    Show System Specs
    Can you ping the server from the computer?
     
  4. HTPCSourcer
    • Team MediaPortal
    • Administrator

    HTPCSourcer MP2 Product Manager

    Joined:
    May 16, 2008
    Messages:
    10,498
    Likes Received:
    1,105
    Gender:
    Male
    Ratings:
    +2,370 / 21
    Home Country:
    Germany Germany
    Show System Specs
    Any uncertainty can easily be eliminated by looking into the logs.;) Please see Bug reports and log files for an explanation how to create them.
     
  5. ITSPecialist

    ITSPecialist New Member

    Joined:
    July 11, 2017
    Messages:
    2
    Likes Received:
    2
    Gender:
    Male
    Ratings:
    +2 / 0
    Home Country:
    Germany Germany
    Hey guys,
    I just found the problem and think it coul be helpful for others to share the solution:

    The sytem running the MePo 2 Server is reachable from all other systems in my network, but as told above in the "MediaPortal 2 TV Configuration" I only have the option to use "auto" or "127.0.0.1" as the IP address used by the server for RTSP streaming. So I tried different things and finally found out that the hostname of the server doesn't get resolved to the IP correctly - but onyl on the machine itself. All other systems resolved the hostname to the correct ip-address. This made me looking at the hosts file on my server where I found a line like this:
    127.0.0.1 *hostnameofmyserver* # LMS GENERATED LINE

    I deleted this line and did a reboot of the server. After that the MedPo server still was not visible to other clients. Looking at the hosts file agian I had to see that the line was back again. I then google the "LMS GENERATED LINE" and found out that this line is generated by the "Intel Active Management Technology (AMT)". I disabled AMT in the BIOS, unistalled the software and removed the corresponding entry from the hosts file again - and from now on the MePo 2 Server works as expected and is also visible to all my systems in the network.

    Hopefully this information is helpful for some other users!
     
    • Like Like x 2
  6. rcauvin

    rcauvin Portal Member

    Joined:
    May 6, 2017
    Messages:
    11
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +0 / 0
    Home Country:
    United States of America United States of America
    Which client are you using to access RTSP streaming, and what connection URL are you using?
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!