MediaPortal 1.16 server crashing due to user error? (1 Viewer)

Frustrated

Portal Member
June 15, 2014
30
2
63
Canada Canada
Country flag
Was using MediaPortal 1.16 approximately 3 years ago on an old C2Duo E6850 w Win7 Enterprise and 4GB RAM. I stopped using MediaPortal and pulled the computer out of use. I did use the computer 2 years ago to test some other software which remained installed on the system.

I wanted to return to using MediaPortal the other day so I fired up the machine and noticed this other software installed and decided to uninstall this software which I did. However stupid me also noticed there were 2 installations of MySQL and since the uninstalled software was accounting software thought the MySQL was connected to the accounting software and uninstalled the MySQL .

Tuner card is an ancient Hauppauge 1600. I tried firing up MediaPortal only to discover the software hung at Starting Plugins. Searching through the forum found a post where someone stopped Power Scheduler in MediaPortal client and server and the client started up. So I disabled it in the client. However when I tried starting up the server it simply crashed. I tried reinstalling 1.16 from the downloaded file but that failed when it tried to do the server. This was when I discovered that the MySQL that I uninstalled was apparently for MediaPortal. I downloaded the Community Build of MySQL of 5.6.49 and installed that and managed to update the databases using the default password of MediaPortal.

However, the client still hangs with PowerScheduler enabled and the server is still crashing. With the server, I noticed that TV Service which is running is attempting to stop and simply hangs. Is there a way of salvaging this install or do I have to do a clean install? If a clean install is there a way of at least backing up the configuration files that are from 3 years ago?
 

Attachments

Frustrated

Portal Member
June 15, 2014
30
2
63
Canada Canada
Country flag
Thanks for the second link. That second link says to set the IP address stored in that Server table to a null value and simply save the table that way. Does that mean that the software updates the IP address the next time it is run?

Can one use the computer name rather than an IP address for the server so that if IP changes there is none of this issue again?
 

Frustrated

Portal Member
June 15, 2014
30
2
63
Canada Canada
Country flag
It seems that one can use the computer name in the Hostname field in the Server table for MediaPortal. I updated the record in my DB and the Server Configuration app loads fine now irrespective of the IP address of the machine. Thanks again for the links that helped alot
 

azzuro

Test Group
  • Team MediaPortal
  • May 10, 2007
    9,620
    5,243
    France - IDF
    France France
    Country flag
    Can one use the computer name rather than an IP address for the server so that if IP changes there is none of this issue again?
    best to use ip, i use this myself, for don't have issue on name change. i use fixed IP set in DHCP for each MAC address, except mobile phone ...
     

    Frustrated

    Portal Member
    June 15, 2014
    30
    2
    63
    Canada Canada
    Country flag
    best to use ip, i use this myself, for don't have issue on name change. i use fixed IP set in DHCP for each MAC address, except mobile phone ...
    What exactly does setting the IP address to a blank in the Server table do? Is the IP address no longer stored in the Server table so it accommodates IP address changes? The reason I am asking is that I have two subnets here. The subnet1 network is where this box will normally reside and the other, subnet2 network is where the other computers are located and is where the box is currently for maintenance and testing. Hence the issue with the IP address changes. I use fixed IPs also assigned by the MAC address for most of the devices on the subnet2 network, while subnet1 is strictly DHCP and leases.
     

    Users who are viewing this thread

    Similar threads
    OP Title Forum Replies Date
    R [solved] MediaPortal: TV Server und HD Sender Installationsprobleme? 2
    J MediaPortal TV Server and Kodi media source issues General 9
    M VMWare Workstation Installation stört Mediaportal TV Server Allgemeines Support- und Diskussionsforum 5
    M VPN: Mediaportal TV-Server ist not using all available bandwidth which results in TV stuttering Newcomers Forum 0
    J Clock speed vs multi-core CPU's Can MediaPortal benefit from multi core cpu's? General 0
    P Mediaportal 2 client can't find TV server General 3
    T Neuer MediaPortal Rechner Barebones/PC-Systeme/Kaufberatung 2
    morpheus_xx [News] MediaPortal 2.3 Release News and Announcements 4
    G Anyone else having issues with MC2XML? (not a Mediaportal issue) General Support 3
    A MediaPortal crash (and restart) on LiveTV after Windows Update (Sep 2020) driver update for Intel HD Graphics 4600 General Support 10
    A VideoDatabaseV5.db3 lock not released on shutting down PC from MediaPortal Installation, configuration support 0
    ajs [News] MediaPortal 1.26 Pre-Release ready for testing! News and Announcements 0
    M Add Radio channels and EPG to Mediaportal xmlTV 3
    Symphy Version 0.2.9.0 for MediaPortal 1.25 ASIO music player 0
    doskabouter Installing mediaportal MediaPortal 1 3
    A Mediaportal Allgemeines Support- und Diskussionsforum 0
    G Update von MediaPortal Installationsprobleme? 0
    ajs [News] MediaPortal 1 - 1.25 Released! News and Announcements 1
    horned_reaper Standby is prevented by MediaPortal client General Support 0
    U [solved] MediaPortal crashing on startup General Support 10
    g0rsq Info box randomly popping up when watching TV or other video MediaPortal 2 Newcomers Forum 1
    high [unanswered] Hallo möchte gerne Mediaportal. nutzen kann mich jemand anrufen? contactform feedback and requests 2
    ajs [News] MediaPortal 1.25 Pre-Release ready for testing! News and Announcements 0
    ajs [Rejected] Mediaportal Codename MediaPortal 1 48
    M 2nd (Touch-)Display Support on MediaPortal 2 such MPDisplay++? General 2

    Similar threads

    Top Bottom