[solved] Mediaportal Configuration Crashes (1 Viewer)

bradl822

Portal Member
January 17, 2013
17
10
30
Brisbane, Queensland, Australia
Home Country
Australia Australia
Hi,

I get a Microsoft.Net error when launching config. This prevents me from making any changes in config at all.

See attached logs.

Capture.JPG

Pressing details I get the following info.
Code:
See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.NullReferenceException: Object reference not set to an instance of an object.
   at MediaPortal.InputDevices.irremote.GetHCWPath()
   at MediaPortal.Configuration.Sections.Remote.LoadSettings()
   at MediaPortal.Configuration.SettingsForm.LoadSectionSettings(TreeNode currentNode)
   at MediaPortal.Configuration.SettingsForm.SettingsForm_Load(Object sender, EventArgs e)
   at System.Windows.Forms.Form.OnLoad(EventArgs e)
   at System.Windows.Forms.Form.OnCreateControl()
   at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
   at System.Windows.Forms.Control.CreateControl()
   at System.Windows.Forms.Control.WmShowWindow(Message& m)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
   at System.Windows.Forms.Form.WmShowWindow(Message& m)
   at System.Windows.Forms.Form.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1080.0 built by: NETFXREL3STAGE
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
----------------------------------------
Configuration
    Assembly Version: 1.15.0.0
    Win32 Version: 1.15.0.0
    CodeBase: file:///C:/Program%20Files%20(x86)/Team%20MediaPortal/MediaPortal/Configuration.exe
----------------------------------------
System.Windows.Forms
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1038.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1081.0 built by: NETFXREL3STAGE
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1078.0 built by: NETFXREL3STAGE
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
Core
    Assembly Version: 1.15.0.0
    Win32 Version: 1.15.0.0
    CodeBase: file:///C:/Program%20Files%20(x86)/Team%20MediaPortal/MediaPortal/Core.DLL
----------------------------------------
Utils
    Assembly Version: 1.15.0.0
    Win32 Version: 1.15.0.0
    CodeBase: file:///C:/Program%20Files%20(x86)/Team%20MediaPortal/MediaPortal/Utils.DLL
----------------------------------------
Common.Utils
    Assembly Version: 1.15.0.0
    Win32 Version: 1.15.0.0
    CodeBase: file:///C:/Program%20Files%20(x86)/Team%20MediaPortal/MediaPortal/Common.Utils.DLL
----------------------------------------
System.Xml
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1064.2 built by: NETFXREL3STAGE
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
log4net
    Assembly Version: 1.2.11.0
    Win32 Version: 1.2.11.0
    CodeBase: file:///C:/Program%20Files%20(x86)/Team%20MediaPortal/MediaPortal/log4net.DLL
----------------------------------------
System.Core
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1038.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------
System.Configuration
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1038.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
BassRegistration
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Program%20Files%20(x86)/Team%20MediaPortal/MediaPortal/BassRegistration.DLL
----------------------------------------
Accessibility
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1038.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/Accessibility/v4.0_4.0.0.0__b03f5f7f11d50a3a/Accessibility.dll
----------------------------------------
Microsoft.GeneratedCode
    Assembly Version: 1.0.0.0
    Win32 Version: 4.6.1064.2 built by: NETFXREL3STAGE
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
Microsoft.DirectX.Direct3D
    Assembly Version: 1.0.2902.0
    Win32 Version: 9.05.132.0000
    CodeBase: file:///C:/WINDOWS/assembly/GAC/Microsoft.DirectX.Direct3D/1.0.2902.0__31bf3856ad364e35/Microsoft.DirectX.Direct3D.dll
----------------------------------------
Microsoft.DirectX
    Assembly Version: 1.0.2902.0
    Win32 Version: 5.04.00.2904
    CodeBase: file:///C:/WINDOWS/assembly/GAC/Microsoft.DirectX/1.0.2902.0__31bf3856ad364e35/Microsoft.DirectX.dll
----------------------------------------
Bass.Net
    Assembly Version: 2.4.10.3
    Win32 Version: 2.4.10.3
    CodeBase: file:///C:/Program%20Files%20(x86)/Team%20MediaPortal/MediaPortal/Bass.Net.DLL
----------------------------------------
Databases
    Assembly Version: 1.15.0.0
    Win32 Version: 1.15.0.0
    CodeBase: file:///C:/Program%20Files%20(x86)/Team%20MediaPortal/MediaPortal/Databases.DLL
----------------------------------------
System.Data
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1038.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_32/System.Data/v4.0_4.0.0.0__b77a5c561934e089/System.Data.dll
----------------------------------------
DirectShowLib
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.0.0
    CodeBase: file:///C:/Program%20Files%20(x86)/Team%20MediaPortal/MediaPortal/DirectShowLib.DLL
----------------------------------------
System.Numerics
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1038.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Numerics/v4.0_4.0.0.0__b77a5c561934e089/System.Numerics.dll
----------------------------------------
Microsoft.GeneratedCode
    Assembly Version: 1.0.0.0
    Win32 Version: 4.6.1064.2 built by: NETFXREL3STAGE
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.Runtime.Serialization.Formatters.Soap
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1038.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Serialization.Formatters.Soap/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Runtime.Serialization.Formatters.Soap.dll
----------------------------------------
RemotePlugins
    Assembly Version: 1.15.0.0
    Win32 Version: 1.15.0.0
    CodeBase: file:///C:/Program%20Files%20(x86)/Team%20MediaPortal/MediaPortal/RemotePlugins.DLL
----------------------------------------
Interop.X10
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Program%20Files%20(x86)/Team%20MediaPortal/MediaPortal/Interop.X10.DLL
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.
 
Last edited:

mm1352000

Development Group
  • Team MediaPortal
  • September 1, 2008
    21,577
    8,223
    Home Country
    New Zealand New Zealand
    Country flag
    Hello and thanks for the report

    Some questions...
    Have you ever installed or used a Hauppauge remote control? (I ask because that's what the error seems to relate to.)
    Are you running config with administrative privileges?
    Are you able to provide a screenshot of the contents of registry key "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Hauppauge WinTV Infrared Remote"? (If you have no idea what I'm talking about here, just say so. ;) )
     

    bradl822

    Portal Member
    January 17, 2013
    17
    10
    30
    Brisbane, Queensland, Australia
    Home Country
    Australia Australia
    Hey, thanks for the swift response.

    I previously had a Hauppauge Remote control and tv card installed, I have since removed both and have uninstalled the software.
    Yes running as admin.

    I believe this is what you meant o_O

    Capture.JPG
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,577
    8,223
    Home Country
    New Zealand New Zealand
    Country flag
    No problem. :)

    Okay, so I reckon the removing of the remote control software is what has caused this. It doesn't seem to have been removed cleanly.

    I believe this is what you meant o_O
    Mmmm, maybe... but due to the way you cropped the screenshot, I'm not sure if you're looking at the right key.

    I have the Hauppauge remote software installed, and my registry (Windows XP) shows:
    upload_2016-7-9_14-45-32.png
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,577
    8,223
    Home Country
    New Zealand New Zealand
    Country flag
    Okay, thanks.

    If you're sure that you've removed the remote control software then I would delete that key, and that should solve the problem.
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,577
    8,223
    Home Country
    New Zealand New Zealand
    Country flag
    Wonderful! :)
    I'm glad to have been able to help.
     

    Users who are viewing this thread

    Similar threads

    I ended up doing a clone disk recovery. I had just done a backup, and I figured I might as well test it -- it's been a while since I've gone through the recovery process. All good. :) I had the logs, but lost them in the recovery. Sorry. :( I believe the issue was that I had removed Windows Media Player from Windows Features. Still...
    I ended up doing a clone disk recovery. I had just done a backup, and I figured I might as well test it -- it's been a while since...
    So I tried upgrading from 1.27 to 1.28. I upgrade frequently without issues. I did a simple upgrade, so I did not delete my user...
    Replies
    2
    Views
    257
    I just copied over a backup and now it's working. It must have been some sort of corruption of important files. Thanks! Emph
    I just copied over a backup and now it's working. It must have been some sort of corruption of important files. Thanks! Emph
    I was using MediaPortal just last night with no issues at all, but since today, it doesn't autostart, if I try to run it or...
    Replies
    2
    Views
    297
    Oh ok Hope you will feel better soon (not only for MP ofc) good luck From Tapatalk
    Oh ok Hope you will feel better soon (not only for MP ofc) good luck From Tapatalk
    System.NullReferenceException Error when opening or closing Mediaportal configuration AND 'Invalid File Handle 32' during...
    Replies
    7
    Views
    2K
    hi. I have similar problem. I managed to scan dvb-t and -s programs,but for some reason dvb-s freezes after several minutes of use and during this problem i can not use mp.same problem with dvb-t. in other hand,when i am using preview in mp tv settings and when i am usin hauppauge software for live tv,there is no problems at all. i...
    hi. I have similar problem. I managed to scan dvb-t and -s programs,but for some reason dvb-s freezes after several minutes of use...
    Hi. I recently reinstalled my BlackGold TV card, but the DVBS scan returns only no signal? The DVBT scan works fine. I tried to...
    Replies
    3
    Views
    5K
    Sorry for your trouble. I'm not able to help with the iMon stuff...
    Sorry for your trouble. I'm not able to help with the iMon stuff...
    Hmmm, unfortunately, another problem after my complete reinstall (incl. new Windows intallation): Since yesterday the config...
    Replies
    5
    Views
    1K
    Top Bottom