MediaPortal crashes after it has been closed (1 Viewer)

IchBinsShort

Portal Pro
January 3, 2008
683
54
Home Country
Germany Germany
When I close Mediaportal I get an error Message that MediaPortal must be terminated due to an error. I think the problem is the Mediaportal.xml because in the Log Files I can see a problem with the Mediaportal.xml file. But I don't know why this error occurs.
 

Vasilich

Portal Pro
August 30, 2009
3,394
1,170
Germany, Mayence
Home Country
Russian Federation Russian Federation
2013-01-02 14:13:06.066406 [ERROR][MPMain(1)]: Exception :confused:ystem.IO.IOException: Der Prozess kann nicht auf die Datei "C:\ProgramData\Team MediaPortal\MediaPortal\MediaPortal.xml" zugreifen, da sie von einem anderen Prozess verwendet wird.
hast Du schon in ProcessExplorer oder ProcessHacker angeschaut wer diesen Datei offen hält?
 

Vasilich

Portal Pro
August 30, 2009
3,394
1,170
Germany, Mayence
Home Country
Russian Federation Russian Federation
und was ist mit dem MusicInfoHandler?
2013-01-02 13:09:59.546875 [ERROR][MusicInfoHandler: Album(34)]: Exception :confused:ystem.Net.WebException: Der Remoteserver hat einen Fehler zurückgegeben: (500) Interner Serverfehler.
- der Log-Datei ist voll von Meldungen dieser Art.
 

IchBinsShort

Portal Pro
January 3, 2008
683
54
Home Country
Germany Germany
2013-01-02 14:13:06.066406 [ERROR][MPMain(1)]: Exception :confused:ystem.IO.IOException: Der Prozess kann nicht auf die Datei "C:\ProgramData\Team MediaPortal\MediaPortal\MediaPortal.xml" zugreifen, da sie von einem anderen Prozess verwendet wird.
hast Du schon in ProcessExplorer oder ProcessHacker angeschaut wer diesen Datei offen hält?

Okay Danke für den Tipp habe mir das Programm jetzt heruntergeladen aber wie kann ich mir dort anzeigen lassen welcher Process die Datei offen hält ? Geht das nicht nur mit "Dll" und "exe" Dateien ?
Das MusicInfoHandler Plugin werde ich mal deaktivieren.
 

IchBinsShort

Portal Pro
January 3, 2008
683
54
Home Country
Germany Germany
Ja genau aber vielleicht habe ich das Problem schon gefunden, es scheint MPExtendend zu schein welches dieses Problem verursacht, habe mal testweise den Service beendet und konnte schon zweimal Mediaportal beenden ohne das diese Fehlermeldung auftritt. Werde es mal weiter beobachten... Danke für die Hilfe
 

emphatic

Design Group
  • Team MediaPortal
  • August 25, 2006
    3,732
    1,193
    Alingsås
    Home Country
    Sweden Sweden
    This is the English forum, so please write in English as more people are likely to have this issue.

    @IchBinsShort, do you have MPExtended installed? Because I got this same issue when I installed MPExtended, and it went away as I uninstalled it. I think it keeps Mediaportal.xml open so that MediaPortal can't write to it when you close MePo.

    Emph
     

    IchBinsShort

    Portal Pro
    January 3, 2008
    683
    54
    Home Country
    Germany Germany
    This is the English forum, so please write in English as more people are likely to have this issue.

    @IchBinsShort, do you have MPExtended installed? Because I got this same issue when I installed MPExtended, and it went away as I uninstalled it. I think it keeps Mediaportal.xml open so that MediaPortal can't write to it when you close MePo.

    Emph

    Oh okay sorry. Yes I have MPExtended installed and when the Service is started I had the problem with crashing Mediaportal. When I stopped the service it works fine. I will post this bug in the MPExtended Subforum.
     

    Users who are viewing this thread

    Top Bottom