Mediaportal hangs when playing some files (1 Viewer)

ozn

Portal Member
June 4, 2008
19
0
Country flag
Good Morning,

My Mediaportal Crash when playing some avi files and I need to force close by Alt+F4 to recover control of the system. I'm getting that issue with some files download by internet.

On MyTVseries error log show next:

MP-Tvseries.log

2016-01-10 21:46:30.566 [INFO][01]: Re-enabling native autoplay.
2016-01-10 21:46:30.766 [INFO][01]: #TVSeries.Extended.Title: Sobrenatural/10/1/Negro
2016-01-10 21:46:33.946 [INFO][01]: TVSeriesPlugin.VideoHandler.Play()
System.NullReferenceException: Referencia a objeto no establecida como instancia de un objeto.
en MediaPortal.Player.VideoPlayerVMR7.AudioLanguage(Int32 iStream)
en MediaPortal.Player.VideoPlayerVMR7.SelectAudioLanguage()
en MediaPortal.Player.VideoPlayerVMR7.Play(String strFile)
en MediaPortal.Player.g_Player.Play(String strFile, MediaType type, TextReader chapters, Boolean fromPictures, Int32 title, Boolean forcePlay, Boolean fromExtTS)
en WindowPlugins.GUITVSeries.VideoHandler.Play(Int32 timeMovieStopped) en C:\Development\mptvseries\MP-TVSeries\VideoHandler.cs:línea 466
2016-01-10 21:46:34.066 [INFO][01]: Disabling native autoplay.

>> The Path showns on error "C:\Development\mptvseries\MP-TVSeries\VideoHandler.cs" don't exist on any of my system.

Thinking on a codec issue, I have try in a desktop computer and laptop computer where I have installed MP an scan that file but also getting same error. It happens in some other various avi files, but all seems to be fine if reproduce manually in any player.

Curiosly If I take that video file a reprocess by my own it play properly on mediaportal, I have passed avifix,etcc and mediainfo compare that 2 files and no any significant difference between them. Also If i played that problematically video file with windows Medipa Player, VLC or MPC-HC in mediaportal HTPC the file is properly played, but not with integrated player.

I have tryed to reproduce by vmr9 or evr but the issue is the same. I attached watchdog logs for further investigation. Can you please @RoChess take a look to that issue and even try that avi file on your system, I'm stuck on getting a solution for that issue.

I have upload to MEGA the file for investigation:

Error file >> https://mega.nz/#!vJkTDIxJ!IUH-K1QTGlD-kkXBz2iFDyfsVNzfavzI9on4u8jOstw
Fixed file (recompress by avirecomp) >> https://mega.nz/#!7BtG1CjJ!7GuAlp70_NNkfI5nyOuDF82M6F7JrUCmZVgl2yg2ciQ

have send a post before cause i think it was a problem with mytv series plugins series, but it seems an issue with MP player, cause the error is the same:

[2016-01-21 10:25:38,578] [Error ] [MPMain ] [ERROR] - OnMessage exception:confused:ystem.NullReferenceException: Referencia a objeto no establecida como instancia de un objeto.
en MediaPortal.Player.VideoPlayerVMR7.AudioLanguage(Int32 iStream)
en MediaPortal.Player.VideoPlayerVMR7.SelectAudioLanguage()
en MediaPortal.Player.VideoPlayerVMR7.Play(String strFile)
en MediaPortal.Player.g_Player.Play(String strFile, MediaType type, TextReader chapters, Boolean fromPictures, Int32 title, Boolean forcePlay, Boolean fromExtTS)
en MediaPortal.Playlists.PlayListPlayer.FakePlayer.MediaPortal.Playlists.PlayListPlayer.IPlayer.Play(String strFile, MediaType type)
en MediaPortal.Playlists.PlayListPlayer.Play(Int32 iSong, Boolean setFullScreenVideo)
en MediaPortal.Playlists.PlayListPlayer.PlayNext(Boolean setFullScreenVideo)
en MediaPortal.GUI.Video.GUIVideoFiles.PlayMovieFromPlayList(Boolean askForResumeMovie, Int32 iMovieIndex, Boolean requestPin)
en MediaPortal.GUI.Video.GUIVideoFiles.OnClick(Int32 iItem)
en Common.GUIPlugins.WindowPluginBase.OnClicked(Int32 controlId, GUIControl control, ActionType actionType)
en MediaPortal.GUI.Video.GUIVideoBaseWindow.OnClicked(Int32 controlId, GUIControl control, ActionType actionType)
en MediaPortal.GUI.Library.GUIWindow.OnMessage(GUIMessage message)

Can you please check it out? Thanks in advance.
 

RoChess

Extension Developer
  • Premium Supporter
  • March 10, 2006
    4,418
    1,883
    Country flag
    I am in no position to fix it, just another user helping others. That does give me insights into a lot of common issues, and codecs tend to always pop up on occasion. Enabling the traybar icons on LAV splitter, audio, and video codecs can assist in debugging, especially if you use MediaPortal in windowed mode. Verifying the MediaInfo DLL file is up to date can also fix many issues.

    MediaPortal bundles the current versions of LAV and MediaInfo at the time of release, but those projects are constantly updated.

    MP-TVSeries, and Moving-Pictures pass playback control to MediaPortal, so if you actually see LAV load any traybar icon, at that point you need to relay all your logs to the MediaPortal team. It helps to then first reproduce the problem in the MyVideos plugin of MediaPortal, because it will make it much easier for the MediaPortal development team to narrow down the issue.

    If the media file plays fine in MyVideos, but still crashes in a plugin such as MP-TVSeries then you are at the right place.
     

    ozn

    Portal Member
    June 4, 2008
    19
    0
    Country flag
    Thank for your suppor @RoChess.

    There are some more logs

    Can you please check it out? Thanks in advance.
     
    Last edited by a moderator:

    Vasilich

    Test Group
  • Team MediaPortal
  • August 30, 2009
    3,394
    1,170
    Germany, Mayence
    Home Country
    Russian Federation Russian Federation
    Country flag
    do not try to use VMR9 on Windows 10 - it won't end good.
    I don't see any crash from MP - all logs show clean exit.
    I see one exception when using moving pictures - as already said, try to identify plugin that causes troubles (i would start with MyVideo), and after crash collect logs and post in appropriate thread, mentioning exact date and time when the crash happened.

    Moreover:
    [2016-01-10 21:41:53,895] [Error ] [1 ] [ERROR] - IntegrityCheck: the C:\ProgramData\Team MediaPortal\MediaPortal\Database\VideoDatabaseV5.db3 is corrupt.
    so please check your video database.
     

    ozn

    Portal Member
    June 4, 2008
    19
    0
    Country flag
    Good evening Vasilich,

    I have always uses EVR but for testing purpouse I used VMR9 so the logs ar for that reason. I don't really use My videos pugins, only for testing as rochess suggest, but I fixed that issue on corrupt database a week ago but that is the database for MyVideos plugin not MovinPictures (that actually uses "movingpictures.db3").

    I have also installed Mediaportal on a new computer and the same thing happens with that video files, and some other that cause same issue. Can you please download from mega from the link show in my first case and check if it play properly via MediaPortal (as I said file works on vlc, WM player,etc..)?

    Error file >> https://mega.nz/#!vJkTDIxJ!IUH-K1QTGlD-kkXBz2iFDyfsVNzfavzI9on4u8jOstw
    Fixed file (recompress by avirecomp) >> https://mega.nz/#!7BtG1CjJ!7GuAlp70_NNkfI5nyOuDF82M6F7JrUCmZVgl2yg2ciQ

    It fails to me in two different computer, one with my ever used installation, and the other with a fresh install.

    Onces I play video, by movin-picutres, tv-series or myvideos plugin, with all ways, the issue is the same, MP get stucks and I need to forced close by alt+f4. The only error I see for the time y play the videos is next one i mention before.

    I also noticed that today logs has not been uploaded properly, I have attached right now.

    [2016-01-21 10:25:38,578] [Error ] [MPMain ] [ERROR] - OnMessage exceptionystem.NullReferenceException: Referencia a objeto no establecida como instancia de un objeto.
    en MediaPortal.Player.VideoPlayerVMR7.AudioLanguage(Int32 iStream)
    en MediaPortal.Player.VideoPlayerVMR7.SelectAudioLanguage()
    en MediaPortal.Player.VideoPlayerVMR7.Play(String strFile)
    en MediaPortal.Player.g_Player.Play(String strFile, MediaType type, TextReader chapters, Boolean fromPictures, Int32 title, Boolean forcePlay, Boolean fromExtTS)
    en MediaPortal.Playlists.PlayListPlayer.FakePlayer.MediaPortal.Playlists.PlayListPlayer.IPlayer.Play(String strFile, MediaType type)
    en MediaPortal.Playlists.PlayListPlayer.Play(Int32 iSong, Boolean setFullScreenVideo)
    en MediaPortal.Playlists.PlayListPlayer.PlayNext(Boolean setFullScreenVideo)
    en MediaPortal.GUI.Video.GUIVideoFiles.PlayMovieFromPlayList(Boolean askForResumeMovie, Int32 iMovieIndex, Boolean requestPin)
    en MediaPortal.GUI.Video.GUIVideoFiles.OnClick(Int32 iItem)
    en Common.GUIPlugins.WindowPluginBase.OnClicked(Int32 controlId, GUIControl control, ActionType actionType)
    en MediaPortal.GUI.Video.GUIVideoBaseWindow.OnClicked(Int32 controlId, GUIControl control, ActionType actionType)
    en MediaPortal.GUI.Library.GUIWindow.OnMessage(GUIMessage message)

    Thanks for your assistance again.
     

    Users who are viewing this thread

    Similar threads

    I really think this site should be taken out as it is not working, but I'm still hoping it's going to work one day. In a browser this site isn't working either, so it's not onlinevideos related (the crashing is though). A while ago I did search for this site, and found it (vaguely remember it was Italian), but can't find it right...
    I really think this site should be taken out as it is not working, but I'm still hoping it's going to work one day. In a browser...
    using mp1.12 and latest online videos, when I try to access music television I get the categories menu selec a category, then mp...
    Replies
    1
    Views
    1K
    Do I even need this? just reading up it looks like it's an apple service, I don't have any apple devices. Can I just delete the plugin or does MPExtended need it?
    Do I even need this? just reading up it looks like it's an apple service, I don't have any apple devices. Can I just delete the...
    I'm having an issue where Mediaportal will crash at the end of a track, I can play one, entire mp3 before this occurs. I can then...
    Replies
    2
    Views
    895
    This issue seems have been rectified as all the previously unavailable videos are now watchable.
    This issue seems have been rectified as all the previously unavailable videos are now watchable.
    Hi all If this has been covered elsewhere, sorry I searched, please point me to the right place :) I saw a lot of posts about...
    Replies
    6
    Views
    2K
    Hallo! Ich muss den Thread hier mal auspacken, weil mich jetzt das selbe Problem mit der aktuellen MP1 Version plagt. Hab alle Codecs auf das Neuste was ging aktualisiert und die Codec Einstellung wie im wiki vorgenommen. Alle Videoformate lassen sich bis auf .mp4 super abspielen. Über VLC laufen die Videos auch ohne Probleme. Wenn...
    Hallo! Ich muss den Thread hier mal auspacken, weil mich jetzt das selbe Problem mit der aktuellen MP1 Version plagt. Hab alle...
    Hallo, bei der Wiedergabe von einige wenige MP4 Dateien bleibt MP 1.7.0 und 1.8.0 bei mir hängen. Es erscheint einfach kein Video...
    Replies
    2
    Views
    2K
    Yes. I do use wasapi for MyMusic, as I've got some dts audio albums. Same issue.
    Yes. I do use wasapi for MyMusic, as I've got some dts audio albums. Same issue.
    Jira issue - https://issues.team-mediaportal.com/browse/MP1-4134 MediaPortal Version: 1.4.0 Description Quite easy to explain...
    Replies
    36
    Views
    6K
    Top Bottom