Mediaportal no longer starting after computer lockup. Please help.

markus_g

Portal Pro
August 12, 2006
104
28
Country flag
Hello,
I was watching a video file and the computer locked up and needed a hard reboot. Now Mediaportal no longer starts and comes up with Mediaportal has stopped working. I have used Watchdog to gather the log files.

It appears to me that the video database may have corrupted itself.

Regards,

Markus.
 
Last edited:

HTPCSourcer

MP2 Product Manager
  • Team MediaPortal
  • Administrator
  • May 16, 2008
    11,286
    113
    Country flag
    Hi Markus,

    It looks as if your video database got corrupted.

    [2014-11-12 20:44:19,889] [Log ] [MPMain ] [INFO ] - opening video database
    [2014-11-12 20:44:19,920] [Log ] [MPMain ] [INFO ] - SQLiteClient: Closing database: VideoDatabaseV5.db3

    Try to replace VideoDatabaseV5.db3 by the backup copy from the backup directory in the same path.
     

    markus_g

    Portal Pro
    August 12, 2006
    104
    28
    Country flag
    Hi Markus,

    It looks as if your video database got corrupted.

    [2014-11-12 20:44:19,889] [Log ] [MPMain ] [INFO ] - opening video database
    [2014-11-12 20:44:19,920] [Log ] [MPMain ] [INFO ] - SQLiteClient: Closing database: VideoDatabaseV5.db3

    Try to replace VideoDatabaseV5.db3 by the backup copy from the backup directory in the same path.
    Thankyou.
    I couldn't find any backup directories but did have one manual backup from 6 months ago and this one works.

    Should the backup directory be in C:\ProgramData\Team MediaPortal\MediaPortal

    Regards,

    Markus
     

    HTPCSourcer

    MP2 Product Manager
  • Team MediaPortal
  • Administrator
  • May 16, 2008
    11,286
    113
    Country flag
    Should the backup directory be in C:\ProgramData\Team MediaPortal\MediaPortal
    Right. There you will see a path "database" and within "database" there should be a "Backup".
     
    Last edited:

    HTPCSourcer

    MP2 Product Manager
  • Team MediaPortal
  • Administrator
  • May 16, 2008
    11,286
    113
    Country flag
    Maybe I am wrong. I will take a look at my own install to see where backups are stored.
     

    HTPCSourcer

    MP2 Product Manager
  • Team MediaPortal
  • Administrator
  • May 16, 2008
    11,286
    113
    Country flag
    Actually no regular backups are being made by MePo as there is no such functionality built in. What you may see is some additionally installed plugins such as Moving Picture and TV Series doing their own backup at each start of MediaPortal.

    It's up to you whether you want to run appropriate backups of your system - something you may want to do anyway. The link above describes a backup of the current installation prior to updating/installing a new version. And only then. This is simply way to allow you to roll back to your previous installation in case something goes wrong or you don't like the updated version. It is not meant to be a system backup.
     

    regeszter

    Retired Team Member
  • Premium Supporter
  • October 29, 2005
    5,335
    113
    Hi,

    Can you try upgrade to 1.10 Pre Release? I have added a database integrity check to see if there is a db corruption.
     
    Top Bottom